Bug 4929 - Direct (no proxy or registrar) SIP URI dialing
: Direct (no proxy or registrar) SIP URI dialing
Status: RESOLVED WONTFIX
Product: Chat & Call & SMS
SIP
: 5.0-beta2
: All Maemo
: Low enhancement with 18 votes (vote)
: ---
Assigned To: rtcomm@maemo.org
: sip-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-08-16 21:18 UTC by Lucas Maneos
Modified: 2012-03-24 11:44 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Lucas Maneos (reporter) 2009-08-16 21:18:36 UTC
SOFTWARE VERSION:
5.2008.43-7

STEPS TO REPRODUCE THE PROBLEM:
1a. Start with no SIP accounts configured, or any configured ones disabled.
2a. Start Internet call application.

or 

1b. Start with no SIP accounts configured, or any configured ones disabled.
2b. Start browser.
3b. Open <https://bugs.maemo.org/attachment.cgi?id=1255>.
4b. Tap the sip: link.

EXPECTED OUTCOME:
a. Option to enter a SIP URI to be dialed.

or

b. Internet call application starts and attempts to dial the SIP URI using
NAPTR/SRV/A DNS lookups to locate the appropriate server.

ACTUAL OUTCOME:
"No accounts set up".

REPRODUCIBILITY:
Always.

OTHER COMMENTS:
This would be useful since many SIP services do not allow outgoing calls to
third-party domains.

One question is what to put in the From: header in such a case.  An "Anonymous"
(RFC3261 8.1.1.3 & 20.20) header would seem appropriate.
Comment 1 Andre Klapper maemo.org 2009-08-17 14:46:51 UTC
True... Clicking the "sip:" link in a current Fremantle says
"Unable to open. No accounts."
Comment 2 Andre Klapper maemo.org 2012-03-24 11:44:35 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )