Bug 4916 - Re-enable reset and/or reset-and-clear in osso-xterm
: Re-enable reset and/or reset-and-clear in osso-xterm
Status: VERIFIED FIXED
Product: Utilities
X Terminal
: 5.0/(1.2009.42-11)
: All Maemo
: Low enhancement with 3 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: osso-xterm-bugs
:
: community-diablo, patch
:
: 3929
  Show dependency tree
 
Reported: 2009-08-13 10:56 UTC by luarvique
Modified: 2010-01-14 12:25 UTC (History)
5 users (show)

See Also:


Attachments
add reset/reset_and_clear functions to the menu (3.59 KB, patch)
2009-08-13 13:51 UTC, Lucas Maneos
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description luarvique (reporter) 2009-08-13 10:56:41 UTC
SOFTWARE VERSION:
5.0-beta2 and all later versions

STEPS TO REPRODUCE THE PROBLEM:
Open XTerm, search for options described below.

EXPECTED OUTCOME:
No options present

ACTUAL OUTCOME:
There should be options to toggle scroll bar, reset and clear terminal, and
reverse colors.

REPRODUCIBILITY:
always

OTHER COMMENTS:
Patches for OS2008 XTerm available here:

http://talk.maemo.org/showthread.php?t=23291&page=2
Comment 1 Lucas Maneos 2009-08-13 13:41:06 UTC
(In reply to comment #0)
> There should be options to toggle scroll bar, reset and clear terminal, and
> reverse colors.

The scroll bar feature would be INVALID for Fremantle, and it's probably better
to split the other two into separate bugs.   Keeping this one for reset.

I can't find a patch for the reverse function apart from a partial one in
<http://pastebin.com/f64c43915>, but please feel free to open a new enhancement
request if you can locate it.
Comment 2 Lucas Maneos 2009-08-13 13:51:36 UTC
Created an attachment (id=1312) [details]
add reset/reset_and_clear functions to the menu

A starting point for adding reset functions back, against 0.14.mh24 (I couldn't
build trunk, sorry).

My hildon-fu is very weak, so any criticism is welcome.  One thing that's
definitely wrong with it is that the button labels are not localised.

Other than that it seems to work fine here.  To test:
1. Start osso-xterm.
2. Run "head /bin/sh" to corrupt the terminal.
3. Select either Reset or Reset and clear from the menu to recover.
Comment 3 Faheem Pervez maemo.org 2009-08-13 13:54:23 UTC
(In reply to comment #1)
> I can't find a patch for the reverse function apart from a partial one in
> <http://pastebin.com/f64c43915>, but please feel free to open a new enhancement
> request if you can locate it.
> 

That should be enough. Ironically, a lot of these features actually are in
osso-xterm but options to use them are taken out (as is the case with the reset
and reset-and-clear features). I'm using scratchbox over SSH and I can tell you
that reset(-and-clear) are definitely neeeded.
Comment 4 Gabriel Schulhof nokia 2009-09-28 15:11:53 UTC
Fixed as of osso-xterm-0.14.mh28:
https://garage.maemo.org/svn/osso-xterm/osso-xterm/tags/0.14.mh28
Comment 5 Lucas Maneos 2009-10-12 20:39:01 UTC
*** Bug 5328 has been marked as a duplicate of this bug. ***
Comment 6 Lucas Maneos 2009-10-22 07:57:49 UTC
Marking patches of interest to Diablo (Maemo4) community updates, please excuse
the noise.
Comment 7 Andre Klapper maemo.org 2009-11-09 19:55:10 UTC
Internal version 45-14 that I am running here definitely offers the option to
Reset as it's osso-xterm 0.14.mh29. Don't know if the fix wa already included
in 1.2009.41-10.
Comment 8 luarvique (reporter) 2009-11-09 19:56:33 UTC
(In reply to comment #7)
> Internal version 45-14 that I am running here definitely offers the option to
> Reset as it's osso-xterm 0.14.mh29. Don't know if the fix wa already included
> in 1.2009.41-10.
Definitely was not.
Comment 9 Andre Klapper maemo.org 2010-01-14 12:25:32 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.