Bug 4914 - Add context menu to XTerm (for URLs, etc)
: Add context menu to XTerm (for URLs, etc)
Status: RESOLVED WONTFIX
Product: Utilities
X Terminal
: 5.0/(1.2009.41-10)
: All Maemo
: Low enhancement with 7 votes (vote)
: ---
Assigned To: unassigned
: osso-xterm-bugs
:
: community-diablo, patch
:
: 3929
  Show dependency tree
 
Reported: 2009-08-13 10:52 UTC by luarvique
Modified: 2012-03-24 11:46 UTC (History)
6 users (show)

See Also:


Attachments
Patch by Faheem (7.98 KB, patch)
2009-08-13 13:54 UTC, Andre Klapper
Details
URL (20.48 KB, image/png)
2009-12-08 23:27 UTC, Bartosz Taudul
Details
After tapping the URL (open, copy) (31.65 KB, image/png)
2009-12-08 23:27 UTC, Bartosz Taudul
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description luarvique (reporter) 2009-08-13 10:52:45 UTC
SOFTWARE VERSION:
5.0-beta2 and later versions

STEPS TO REPRODUCE THE PROBLEM:
Open XTerm, click on a URL or text.

EXPECTED OUTCOME:
A context menu should appear with options to open URL or copy it to clipboard.

ACTUAL OUTCOME:
No context menu.

REPRODUCIBILITY:
always

OTHER COMMENTS:
Patch for OS2008 XTerm available here:

http://talk.maemo.org/showthread.php?t=23291
Comment 1 Faheem Pervez maemo.org 2009-08-13 11:56:44 UTC
(In reply to comment #0)
> Patch for OS2008 XTerm available here:
> 
> http://talk.maemo.org/showthread.php?t=23291
> 

The full source got lost when my host got shutdown but enabling this was the
simple matter of:
Removing the "#if 0" from the comment "Copy & paste didn't work quite well from
popup menu and there was only one " in the file terminal-window.c, uncommenting
"GtkWidget      *popup;" and and adding "    <menuitem action='open-url'/>" to
the "popup-menu" UI description.
Comment 2 Andre Klapper maemo.org 2009-08-13 13:54:10 UTC
Created an attachment (id=1313) [details]
Patch by Faheem

Attaching Faheem's patch here. See comment 1 for changes.
Comment 3 luarvique (reporter) 2009-10-12 14:51:31 UTC
Still missing in 1.2009.41-10.
Comment 4 Lucas Maneos 2009-10-22 07:57:47 UTC
Marking patches of interest to Diablo (Maemo4) community updates, please excuse
the noise.
Comment 5 Bartosz Taudul 2009-12-08 23:26:27 UTC
Works for me in 1.2009.42-11.
Comment 6 Bartosz Taudul 2009-12-08 23:27:12 UTC
Created an attachment (id=1699) [details]
URL
Comment 7 Bartosz Taudul 2009-12-08 23:27:50 UTC
Created an attachment (id=1700) [details]
After tapping the URL (open, copy)
Comment 8 Andre Klapper maemo.org 2012-03-24 11:46:19 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )