Bug 4905 - IRC Chat Join messages ignore case sensitivity at start of nicknames
: IRC Chat Join messages ignore case sensitivity at start of nicknames
Status: RESOLVED WONTFIX
Product: Chat & Call & SMS
Messaging
: 4.1.3 (5.2008.43-7)
: All Linux
: Low minor (vote)
: ---
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
: 5139
:
  Show dependency tree
 
Reported: 2009-08-12 02:55 UTC by Jason Carter
Modified: 2010-03-11 16:01 UTC (History)
1 user (show)

See Also:


Attachments
GAN800 joins, tablet view (113.23 KB, image/png)
2009-08-12 03:04 UTC, Jason Carter
Details
GAN800 joins, PC view (22.04 KB, image/png)
2009-08-12 03:05 UTC, Jason Carter
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Jason Carter (reporter) 2009-08-12 02:55:43 UTC
SOFTWARE VERSION: 5.2008.43-7
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:
1) Install RTCOMM.
2) Add an account for any IRC server. I used the default (irc.freenode.net)
3) Have the IRC account go online.
4) Join a chatroom that is preferably busy (I joined #maemo)
5) Join the same chatroom and server on a PC or any other IRC client (even
XChat on the tablet)
6) Watch for people to join (or use yet another client to simulate joining)

EXPECTED OUTCOME: IRC nicks in all join messages should properly match up with
their actual chosen IRC nick.

ACTUAL OUTCOME: If the user's IRC nick begins with a capital letter, the IRC
plugin will report any string of capital letters at the start of a IRC nick in
lowercase when they are joining. For example, GAN800 joined the room. On my PC
client, it will show "GAN800 joined" but the tablet's IRC plugin will report
"gan800". When "MaseN810" joined, it said "maseN810" joined the room.

REPRODUCIBILITY: Always
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED: RTCOMM

OTHER COMMENTS: This bug appears to only affect channel join messages. All
channel part messages come up fine. Channel messages all work fine as well
(except for those mentioned in bug #4900).

I know there is almost no chance of this being fixed since the plugin will not
be returning in Fremantle.

Screenshots added soon.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2)
Gecko/20090804 Shiretoko/3.5.2
Comment 1 Jason Carter (reporter) 2009-08-12 03:04:20 UTC
Created an attachment (id=1304) [details]
GAN800 joins, tablet view
Comment 2 Jason Carter (reporter) 2009-08-12 03:05:19 UTC
Created an attachment (id=1305) [details]
GAN800 joins, PC view
Comment 3 Jason Carter (reporter) 2009-08-12 15:32:19 UTC
Bug #4900 may be related (or have the same trigger).
Comment 4 Andre Klapper maemo.org 2010-03-11 16:01:15 UTC
This is a WONTFIX for Maemo4.
If bug 5139 for Maemo5 gets solved in the future and if the problem reporterd
here will be still an issue in Maemo5 after fixing bug 5139, please update this
report (steps, Version field) and reopen it. Thanks.