Bug 4845 - (int-130496) Remove Scratchboxism in libosso packaging
(int-130496)
: Remove Scratchboxism in libosso packaging
Status: RESOLVED FIXED
Product: Desktop platform
libosso
: 5.0/(3.2010.02-8)
: All Maemo
: Low normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: Kimmo Hämäläinen
: libosso-bugs
:
: patch
:
:
  Show dependency tree
 
Reported: 2009-07-29 00:00 UTC by Carsten Munk
Modified: 2010-03-15 20:53 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Carsten Munk (reporter) maemo.org 2009-07-29 00:00:26 UTC
SOFTWARE VERSION:
5.0-beta2 SDK

STEPS TO REPRODUCE THE PROBLEM:

Building libosso outside Scratchbox (Debian/Ubuntu) in typical build
environment (build-essentials and dependancies installed)

EXPECTED OUTCOME:

Ability to build libosso

ACTUAL OUTCOME:

Fails to build due to assumption that automake, autoconf and libtool is
installed in typical build environments, this is a scratchboxism (which
Scratchbox has), but Debian, Ubuntu and others do not.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

Fixing this is a matter of adding ', autoconf, automake, libtool' to
Build-Depends in libosso packaging. Adding this fix will remove the one delta
we have to maintain in Mer and would allow us and others to directly use the
libosso packaging outside of Maemo without modification.

Use of libtool, autoconf and automake can be seen in 'autogen.sh' and hence
package should build-depend on them as these tools are not part of a typical
build environment.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.11)
Gecko/2009060308 Ubuntu/9.04 (jaunty) Firefox/3.0.11
Comment 1 Kimmo Hämäläinen nokia 2009-07-29 14:07:36 UTC
any patch?
Comment 2 Carsten Munk (reporter) maemo.org 2009-07-29 14:31:49 UTC
(In reply to comment #1)
> any patch?
> 

As stated in other comments, it is a matter of adding ', autoconf, automake,
libtool' to the Build-Depends: line in debian/control of the package - so a
patch may be a bit overkill. :)

But since you did ask, yes, we do have one: 

http://gitorious.org/mer/libosso/commit/e0b6a63450d9706a6016a49dd11af27b64371e04
for graphical patch, 

http://gitorious.org/mer/libosso/commit/e0b6a63450d9706a6016a49dd11af27b64371e04.patch
for patch.
Comment 3 Kimmo Hämäläinen nokia 2009-07-29 14:48:48 UTC
ah, yes, I didn't read it properly, sorry.
Comment 4 Andre Klapper maemo.org 2009-07-29 15:22:42 UTC
Imported...
Comment 5 Kimmo Hämäläinen nokia 2010-02-18 14:46:31 UTC
fixed in git master now, no idea when it can be included to the produce (as the
bug is not hurting enough)
Comment 6 Andre Klapper maemo.org 2010-03-15 20:53:31 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).