Bug 4766 - (int-127983) freedesktop.org icon naming spec not respected with regard to icon contexts
(int-127983)
: freedesktop.org icon naming spec not respected with regard to icon contexts
Status: RESOLVED FIXED
Product: Desktop platform
Themes
: 5.0-beta2
: All Linux
: Low normal (vote)
: 5.0 (1.2009.41-10)
Assigned To: unassigned
: themes-bugs
: http://standards.freedesktop.org/icon...
:
:
:
  Show dependency tree
 
Reported: 2009-07-07 14:13 UTC by Christian Persch (GNOME)
Modified: 2009-08-28 16:00 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Christian Persch (GNOME) (reporter) 2009-07-07 14:13:14 UTC
[This is with fremantle beta SDK.]

Steps to reproduce:
Install private themed icons into $(pkgdatadir)/icons/hicolor/$size/actions/,
and use gtk_icon_theme_append_search_path() to append "$(pkgdatadir)/icons" to
the icon theme search path.

Expected results:
The application finds the icons.

Actual results:
The icons are not found; the "missing-image" icon is displayed instead.
stracing the application reveals that it never even looks in
$(pkgdatadir)/icons/hicolor/$size/actions for the icons; only
$(pkgdatadir)/icons/hicolor/$size/hildon is searched.

This is contrary to the icon naming spec
[http://standards.freedesktop.org/icon-naming-spec/icon-naming-spec-latest.html#context]
which has "actions" in its list of default contexts, and yet another problem to
fix when porting applications from Gnome to hildon.

The cause of this problem seems to be that /usr/share/icons/hicolor/index.theme
does not list the "actions" (etc.) directories in its Directories key.
Comment 1 Andre Klapper maemo.org 2009-07-13 17:32:47 UTC
Hi Christian,
can you provide a small testcase?

(Added the ticket to http://wiki.maemo.org/Mainstream_Linux_Alignment .)
Comment 2 Christian Persch (GNOME) (reporter) 2009-07-13 19:33:46 UTC
I'm sorry I don't have the time right now to create a standalone testcase, but
you can see the problem in aisleriot from git://git.gnome.org/gnome-games and
building revision 849d7850fde0b9b11b856ef1a8788b05b427dcad (which is just
before 0cda45c755bf1eae63acecc80714f3c05662e7fb where I added a work-around for
this problem). Configuring with "--with-platform=hildon
--with-platform-variant=maemo5 --enable-games=aisleriot --disable-tests" should
work in scratchbox.

The symptom of the problem is the "missing-image" icon placeholder in the
toolbar, and a message on console about gtk being unable to find the
"card-deal" icon in the theme.
Comment 3 Andre Klapper maemo.org 2009-08-28 16:00:18 UTC
This issue has been FIXED in the internal Fremantle version.