Bug 474 - Implement SCO support for Bluetooth headsets
: Implement SCO support for Bluetooth headsets
Status: CLOSED FIXED
Product: Connectivity
Bluetooth
: 1.0
: All Maemo
: Medium enhancement with 19 votes (vote)
: ---
Assigned To: unassigned
: bluetooth-bugs
:
: enhancement-it2006, ITOS2007HE-garage
:
:
  Show dependency tree
 
Reported: 2006-05-15 03:33 UTC by David Woodhouse
Modified: 2007-11-28 10:57 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description David Woodhouse (reporter) 2006-05-15 03:33:26 UTC
I'm sure this has been discussed elsewhere but I can't find a coherent answer,
so I'll open this bug for it. I had a vague recollection that SCO support was
supposed to have been implemented by now. Is it planned? When?
Comment 1 Maemo QA (deprecated) 2006-05-15 12:41:09 UTC
David, have you tried with a newer release than 2005.45, against which you've
reported this bug?
Comment 2 David Woodhouse (reporter) 2006-05-15 13:46:09 UTC
I haven't, to be honest. I've seen people talking about how VoIP will be
available 'some day' but haven't actually checked if SCO support (which is
required for Bluetooth audio) has been implemented in the latest kernel.

Are you suggesting that the latest release _does_ support it, and the reason
Google failed me last night was because it all just works now and hence nobody's
talking about it any more?
Comment 3 Maemo QA (deprecated) 2006-05-15 14:17:31 UTC
(In reply to comment #2)
> Are you suggesting that the latest release _does_ support it, and the reason
> Google failed me last night was because it all just works now and hence nobody's
> talking about it any more?

No, I have no such information, sorry. However, you reported the bug against a
very old release, that's the reason for the question.

I tried to contact the upstream maintainer for a comment on this issue, but with
no luck. I'll let you know when I get more info. Marking as enhancement for now.
Comment 4 Maemo QA (deprecated) 2006-08-03 16:19:56 UTC
Will be handled as a feature request. Thanks for your feedback!
Comment 5 Mike Lococo 2007-01-27 19:44:13 UTC
Changing summary to make explicit that this bug affects bluetooth headsets.
Comment 6 Mike Lococo 2007-01-27 19:45:04 UTC
*** Bug 668 has been marked as a duplicate of this bug. ***
Comment 7 Quim Gil nokia 2007-04-27 09:22:16 UTC
Assigning this feature request to me, since it's one of the currently most
voted. I'm not the guy to solve the problem but I'll try to figure out the
current status and plans.
Comment 8 Quim Gil nokia 2007-05-05 10:58:20 UTC
Good news: the release of this requested feature is in our plans. In fact we
are working on this already.

Not that good news: it will take still a while to have this functionality
released. We can't compromise to dates but, don't worry, we are not talking
about another entire year to wait.

Thanks for the patience. In the meantime I'll leave this bug sleeping.
Comment 9 Laurent GUERBY 2007-05-05 15:50:48 UTC
Great news again!

I'll postpone burrying my wires for a while :).
Comment 10 Laurent GUERBY 2007-07-08 13:54:22 UTC
I tried to pair a bluetooth headset with 4.2007.26-8 but still no luck, after
all it wasn't announced yet :).
Comment 11 Quim Gil nokia 2007-07-09 09:30:39 UTC
What couldn't be said on May but can be said now is that this feature is
planned  for the Chinook release.  :)  

Don't take is at granted but this is the current plan.

Also to say it explicitely: we want to see one day BT headsets being used at
full compliance and possibilities. You have noticed that Nokia in general
doesn't like cables and wires. ;) Why the whole functionality is not already in
place is a matter of planning and resources, but not that we don't want to have
this functionality.
Comment 12 feig 2007-08-27 21:31:35 UTC
The latest Bluez release includes A2DP and SCO support.

http://wiki.bluez.org/wiki/Audio
http://www.bluez.org/news.html

I think that if Nokia is going to do something with this, they should use
what's already included with Bluez.
Comment 13 Johan Hedberg nokia 2007-08-28 11:15:11 UTC
(In reply to comment #12)
> The latest Bluez release includes A2DP and SCO support.
> 
> http://wiki.bluez.org/wiki/Audio
> http://www.bluez.org/news.html
> 
> I think that if Nokia is going to do something with this, they should use
> what's already included with Bluez.

Not only will Nokia use it, but the Audio support in BlueZ has been for the
most part created or funded (through INdT) by Nokia. You'll see HSP support
very soon and hopefully A2DP a little later (with some hacks you can get it
already now workig, e.g. I tested A2DP successfully on N800 HW yesterday with
an unmodified upstream bluez-utils package).
Comment 15 Laurent GUERBY 2007-11-28 00:47:30 UTC
Tested my Logitech Mobile Freedom Bluetooth Headset with
RX-34_2008SE_1.2007.44-4 on my N800 and both sound/music listening and
recording with maemo recorder worked through the headset after pairing, with a
nice bluetooth sound icon on Home.

Thanks to the great work!

I think you can close this bugzilla.
Comment 16 Michael Wiktowy 2007-11-28 01:39:32 UTC
Yup ... I have to say that SCO works really well now with my Jabra 8010.

If A2DP was working and it would switch to SCO when I get a VoIP call, I would
be in bluetooth headset nirvana.

But A2DP support is a different bug (bug 667) so I would vote for closing this
one also.

Thanks.
Comment 17 Jake Kunnari 2007-11-28 10:56:54 UTC
Fix and verified by couple active users.
Comment 18 Jake Kunnari 2007-11-28 10:57:08 UTC
Closing