maemo.org Bugzilla – Bug 4734
lsb-core conflicts with python >= 2.6, blocking PyMaemo from upgrading to 2.6
Last modified: 2010-08-12 16:46:04 UTC
You need to
before you can comment on or make changes to this bug.
SOFTWARE VERSION: Maemo 5 Beta SDK (Fremantle)
Fremantle X86 target freshly installed following SDK installation instructions.
Only maemo-sdk-runtime and nokia-binaries installed
STEPS TO REPRODUCE THE PROBLEM:
sbox> apt-cache show lsb-core | grep Conflicts
Conflicts: python (>= 2.6), lsb (<< 2.0-2)
It should not conflict with Python 2.6
Currently conflicts with Python 2.6
EXTRA SOFTWARE INSTALLED: maemo-sdk-runtime, nokia-binaries
lsb-core is a dependency of many core packages in the SDK, e.g.
maemo-core-runtime (through lsb-base) and x11-common. This way, it cannot be
removed from the SDK.
The current version in Fremantle Beta SDK conflicts with Python (>= 2.6), which
means that the PyMaemo cannot ship a release containing Python 2.6, unless the
"lsb" package is upgraded to a version that does not have this conflict.
Unfortunately the latest version in Debian still has such conflict (Python 2.6
in Debian is still experimental), but the latest stable version in Ubuntu is
The current situation is a blocker for Python 2.6 in PyMaemo, because PyMaemo
packages will not be installable on the SDK otherwise.
..and we have quite some 3rd part packages depending on pymaemo. --> critical
Please note that, currently, PyMaemo in Fremantle is using python2.5, which is
not affected by this bug. On the other hand, we are discussing (see
possible upgrade to python2.6 (we even have the changes in SVN already), but we
just found out this issue that might for now block us from upgrading to
Ah, okay. Thanks for the clarification.
It seems the lsb-core version in Fremantle beta 2 (3.2-15osso2) is particularly
old. Newer versions (e.g. 4.0-0ubuntu0.8.04.1 from Ubuntu) do not have this
Anyway, I think it is too late to migrate PyMaemo to 2.6 for Fremantle,
assuming this is the latest beta before the final release. It would just break
things for 3rd party Python applications that are already in Fremantle
As reported by Thomas Tanner (and slightly verified by me), although the
current binary lsb-core package still conflicts with Python (>= 2.6), any SDK
packages (at least on latest fremantle release) seem to not depend anymore on
Instead, only lsb-base and lsb-release seem to be used, which do not conflict
with python 2.6 at all. Some data (from my SDK installation):
> dpkg -l 'maemo-sdk*' | grep ii
ii maemo-sdk-debug 5.0+0m5 Meta package for Maemo debug
ii maemo-sdk-dev 5.0+0m5 Meta package for Maemo devel
ii maemo-sdk-runtime 5.0+0m5 Meta package for the Maemo runtime
> dpkg -l 'lsb*' | grep ii
ii lsb-base 3.2-15osso2 Linux Standard Base 3.2 init script function
ii lsb-release 3.2-15osso2 Linux Standard Base version reporting utilit
At least for Harmattan this has been FIXED.
No idea if there are plans for Maemo5 though.
(Adding Bruno to CC: who is one of current PyMaemo developers)
I believe it was agreed by the PyMaemo team that the bug will not be fixed for
Maemo 5. As you mentioned, on Maemo 6 it was already fixed.
Bruno, can you check if I can close this bug as FIXED?
(In reply to comment #7)
> I believe it was agreed by the PyMaemo team that the bug will not be fixed for
> Maemo 5. As you mentioned, on Maemo 6 it was already fixed.
> Bruno, can you check if I can close this bug as FIXED?
We indeed do not have plans to fix it on Maemo5; and yes, you can mark it
Marking as FIXED as suggested.