Bug 4729 - hildon-input-method svn: Can't build in public SDK
: hildon-input-method svn: Can't build in public SDK
Status: CLOSED FIXED
Product: Desktop platform
Input method framework
: 5.0-beta2
: All Linux
: Low normal (vote)
: 5.0 (1.2009.41-10)
Assigned To: Murray Cumming
: input-method-framework-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-06-23 19:04 UTC by Murray Cumming
Modified: 2010-02-25 15:22 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Murray Cumming (reporter) 2009-06-23 19:04:29 UTC
Trying to build the hildon-input-method module from svn, I get this build
error. I guess that something in the configure is causing the (normally simple)
pkg-config check to fail and give a misleading error:

checking for GTK... configure: error: The pkg-config script could not be found
or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

Alternatively, you may set the environment variables GTK_CFLAGS
and GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To get pkg-config, see <http://pkg-config.freedesktop.org/>.
See `config.log' for more details.


Just to show that it's definitely there:
[sbox-maemo5sdk-i486: ~/fremantle] > which pkg-config
/scratchbox/tools/bin/pkg-config


I notice that this svn module has not had any changes recently. Is there a
newer version in an internal svn repository?
Comment 1 Murray Cumming (reporter) 2009-06-25 17:03:13 UTC
This is fixed in the internal svn version, now that I've found it.

I see no statement anywhere about why this has moved to a private svn
repository.
Comment 2 Andre Klapper maemo.org 2009-06-25 17:42:14 UTC
(In reply to comment #1)
> This is fixed in the internal svn version, now that I've found it.

Closing as FIXED in Fremantle. Kind of. At least the *current* svn will not
receive fixes.

There will be a public SDK update next month according to bug 4560 comment 5.
I've also asked Nokia to at least sync SVN with the public code in Fremantle
beta SDK.
Comment 3 Murray Cumming (reporter) 2009-06-25 18:10:16 UTC
Reopening because this is about building from svn, and until the public svn is
fixed this bug is not fixed. It could instead be closed by someone announcing
that the public svn repository is considered useless.
Comment 4 Andre Klapper maemo.org 2009-06-25 18:45:10 UTC
Quim, can you find out how to have Maemo SVN status officially commented?
Comment 5 Richard Sun (Nokia) 2009-07-22 22:51:21 UTC
the reason why stage SVN doesn't sync with internal one is because:
* a big refactoring happened, which leads doc out-of-date. -> it is just fixed. 
* no clear clue whether plugin can be open source. if feel to go, relevant
package needs to pattern/legal check, which causes delay.  --> unfortunately no
progress at all.

But code sync will be happened no later than next week. after that development
will continue on stage
Comment 6 Richard Sun (Nokia) 2009-07-27 16:39:33 UTC
Stage SVN has synced with internal SVN, And it will be up to date from now on.
Comment 7 Murray Cumming (reporter) 2009-07-27 18:02:56 UTC
(In reply to comment #6)
> Stage SVN has synced with internal SVN, And it will be up to date from now on. 

Will it be synced manually every now and then, or have you started working with
the public svn day-to-day?


I think you forgot to add the docs/ directory:

[sbox-FREMANTLE_X86: ~/fremantle/hildon-input-method] > ./autogen.sh
--prefix=/usr
+ libtoolize --automake
+ aclocal
/usr/share/aclocal/audiofile.m4:12: warning: underquoted definition of
AM_PATH_AUDIOFILE
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending%20aclocal
+ gtkdocize
+ autoconf
+ autoheader
+ automake --add-missing --foreign
configure.ac:132: required file `docs/Makefile.in' not found
Makefile.am:8: required directory ./docs does not exist
Comment 8 Richard Sun (Nokia) 2009-07-27 18:09:10 UTC
Opps, now docs are added. 

In Current case, stage will be synced once new tag is released. Later on, work
will move completely on Stage,
Comment 9 Murray Cumming (reporter) 2009-07-27 18:19:40 UTC
The build now fails like so:

hildon-im-ui.c:1109: error: expected declaration specifiers or '...' before
'HildonIMInputModeMessage'
hildon-im-ui.c: In function 'hildon_im_ui_process_input_mode_message':
hildon-im-ui.c:1120: error: 'msg' undeclared (first use in this function)
hildon-im-ui.c:1120: error: (Each undeclared identifier is reported only once
hildon-im-ui.c:1120: error: for each function it appears in.)
hildon-im-ui.c: In function 'hildon_im_ui_client_message_filter':
hildon-im-ui.c:1313: error: 'HILDON_IM_INPUT_MODE' undeclared (first use in
this function)
hildon-im-ui.c:1314: error: 'HILDON_IM_INPUT_MODE_FORMAT' undeclared (first use
in this function)
hildon-im-ui.c:1316: error: 'HildonIMInputModeMessage' undeclared (first use in
this function)
hildon-im-ui.c:1316: error: 'msg' undeclared (first use in this function)
hildon-im-ui.c:1316: error: expected expression before ')' token
hildon-im-ui.c:1317: error: too many arguments to function
'hildon_im_ui_process_input_mode_message'
make[2]: *** [hildon-im-ui.lo] Error 1
make[2]: Leaving directory `/home/murrayc/fremantle/hildon-input-method/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/murrayc/fremantle/hildon-input-method'


This is also suspicious, during configure:

checking for catalogs to be installed...  en_GB
./configure: line 22854: ./po/POTFILES.in: No such file or directory

I think you forgot to add the po/ directory.
Comment 10 Richard Sun (Nokia) 2009-07-28 12:59:27 UTC
(In reply to comment #9)
> The build now fails like so:
> 
> hildon-im-ui.c:1109: error: expected declaration specifiers or '...' before
> 'HildonIMInputModeMessage'
> hildon-im-ui.c: In function 'hildon_im_ui_process_input_mode_message':
> hildon-im-ui.c:1120: error: 'msg' undeclared (first use in this function)
> hildon-im-ui.c:1120: error: (Each undeclared identifier is reported only once
> hildon-im-ui.c:1120: error: for each function it appears in.)
> hildon-im-ui.c: In function 'hildon_im_ui_client_message_filter':
> hildon-im-ui.c:1313: error: 'HILDON_IM_INPUT_MODE' undeclared (first use in
> this function)
> hildon-im-ui.c:1314: error: 'HILDON_IM_INPUT_MODE_FORMAT' undeclared (first use
> in this function)
> hildon-im-ui.c:1316: error: 'HildonIMInputModeMessage' undeclared (first use in
> this function)
> hildon-im-ui.c:1316: error: 'msg' undeclared (first use in this function)
> hildon-im-ui.c:1316: error: expected expression before ')' token
> hildon-im-ui.c:1317: error: too many arguments to function
> 'hildon_im_ui_process_input_mode_message'
> make[2]: *** [hildon-im-ui.lo] Error 1
> make[2]: Leaving directory `/home/murrayc/fremantle/hildon-input-method/src'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/murrayc/fremantle/hildon-input-method'
> 

Did you installed latest gtk from trunk? 

> 
> This is also suspicious, during configure:
> 
> checking for catalogs to be installed...  en_GB
> ./configure: line 22854: ./po/POTFILES.in: No such file or directory
> 
> I think you forgot to add the po/ directory.
>

po directory is not necessary in configure. Can you try to build it from a
clean source code?

Although I am using internal mini-rootstrap to test, I tried clean build from
stage svn. Everything is fine for me.
Comment 11 Murray Cumming (reporter) 2009-07-28 13:45:22 UTC
(In reply to comment #10)
> > hildon-im-ui.c:1109: error: expected declaration specifiers or '...' before
> > 'HildonIMInputModeMessage'
> > hildon-im-ui.c: In function 'hildon_im_ui_process_input_mode_message':

> Did you installed latest gtk from trunk? 

No. Shouldn't it be enough with the version in the beta SDK?

Where is that svn (or git?) for gtk+? This seems to be old and unused now:
https://stage.maemo.org/viewcvs.cgi/projects/haf/trunk/gtk%2B/?root=maemo&pathrev=9626

> 
> > 
> > This is also suspicious, during configure:
> > 
> > checking for catalogs to be installed...  en_GB
> > ./configure: line 22854: ./po/POTFILES.in: No such file or directory
> > 
> > I think you forgot to add the po/ directory.
> >
> 
> po directory is not necessary in configure. Can you try to build it from a
> clean source code?
> 
> Although I am using internal mini-rootstrap to test, I tried clean build from
> stage svn. Everything is fine for me. 
>
Comment 12 Murray Cumming (reporter) 2009-07-28 13:53:52 UTC
(In reply to comment #11)
> > po directory is not necessary in configure.

Well, configure complains about it, presumably because you are using
AM_GLIB_GNU_GETTEXT (and you even mention a en_GB translation that would need
to be in po/). But problem seems to exist in your internal svn version too.
Comment 13 Richard Sun (Nokia) 2009-07-28 14:08:31 UTC
(In reply to comment #11)

> > Did you installed latest gtk from trunk? 
> 
> No. Shouldn't it be enough with the version in the beta SDK?
> 

I don't think so. Some new IMcontext property and IM_MODE are added 

> Where is that svn (or git?) for gtk+? This seems to be old and unused now:
> https://stage.maemo.org/viewcvs.cgi/projects/haf/trunk/gtk%2B/?root=maemo&pathrev=9626
> 

following is the trunk svn link 
https://stage.maemo.org/svn/maemo/projects/haf/trunk/gtk+/

> > > 
> > > This is also suspicious, during configure:
> > > 
> > > checking for catalogs to be installed...  en_GB
> > > ./configure: line 22854: ./po/POTFILES.in: No such file or directory
> > > 
> > > I think you forgot to add the po/ directory.
> > >
> > 
> > po directory is not necessary in configure. Can you try to build it from a
> > clean source code?
> > 
> > Although I am using internal mini-rootstrap to test, I tried clean build from
> > stage svn. Everything is fine for me. 
> > 
>
Comment 14 Richard Sun (Nokia) 2009-07-28 14:14:19 UTC
(In reply to comment #12)
> 
> Well, configure complains about it, presumably because you are using
> AM_GLIB_GNU_GETTEXT (and you even mention a en_GB translation that would need
> to be in po/). But problem seems to exist in your internal svn version too.
> 

No idea and it works for me. even po is not in position, it shouldn't break
building.
Comment 15 Murray Cumming (reporter) 2009-07-28 15:12:27 UTC
OK. This builds with the internal (not a public beta) SDK, which must have a
newer GTK+. I'd like to keep this bug open so it can be confirmed that the svn
trunk (at that time) of hildon-input-method builds with a public SDK at some
time in the future.
Comment 16 Andre Klapper maemo.org 2009-11-12 15:13:32 UTC
(In reply to comment #15)
> I'd like to keep this bug open so it can be confirmed that the svn
> trunk (at that time) of hildon-input-method builds with a public SDK at some
> time in the future.

Can somebody re-check the situation in Fremantle now that the final public SDK
has been out for a month?
Comment 17 Urho Konttori 2010-01-05 22:02:23 UTC
Can you check this jrocha?
Comment 18 Marcell Lengyel maemo.org 2010-02-24 09:59:59 UTC
Murray, could you check if this problem still exists? Thanks.
Comment 19 David King 2010-02-24 11:50:55 UTC
(In reply to comment #18)
> Murray, could you check if this problem still exists? Thanks.

configure still fails, now with:

checking for gtkdoc-check... /usr/bin/gtkdoc-check
checking for GTK... yes
checking for GLIB... yes
checking for HILDON... yes
checking for HILDON_IMF... configure: error: Package requirements
(hildon-input-method-framework-3.0 >= 2.1.44) were not met:

Requested 'hildon-input-method-framework-3.0 >= 2.1.44' but version of
hildon-input-method-framework is 2.0.1

This is in an up-to-date public Fremantle SDK. I have
hildon-input-method-framework-dev    1:2.1.41-1+0m5 installed, which is the
most recent in the SDK, but it seems that 2.1.44 is required to configure
successfully. A more recent version is available from Git, however, at
http://maemo.gitorious.org/fremantle-hildon-desktop/hildon-input-method-framework
which allows the git hildon-input-method to configure and build successfully.
Comment 20 Marcell Lengyel maemo.org 2010-02-25 15:22:59 UTC
The current SDK has older packages than the git repository, but that should not
be surprising, I guess. Closing this.