Bug 4631 - GtkHtml view inside HildonPannableArea is "jumpy"
: GtkHtml view inside HildonPannableArea is "jumpy"
Status: RESOLVED WORKSFORME
Product: Desktop platform
general
: 5.0-beta
: All Linux
: Low normal (vote)
: ---
Assigned To: unassigned
: HAF QA mailing list
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2009-06-03 22:30 UTC by Till Harbaum
Modified: 2010-08-23 21:07 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Till Harbaum (reporter) 2009-06-03 22:30:41 UTC
SOFTWARE VERSION:
beta sdk/test units

STEPS TO REPRODUCE THE PROBLEM:
Mount a gtkhtml view inside a HildonPannableArea (instead of a scrolled window)

EXPECTED OUTCOME:
Fluid finger scrolling

ACTUAL OUTCOME:
Some "jumpy" behaviour, even if button-press-events to the gtkhtml view are
disabled and the entire gtkhtml view is set to "insensitive"

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
gtkhtml

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10)
Gecko/2009042513 Ubuntu/8.04 (hardy) Firefox/3.0.10
Comment 1 Andre Klapper maemo.org 2009-06-04 15:39:22 UTC
> STEPS TO REPRODUCE THE PROBLEM:
> Mount a gtkhtml view inside a HildonPannableArea (instead of a scrolled window)

Can you provide exact steps, or attach a testcase please?
Comment 2 Till Harbaum (reporter) 2009-06-04 19:30:10 UTC
(In reply to comment #1)
> Can you provide exact steps, or attach a testcase please?

The html_view from GtkHtml is a widget like any other. As a result in can also
be placed inside a HildonPannableArea. Finger scrolling is just not working
smoothly.

Honestly: Since most bugs end up with "won't fix", i think that spending the
time to write an example is a waste of time.

For me this bugs.maemo.org has become a place where bugs are documented, so i
can point there if a user complains. So this bug report has already served this
purpose without the need of a fully documented example.
Comment 3 Andre Klapper maemo.org 2009-06-15 19:46:31 UTC
(In reply to comment #2)
> Honestly: Since most bugs end up with "won't fix", i think that spending the
> time to write an example is a waste of time.

That's a quite pessimistic approach... If the maintainers need to invest time
writing their own testcase first the WONTFIX rate is likely to increase,
indeed.
Comment 4 Andre Klapper maemo.org 2010-08-23 17:38:49 UTC
WORKSFORME (as I cannot reproduce due to missing testcase).
Plus it's unlikely that it gets fixed at this stage of Maemo5 anyway.

(MeeGo Handset is where the unstable development is taking place. If you are a
developer (not a "normal" end-user) feedback about MeeGo Handset User Interface
issues is specially welcome, e.g. via the MeeGo bugtracker at
https://bugs.meego.com )
Comment 5 Till Harbaum (reporter) 2010-08-23 21:07:29 UTC
Just install the current version of gpxview and pan a cache description in the
"welcome" demo file that comes pre-installed. 

Also, why is "WORKSFORME" a useful reply if it just won't ever get fixed? Why
not set it to "WONTFIX"?