Bug 4624 - need more recent gettext version to support "msgctxt" context
: need more recent gettext version to support "msgctxt" context
Status: RESOLVED FIXED
Product: Development platform
SDK
: 5.0-beta2
: All Linux
: High normal with 1 vote (vote)
: 5.0-final
Assigned To: Juha Kallioinen
: sdk-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-06-03 15:16 UTC by Christian Persch (GNOME)
Modified: 2009-10-22 22:09 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Christian Persch (GNOME) (reporter) 2009-06-03 15:16:49 UTC
[Apologies if I selected the wrong product/component to file this under; it was
hard to find the right place to file.]

The fremantle beta SDK ships with gettext 0.14.x. That version's gettext tools
do not support the "msgctxt" keyword in po files, which leads to a problem when
porting modern applications to maemo, since e.g. most recent Gnome apps use
msgctxt in their po files.

The symptoms of the bug are the build failing in po with an error like this:
../../../po/de.po:1064: keyword "msgctxt" unknown

In order to facilitate porting, fremantle final SDK should ship with a gettext
version that supports this, i.e. at least 0.15, but preferably a more recent
release like 0.17 or 0.18.
Comment 1 Andre Klapper maemo.org 2009-06-03 16:18:13 UTC
Confirming - this makes it cunreetly harder to correctly port applications.
Comment 2 Andre Klapper maemo.org 2009-06-25 17:35:38 UTC
Juha: Are there plans to update this for the next SDK?
This is an issue for porting apps.
Comment 3 Juha Kallioinen nokia 2009-06-26 09:48:41 UTC
(In reply to comment #2)
> Juha: Are there plans to update this for the next SDK?
> This is an issue for porting apps.

It will take a while, but we will update it. Due to holidays it will get done
earliest in August. Also the scratchbox-core needs to be updated since it
provides gettext.
Comment 4 Murray Cumming 2009-08-25 11:20:54 UTC
It's now late in August. Is ther any progress on this?
Comment 5 Jussi Hakala 2009-08-25 11:41:21 UTC
Yes, there is.

Since 1.0.15, gettext inside scratchbox has been upgraded to 0.17.
Comment 6 Murray Cumming 2009-08-25 11:49:20 UTC
Many thanks.

I assume that the Beta2 SDK is using that version of scratchbox, right?
Comment 7 Claudio Saavedra 2009-08-25 12:36:49 UTC
I can confirm it's fixed in targets FREMANTLE_X86/ARMEL:

[sbox-FREMANTLE_X86: ~] > gettext --version
gettext (GNU gettext-runtime) 0.17
Comment 8 Andre Klapper maemo.org 2009-08-25 12:47:08 UTC
Thanks Claudio.

Beta2 SDK still ships gettext 0.14.4-2osso, see
http://repository.maemo.org/unstable/5.0beta2/beta_vs_beta2_content_comparison.html
.
Comment 9 Claudio Saavedra 2009-08-25 12:59:10 UTC
(In reply to comment #8)
> Thanks Claudio.
> 
> Beta2 SDK still ships gettext 0.14.4-2osso, see
> http://repository.maemo.org/unstable/5.0beta2/beta_vs_beta2_content_comparison.html
> .
> 

True:

[sbox-FREMANTLE_ARMEL: ~] > apt-cache policy gettext
gettext:
  Installed: 0.14.4-2osso
  Candidate: 0.14.4-2osso
  Version table:
 *** 0.14.4-2osso 0
        500 http://repository.maemo.org fremantle/sdk/free Packages
        100 /var/lib/dpkg/status


But this should be irrelevant if the setup is right, since gettext comes from
sb:

[sbox-FREMANTLE_ARMEL: ~] > which gettext
/scratchbox/tools/bin/gettext
Comment 10 Jussi Hakala 2009-08-25 18:06:27 UTC
The upgraded version will be later in the repository too, next (beta) release
if not earlier.