Bug 4617 - (int-120359) Toolbar dropdown (when displaying many buttons) not finger friendly
(int-120359)
: Toolbar dropdown (when displaying many buttons) not finger friendly
Status: RESOLVED WONTFIX
Product: Desktop platform
gtk
: 5.0-beta
: All Maemo
: Medium normal with 1 vote (vote)
: 5.0 (1.2009.41-10)
Assigned To: unassigned
: gtk-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-06-02 18:40 UTC by Cornelius Hald
Modified: 2009-06-17 13:32 UTC (History)
2 users (show)

See Also:


Attachments
Screenshot showing the bug (32.93 KB, image/png)
2009-06-02 18:41 UTC, Cornelius Hald
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Cornelius Hald (reporter) 2009-06-02 18:40:40 UTC
SOFTWARE VERSION:
Beta 5.0 SDK

STEPS TO REPRODUCE THE PROBLEM:
Create a toolbar that contains more items as it normally could display. You´ll
see a small arrow on the right side of the toolbar which indicates that there
are more items.

EXPECTED OUTCOME:
When clicking on this indicator something with finger friendly buttons should
pop up. These buttons should have the same size and style as the toolbar. There
is no need to show text labels or keyboard accelerators there.

ACTUAL OUTCOME:
When clicking on this arrow a menu pops up with only stylus sized items. Those
items have small icons, a text label and a keyboard shortcut.
This especially happens when an application is used in portrait mode because
then the toolbar can hold only about half the items that it can hold in
landscape mode.

REPRODUCIBILITY:
always
Comment 1 Cornelius Hald (reporter) 2009-06-02 18:41:55 UTC
Created an attachment (id=1211) [details]
Screenshot showing the bug
Comment 2 Alberto Garcia Gonzalez 2009-06-02 19:50:17 UTC
Moving to GTK
Comment 3 Andre Klapper maemo.org 2009-06-02 21:28:39 UTC
Confirming.
Comment 4 Andre Klapper maemo.org 2009-06-17 13:32:08 UTC
WONTFIX for Fremantle.
Forwarding internal comments:

"The default GTK+ widget indeed shows a menu with menu items when the overflow
arrow is clicked.  This is unfortunately not configurable.  Changing this
requires changes to all GtkToolItems.  Of course all third-party GtkToolItems
are not under our control, so these cannot be expected to be updated.
The landscape mode provides reasonable space for menu items.  Applications are
expected to use landscape only UI. Toolbar overflow is not supposed to be
used."