Bug 4608 - HildonBanner does not except NULL value for deprecated icon argument
: HildonBanner does not except NULL value for deprecated icon argument
Status: RESOLVED FIXED
Product: Desktop platform
hildon-widgets
: 5.0-beta
: All Linux
: Low normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: Claudio Saavedra
: hildon-libs-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-06-02 03:07 UTC by Brent Chiodo
Modified: 2010-03-15 20:53 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Brent Chiodo (reporter) 2009-06-02 03:07:20 UTC
SOFTWARE VERSION:
N/A

STEPS TO REPRODUCE THE PROBLEM:
When creating a new Hildon Banner, pass None or NULL (depending on the
programming language) as the second argument.

EXPECTED OUTCOME:
It will be ignored because Hildon 2.2 doesn't let developers specify icons.

ACTUAL OUTCOME:
It errors because argument 2 must be a string.

REPRODUCIBILITY:
always

OTHER COMMENTS:
Since the second argument is depreciated and only there to support software
programmed for older Hildon versions, it should except None as a parameter (as
that was the Default Icon).

This behavior was observed using PyMaemo in the Fremantle Beta SDK, but assume
it is also present in C, etc.

User-Agent:       Mozilla/5.0 (compatible; Konqueror/4.1; Linux) KHTML/4.1.4
(like Gecko)
Comment 1 Andre Klapper maemo.org 2009-06-02 12:30:23 UTC
So we talk about
http://maemo.org/api_refs/5.0/beta/hildon/HildonBanner.html#hildon-banner-show-information
and the other two functions to create a HildonBanner I guess.

> ACTUAL OUTCOME:
> It errors because argument 2 must be a string.

For future reference, the exact errors message is always welcome. :-)
Comment 2 Alberto Garcia Gonzalez 2010-02-03 10:51:00 UTC
(In reply to comment #0)
> When creating a new Hildon Banner, pass None or NULL (depending on
> the programming language) as the second argument.
>
> EXPECTED OUTCOME:
> It will be ignored because Hildon 2.2 doesn't let developers specify
> icons.
>
> ACTUAL OUTCOME:
> It errors because argument 2 must be a string.

First of all, I'd like to apologize because I somehow overlooked this
bug until now.

I'm checking the HildonBanner C API and I can't see any method where
you cannot pass NULL to create a banner.

Currently the only deprecated parameter not being completely ignored
is 'icon_name' in hildon_banner_show_information_with_markup(), but it
accepts NULL as a valid value.

So I'm closing this as FIXED.

If you think this bug is still present feel free to add a comment.

Thanks!
Comment 3 Andre Klapper maemo.org 2010-03-15 20:53:19 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).