Bug 4594 - (int-131747) Failed to build libosso-2.19 from Fremantle repo (ggc 4.3.2)
(int-131747)
: Failed to build libosso-2.19 from Fremantle repo (ggc 4.3.2)
Status: RESOLVED FIXED
Product: Desktop platform
libosso
: 5.0/(1.2009.42-11)
: x86 Linux
: Unspecified major (vote)
: 5.0/(2.2009.51-1)
Assigned To: Kimmo Hämäläinen
: libosso-bugs
:
: patch
:
:
  Show dependency tree
 
Reported: 2009-05-29 08:23 UTC by Kirtika Ruchandani
Modified: 2010-01-14 12:27 UTC (History)
2 users (show)

See Also:


Attachments
Patch to remove hidden attribute from 2 functions: osso-rpc.c and osso-init.c (1.34 KB, patch)
2009-05-29 15:24 UTC, Kirtika Ruchandani
Details
Patch to avoid inlining functions (1.08 KB, patch)
2009-07-01 14:45 UTC, Kirtika Ruchandani
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Kirtika Ruchandani (reporter) 2009-05-29 08:23:31 UTC
SOFTWARE VERSION: Libosso-2.19 from the Fremantle repo.
[http://repository.maemo.org/pool/fremantle/free/libo/libosso/]

STEPS TO REPRODUCE THE PROBLEM: Just a normal attempt to build with
./autogen.sh,configure and make. 

My system specs:
ggc 4.3.2 
32-bit ubuntu 8.10
maemo-gtk, mce and other deps installed - so no issues there.

EXPECTED OUTCOME: No error !

ACTUAL OUTCOME: 
Build fails at link stage : 
http://pastebin.com/f64a17d8a
The attributes setting of the muali function is the culprit.
The function it cannot find is in osso-rpc.c

What worked for me :
Changes to osso-rpc.c     http://dpaste.com/48890/
Changes to osso-init.c    http://dpaste.com/48893/

This error could be due to my gcc version or something else, but 
this:
(http://projects.linuxtogo.org/pipermail/openembedded-commits/2009-March/025457.html)
has similar changes.


REPRODUCIBILITY: Always
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED: none

OTHER COMMENTS: changelog for version 2.19 is missing. :)



User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10)
Gecko/2009042523 Ubuntu/8.10 (intrepid) Firefox/3.0.10
Comment 1 Kimmo Hämäläinen nokia 2009-05-29 13:20:20 UTC
I don't have that compiler. Please attach a patch that works and I'll fix it...
Comment 2 Kirtika Ruchandani (reporter) 2009-05-29 15:24:15 UTC
Created an attachment (id=1209) [details]
Patch to remove hidden attribute from 2 functions: osso-rpc.c and osso-init.c

Added the patch which worked for me. Can somebody please confirm if this is the
correct approach ? I checked with other alternatives for attribute similar to
hidden which might be appropriate here - but doesnt work that way.
[Also, this build is without outo support. If I have outo on my system, libtool
cribs about run-paths not being absolute.]
Comment 3 Andre Klapper maemo.org 2009-06-23 00:58:09 UTC
Kimmo: Willing to integrate this, or shall I open an internal ticket?
Comment 4 Kimmo Hämäläinen nokia 2009-06-23 10:58:21 UTC
Maybe it's combining "inline" and hidden attribute that is the problem. Could
the reporter try just removing "inline"?  Hiding the symbol is desired.
Comment 5 Andre Klapper maemo.org 2009-07-01 14:21:29 UTC
moreinfo as per last comment.
Kirtika, can you please test this (and remove the moreinfo keyword again after
commenting here)?
Comment 6 Kirtika Ruchandani (reporter) 2009-07-01 14:34:52 UTC
@Andre, Kimmo:
I am extremely sorry for the huge latency in the reply.
Yes, doing what Kimmo suggested works {removing the inline}.
Comment 7 Kirtika Ruchandani (reporter) 2009-07-01 14:45:54 UTC
Created an attachment (id=1256) [details]
Patch to avoid inlining functions

Too trivial to be needed here, but attached the revised patch just in case.
Comment 8 Andre Klapper maemo.org 2009-07-15 14:45:33 UTC
Kimmo, so is this worth importing or can you quickly integrate it?
Comment 9 Andre Klapper maemo.org 2009-10-22 11:27:37 UTC
Fixed in internal week 43 build.
Any public update released with or after this build version (x.2009.43-y) will
include the fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 10 Andre Klapper maemo.org 2010-01-14 12:27:57 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.