Bug 4520 - (int-100553) Cannot build libhildondesktop1 on Mer: No source for libiphb0
: Cannot build libhildondesktop1 on Mer: No source for libiphb0
Product: Licensing Change Requests
: 5.0-beta2
: All Linux
: Unspecified normal with 3 votes (vote)
: ---
Assigned To: Carsten Munk
: licensing-requests
  Show dependency tree
Reported: 2009-05-11 00:55 UTC by Thomas Perl
Modified: 2010-07-19 10:33 UTC (History)
8 users (show)

See Also:



You need to log in before you can comment on or make changes to this bug.

Description Thomas Perl (reporter) 2009-05-11 00:55:39 UTC

Try to build libhildondesktop1 from source in Mer.


All (build-)dependencies are available as source package.


The package libiphb-dev required to build libhildondesktop1 (and the package
libiphb0 as a runtime dependency) are in the Nokia Binaries repository; no
source provided.




libhildondesktop1 is a dependency of python-hildon. The source package for
libiphb0 and libiphb-dev is called "iphbd". This source package would be
required to build libhildondesktop1 on Mer.
Comment 1 Soumya nokia 2009-05-11 14:13:38 UTC
iphb is currently a nokia-closed component. Internally, I have been pushing for
it to be open sourced for a while now. No decisions made yet. Similar situation
will arise with hildon-control-panel too w.r.t libcodelockui1-dev. 

Quim, yet another reason to get those component open. How can we speed up the
decision making?
Comment 2 Anderson Lizardo 2009-05-11 20:43:04 UTC
Just a correction regarding python-hildon: it does not depend on
libhildondesktop1 anymore, I forgot to remove it from debian/control and I'm
working on fixing this.

On the other hand, libhildondesktop1 will be a dependency on
python-hildondesktop (a package we are porting from Ubuntu mobile) which
provides bindings for the home applet support.
Comment 3 Andre Klapper maemo.org 2009-07-30 15:50:04 UTC
*** Bug 4856 has been marked as a duplicate of this bug. ***
Comment 4 Andre Klapper maemo.org 2009-07-30 15:50:37 UTC
Copying from bug 4856:

Currently libhildondesktop is open source and has a hard dependancy in
hd-heartbeat.c on a closed package, libiphb-dev, making it impossible to
implement the libhildondesktop API outside Maemo 5.0 / in fully open source

To implement hildon-home area & making libhildondesktop-using applets work
outside Maemo 5.0, is currently impossible or would require unnecessary deltas
to libhildondesktop.

libiphb is yet-another-closed-source DBUS interface (see MB4560) communicating
with com.nokia.iphbd - but like libtime it has some degree of logic in it.

We'd like to, in Mer, be able to use same APIs as Fremantle for home area items
& start using hildon-home and this can only be done if libiphb is open sourced.
Comment 5 Andre Klapper maemo.org 2010-02-16 19:59:26 UTC
(Moving all Licensing Change Requests to a separate Product in Bugzilla.
Sorry for the bugmail noise)
Comment 6 Carsten Munk maemo.org 2010-02-18 16:51:00 UTC
Temporarily setting this to priority unspecified while it gets evaluated.
Comment 7 Carsten Munk maemo.org 2010-02-19 10:48:30 UTC
Bumped internal bug, assigning to myself as I will be tracking it and we're
taking it out of the queue for processing.
Comment 8 Carsten Munk maemo.org 2010-07-19 10:33:20 UTC
IPHB is now published as part of MeeGo DSME. Closing bug as RESOLVED FIXED.