Bug 448 - (int-54590) wtmp grows without bound
(int-54590)
: wtmp grows without bound
Status: RESOLVED FIXED
Product: Core
Busybox
: unspecified
: All Maemo
: Medium normal (vote)
: 3.2
Assigned To: unassigned
: busybox-bugs
:
: ITOS2007HE-garage
:
:
  Show dependency tree
 
Reported: 2006-04-05 02:02 UTC by Mike Lococo
Modified: 2008-12-06 16:16 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Mike Lococo (reporter) 2006-04-05 02:02:06 UTC
/var/log/wtmp isn't rotated or cleaned on a schedule and will continue to grow
over the lifetime of the device until the unit fills up or is reflashed.  wtmp
sizes of nearly 200M (before jffs compression, size on disk is considerably
smaller) have been documented on some devices.

Although wtmp can be emptied with a shell command (echo "" > /var/log/wtmp),
this requires installing xterm and enabling root access.  Non-technical
end-users have no simple workaround to reclaim space lost to wtmp.

wtmp should be rotated and discarded on a reasonable schedule like weekly or
monthly.

This bug applies to firmware revision 3.2005.51-13 (and probably earlier
versions as well).
Comment 1 Maemo QA (deprecated) 2006-05-09 10:41:54 UTC
Claiming ownership.
Comment 2 Maemo QA (deprecated) 2006-05-09 10:47:13 UTC
Unable to reproduce with latest product image (2006-13). The log file doesn't
exist.

If my memory serves me well, I remember that this issue was supposed to be
fixed
in the latest release. Could someone please verify before I mark the bug FIXED?
Comment 3 Mike Lococo (reporter) 2006-05-17 02:50:13 UTC
Confirmed that wtmp does not exist in 5.2006.13-7.  Closing.
Comment 4 Maemo QA (deprecated) 2006-05-17 12:48:46 UTC
Closing bug
Comment 5 Frantisek Dufka maemo.org 2007-04-18 14:08:03 UTC
reusing N770 bug report for N800, same symptoms, happens with 3.2007.10-7
when file is deleted it appears again after some time and grows
Comment 6 Frantisek Dufka maemo.org 2007-04-18 14:09:46 UTC
See also
http://maemo.org/pipermail/maemo-developers/2007-April/009812.html
Comment 7 Niels Breet maemo.org 2007-04-18 14:20:10 UTC
(In reply to comment #5)
> reusing N770 bug report for N800, same symptoms, happens with 3.2007.10-7
> when file is deleted it appears again after some time and grows

Mine was 64 MB already. Flashed the 3.2007.10-7 image on the day it was released.
Comment 8 Neil MacLeod maemo.org 2007-04-18 19:06:47 UTC
Confirming this in firmware: 3.2007.10-7, wtmp on my device is 64MB.

/home/user # cd /var/log
/var/log # ls -la
drwxr-xr-x    2 root     root            0 Mar 23 14:52 .
drwxr-xr-x   12 root     root            0 Jan  1  1970 ..
-rw-r--r--    1 root     root          390 Mar 23 14:52 fontconfig.log
-rw-r--r--    1 root     root     64732416 Apr 18 17:02 wtmp
/var/log # uptime
 17:03:18 up 9 days, 19:53, load average: 0.12, 0.07, 0.01
Comment 9 Neil MacLeod maemo.org 2007-04-18 19:10:06 UTC
I see this file is not recreated on a reboot, so the uptime is irrelevant - I
flashed my N800 on 23 March.
Comment 10 Eero Tamminen nokia 2007-04-19 11:39:02 UTC
It would have been good to have a separate bug as this is a separate bug
from the 770 one, just the symptoms are same. Anyway -> NB#54590

Btw. When we get "cloning" functionality in Bugzilla...?
Comment 11 Frantisek Dufka maemo.org 2007-04-19 14:43:09 UTC
(In reply to comment #10)
> It would have been good to have a separate bug as this is a separate bug
> from the 770 one

Oh, sorry, I was thinking about this for a bit and then decided to reopen the
bug anyway since for users it is exactly the same bug and most/all info is
relevant. I wonder why is this a problem? Anyway I won't do it next time.
Comment 12 Eero Tamminen nokia 2007-04-19 15:10:42 UTC
> Oh, sorry, I was thinking about this for a bit and then decided to reopen the
> bug anyway since for users it is exactly the same bug and most/all info is
> relevant. I wonder why is this a problem?

For now it's more of a principle (they are different products) than an actual
problem (Maemo Bugzilla has still only very few bugs).  In a separate bug
it would have been of course nice to give a link to earlier 770 bug. :-)
Comment 13 timeless 2007-10-14 05:13:04 UTC
fwiw, the world changed :), it's now just one product.

i hit this, w/ a build not newer than 2007.26-4 , mine was >200mb

rumor has it this is fixed...
Comment 15 Eero Tamminen nokia 2007-12-04 13:13:06 UTC
(In reply to comment #13)
> i hit this, w/ a build not newer than 2007.26-4 , mine was >200mb

This is not an official release.

Anyway, NB#54590 has been marked as fixed already in Bora
(and it doesn't happen in Chinook), so marking this as fixed.