Bug 4417 - cannot login to maemo.org
: cannot login to maemo.org
Status: VERIFIED FIXED
Product: maemo.org Website
Autobuilder
: unspecified
: N810 Maemo
: Low major with 2 votes (vote)
: ---
Assigned To: eero.afheurlin
: repositories@maemo.bugs
:
:
: 4392
:
  Show dependency tree
 
Reported: 2009-04-29 07:53 UTC by john
Modified: 2009-06-26 10:16 UTC (History)
11 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description john (reporter) 2009-04-29 07:53:05 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
latest os2008

STEPS TO REPRODUCE THE PROBLEM:
when i try to login it takes me to a login page. then i type user and pw agian
and nothing happens. further the newly imputed data (user info) appears to be
white font on white backgroumd until i bring up the thumboard on my n810, then
the imputed text appears black

EXPECTED OUTCOME:
login maemo.org
ACTUAL OUTCOME:
cannot get passed login page
REPRODUCIBILITY:
(always/sometimes/once)
always on new maemo
EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:
Comment 1 Niels Breet maemo.org 2009-04-29 13:17:48 UTC
I can't reproduce this at all.

Can you please specify which url you are visiting and which login form you are
using (The one in the header or the one in the middle of the content part?
Comment 2 john (reporter) 2009-04-29 18:31:15 UTC
This is reproducable on my n810.  by going to http://maemo.org/  then going to
the fields on the upper right hand side and logging in (is this the login area?
 it says register, but I am already registered?)

When I type in my information I cannot see any text in the fields when using
n810 keyboard or thumboard.  When I use the thumboard it directs me to
https://maemo.org/ were apparently I can login again.  I fill in the fields
with the thumboard and it mrely reloads the page, when I use the keybaord it
does redirect me to the main page were I am logged in since I can see the
floating widget; however, when I attempt to logoff using the floating widget it
does not logg me off, in fact it does nothing.

Do you think I need to clear my cache or all data in my MicroB?  On my desktop
I do not get any of these problems.
Comment 3 Oskar 2009-05-02 23:40:37 UTC
i tried it right now and it is as john describes it. - i'm very surprised that
pulling out the hardware keyboard actually works, because i have the same login
problems on my desktop. to login from there, i have to go to garage.
Comment 4 Alan Bruce maemo.org 2009-05-06 08:01:38 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Alan Bruce maemo.org 2009-05-06 08:08:15 UTC
I also attempt to log in (from any maemo.org page) using the login at the top
right of the screen. There are no errors, but I am returned to the page I
"logged in" from, and I am still not logged in.

After this happens, I simply change the "http://" in the address bar to
"https://" and I am logged in.

(Additionally, when I am not logged in and I attempt to give the "thumbs up" to
a planet maemo article, I am taken to a weird error page instead of a login
page)
Comment 6 Niels Breet maemo.org 2009-05-06 12:34:54 UTC
I'm beginning to think this is a cache related issue. You probably are logged
in, but the website doesn't show it because it shows the anonymous cached page
you previously were on.

If you start to browse(just click through multiple links) the site after login,
does your logged in status in the header suddenly appear?

Don't to to https while testing this.
Comment 7 Mikko Vartiainen 2009-05-06 17:54:41 UTC
It's cache related for me at least. When I login with username and password
from front page (I don't have them saved), I get the same page again with login
prompt. When I click couple times around for example 'downloads' and
'community', page changes to logged in type. URL stays http:// one and never
changes to https://

My browser:
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.9) Gecko/2009042114
Ubuntu/9.04 (jaunty) Firefox/3.0.9
Comment 8 Niels Breet maemo.org 2009-05-06 18:04:13 UTC
*** Bug 4366 has been marked as a duplicate of this bug. ***
Comment 9 Josua Dietze 2009-05-06 18:29:34 UTC
(In reply to comment #7)
> When I click couple times around for example 'downloads' and
> 'community', page changes to logged in type.

I get the same effect by just reloading the page after the seemingly failed
login.
Comment 10 Oskar 2009-05-07 00:06:26 UTC
I have two situations (three, actually, counting the strange "works with
hardware keyboard"-effect on the N810), and the behaviour varies according to
weather and mood.

Situation 1: I log in, nothing seems to happen. I'm on the same page as before,
not logged in. Then, when I reload or click on a link, I find I'm logged in
after all. - This is not new, it happened when we had the old design, too. May
be somehow cache related, but worth fixing anyway as it certainly is not what
you expect.

Situation 2: I log in, and instead of showing either the page I'm at with my
name on top (as expected) or without my name (as descriped in situation 1
above), the browser takes me to a login page where I should type in username
and password again. (And then again and again.) As if I had misspelled my
password or something, only that I don't tend to have typing errors on logins
that often.
This indicates that the input was processed somehow, it's not a cache issue as
I get to see a new page, but still my attempt to log in wasn't successful.

I can't reproduce any of the situations reliably. I have a feeling that #1
occurs at the laptop I'm at now, while #2 is more likely on my Windows machine
in the office and on the tablet itself..... Which doesn't help at all now. ;)
Comment 11 krisse 2009-05-07 02:33:58 UTC
I have the same experience as Oskar. The site is very unpredictable which makes
it hard to reproduce problems.
Comment 12 john (reporter) 2009-05-07 06:57:20 UTC
Apparently users are not allowed to use bugzilla they have to use normal
support systems, as engineers do not talking to mere users as it waste their
time.  This is based on an information ferom the maemo communty council. 
Please see http://talk.maemo.org/showthread.php?t=28701&page=5 for details.  As
such I am marking as closed and apologize for disturbing their important work -
whatever that may be.
Comment 13 krisse 2009-05-07 07:19:16 UTC
I don't want support, I just want to report a bug on the site. Isn't that the
point of bugzilla, to report observed bugs?
Comment 14 Alan Bruce maemo.org 2009-05-07 09:11:09 UTC
John, lets try to have a sense of humour about this, and not let heated
discussions on the forums get the better of us here.

_Please_ reopen this bug. I need it fixed, too.
Comment 15 Niels Breet maemo.org 2009-05-07 10:44:55 UTC
Changed caching strategy on the webserver cluster. Can anyone test if this
gives any improvements?
Comment 16 Mikko Vartiainen 2009-05-07 12:54:35 UTC
No changes for me
Comment 17 Josua Dietze 2009-05-07 14:44:05 UTC
No change here either.

Re support: before I discovered the IRC way, I honestly thought the bugtracker
was the only way to get a kind of support concerning the website.
While it is a good thing to see other users confirming a problem, it is a bit
frustrating for problems that affect only few people (like bug #4383).
Comment 18 john (reporter) 2009-05-08 18:15:36 UTC
No changes here.  I can reproduce the facts detailed in comment #7 also.  I
have cleared my cache and this did not solve the problem.

(On a side not, where is the "Login" portion of the site anyway? WHy not
caption that is titled that?  Is "Register" the same with "Login"  I would say
the standard in the industry is to have a login webpart and an special link
under that portion were a new user can click to register it would generaly
inform the user if they have not registered click here. In sum, if that is the
login webpart why not title it so?)

So far the only internet site I have not been able to login to with the maemo
operating system (using 5.2008.43-7) and MicroB is the maemo site....kind of
ironic.
Comment 19 krisse 2009-05-08 20:41:33 UTC
(In reply to comment #15)
> Changed caching strategy on the webserver cluster. Can anyone test if this
> gives any improvements?
> 

The problem for me seems to be that I log in but the front page doesn't
acknowledge this.

If I visit other pages on the site my logged-in name is visible in the top
right corner, but the front page constantly shows the login form instead.

So the login works for me, but if I never leave the front page it LOOKS like it
doesn't work.

So perhaps this isn't a logging-in problem but something to do with how the
front page handles displaying the login form. It's supposed to replace the form
with my name when I'm logged in, but it isn't doing so.
Comment 20 john (reporter) 2009-05-09 09:15:57 UTC
i noticed i could log in the front page okay tonight. however, when i logged in
from the talk section my password was not masked.
Comment 21 Alan Bruce maemo.org 2009-05-09 12:17:33 UTC
No changes for me; Firefox 3, Ubuntu Jaunty (but I have observed this behaviour
on Windows XP FF3 as well)

I log in from the upper right, nothing appears to change; I switch to https://
and I'm logged in.

Additional clues: If I am logged in, and then close my browser, reopen it, and
return to http://maemo.org, I am no longer logged in. If I then change to
https:// without logging in first, I get the login form. This also happens if I
go directly to https:// after restarting the browser. If I use this form to
login, I am taken back to the http:// page, and I am not logged in. If I change
back to https://, I am logged in. If I change to http:// again, I am not logged
in.

In summary, it is not possible for me to be logged in at an http:// page. Is
this correct behaviour? This problem, coupled with the fact that maemo.org
insists on returning me to http:// after logging in, makes it appear that login
doesn't work. Also, login status is not retained across sessions. Is this
expected behaviour?
Comment 22 krisse 2009-05-09 17:23:32 UTC
People saying they are "not logged in", how do you know you are not logged in?

I thought I wasn't logged in due to the front page continuing to display the
login form, but when I navigated to another page I saw that I was indeed logged
in.

Is it possible that some of the people saying they aren't logged in are
actually just looking at the front page? And that this is just an error that is
to do with the front page login form appearing when a person is already logged
in?
Comment 23 Josua Dietze 2009-05-09 22:31:18 UTC
(In reply to comment #22)
> Is it possible that some of the people saying they aren't logged in are
> actually just looking at the front page? And that this is just an error that is
> to do with the front page login form appearing when a person is already logged
> in?

It happens anywhere on the site at the moment when you want to change from
"guest mode" to "registered mode".
And it occasionally happens that you seem to be logged in on one page, but
after changing to annother the authentification is gone and you are suddenly
back in "guest mode".
Comment 24 Mikko Vartiainen 2009-05-12 01:03:53 UTC
Here's some log:

1. I logged in on downloads page (had to reload)
2. Clicked on intro page
Here http request and reply

GET /intro/ HTTP/1.1

Host: maemo.org

User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10)
Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10

Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

Accept-Language: en-us,en;q=0.5

Accept-Encoding: gzip,deflate

Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7

Keep-Alive: 300

Connection: keep-alive

Referer: http://maemo.org/downloads/OS2008/

Cookie: PHPSESSID=22db69452295e988fdb50b2de6746cac; __qcb=1973142280;
__qca=1241601956-15239234-99714395

If-Modified-Since: Mon, 02 Feb 2009 09:19:10 GMT

If-None-Match: 9a82ca9e6088d30f1a95f81fd3a4e44e



HTTP/1.1 304 Not Modified

Date: Mon, 11 May 2009 21:55:57 GMT

Server: Apache/2.2.3 (Debian) PHP/5.2.0-8+etch13 mod_ssl/2.2.3 OpenSSL/0.9.8c
Midgard/8.09.4

Connection: Keep-Alive

Keep-Alive: timeout=5, max=100

ETag: 9a82ca9e6088d30f1a95f81fd3a4e44e

Expires: Mon, 11 May 2009 22:22:31 GMT

Cache-Control: public max-age=1800

Vary: Accept-Encoding

3. Browser shows not logged in page from cache because server told that the
page hasn't changed. Correct?
Comment 25 Uwe Kaminski 2009-05-12 10:54:53 UTC
At the moment I'm unable to login at all. If I enter my account and password on
top of the page and click the "go" button I'm not logged in. After this I
pressed F5 (Firefox 3.0.10, WinXP) -> I'm not logged in. This seems to appear
on all maemo.org pages (not talk or wiki).

As a result of this I'm not able to give comments to applications in download
section.

Other results (related bugs) are:
https://bugs.maemo.org/show_bug.cgi?id=4236
and:
https://bugs.maemo.org/show_bug.cgi?id=4392

That's why I increase the Serverity to major. It's a basic feature and doesen't
work yet.
Comment 26 Niels Breet maemo.org 2009-05-12 13:48:23 UTC
One of the servers in the cluster had their clock lagging one hour behind. If
your request was handled by this server, the session expired.

You should now at least be able to stay logged in when moving from page to
page.

This doesn't change the login page issues though.
Comment 27 Uwe Kaminski 2009-05-12 15:16:05 UTC
(In reply to comment #26)
> One of the servers in the cluster had their clock lagging one hour behind. If
> your request was handled by this server, the session expired.
> 
> You should now at least be able to stay logged in when moving from page to
> page.

Yes it works. Actually I don't need a reload of the page to be logged in. It
seems to work all correctly at the moment.

> This doesn't change the login page issues though.

atm I'm not able to reproduce the issues. Maybe the main problem of this bug is
fixed? :)
Comment 28 Josua Dietze 2009-05-12 15:57:03 UTC
(In reply to comment #27)
> atm I'm not able to reproduce the issues. Maybe the main problem of this bug is
> fixed? :)

No change here. Same behaviour as before (reload necessary).
Comment 29 krisse 2009-05-12 17:00:17 UTC
It's started working for me, I don't have any login problems any more.

Maybe there were actually two separate login problems which affected two
separate groups, and one of the login problems has now been cured?
Comment 30 eero.afheurlin 2009-05-14 15:58:38 UTC
Changed cache settings: Now the cluster should always send must-revalidate
-headers to browsers and thus all well behaving browsers should see that the
page has been changed according to login state.

At least on my MicroB it works fine (and my FF but that has been configured to
always check wih the server regardless of max-age)
Comment 31 Josua Dietze 2009-05-16 00:56:08 UTC
Yes, it's finally working. Opera, FF and IE6.
Thank you very much!
Comment 32 Uwe Kaminski 2009-05-20 14:22:31 UTC
Works on Firefox 3.0.10 (windows and Linux versions)
Comment 33 Alan Bruce maemo.org 2009-05-21 20:47:50 UTC
Still the same on my FF 2, Debian 4 box. Exactly the same symptoms as
previously reported. Logging in from the main page puts me back to the main
page with the log in box still there.
Comment 34 Alan Bruce maemo.org 2009-05-21 20:50:20 UTC
Sorry for the second comment. Just discovered that going to another page shows
me as logged in, even though I am apparently not logged in on the main page.
Comment 35 john (reporter) 2009-06-25 17:18:29 UTC
(In reply to comment #34)
> Sorry for the second comment. Just discovered that going to another page shows
> me as logged in, even though I am apparently not logged in on the main page.
> 

Yes, same for me. Main logn page not properly showing login status, while other
web parts such as talk will update my logged in status.
Comment 36 eero.afheurlin 2009-06-26 09:54:46 UTC
>> Sorry for the second comment. Just discovered that going to another page shows
>> me as logged in, even though I am apparently not logged in on the main page.
>> 
>
>Yes, same for me. Main logn page not properly showing login status, while other
>web parts such as talk will update my logged in status.
>

This is because your browser is loading a local cached copy of the front-page
(or whatever page you were on before logging in).

Someone(tm) changed the cache settings while I was not looking reintroducing
this bug, changed them back and tested to work with: FF 3.0 (Mac), Safari 4.0
(Mac), Microb (N810), Camino 1.6.8 (Mac), Midori (N810)
Comment 37 Uwe Kaminski 2009-06-26 10:16:31 UTC
I was able to verify this for firefox 3.11 / fennec (nightly build from
09-06-25) and microb (latest version).

Thanks for fixing this! :)