Bug 4412 - (int-114793) Installation error for extras-devel Fremantle packages (maemo-select-menu-location)
(int-114793)
: Installation error for extras-devel Fremantle packages (maemo-select-menu-loc...
Status: RESOLVED FIXED
Product: Settings and Maintenance
Application manager
: 5.0-beta2
: All Linux
: Low normal (vote)
: 5.0 (1.2009.41-10)
Assigned To: Richard Sun
: application-manager-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-04-29 00:11 UTC by Valério Valério
Modified: 2010-02-24 21:50 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Valério Valério (reporter) maemo.org 2009-04-29 00:11:48 UTC
STEPS TO REPRODUCE THE PROBLEM:

Add Fremantle extras-devel repository in the sdk.
apt-get update
fakeroot apt-get install leafpad (other applications produce the same error)

EXPECTED OUTCOME:

The installation should occur without any error, like in the Fremantle alpha
SDK.

ACTUAL OUTCOME:

****************************
Console output: 

/scratchbox/tools/bin/sh: line 1: /usr/sbin/dpkg-preconfigure: No such file or
directory
Setting up leafpad (0.8.16le-0maemo2) ...
gtk-update-icon-cache: Cache file created successfully.
/var/lib/dpkg/info/leafpad.postinst: line 7: maemo-select-menu-location:
command not found
dpkg: error processing leafpad (--configure):
 subprocess post-installation script returned error exit status 127

********************************

The errors above persist every time I use a apt-get command, but the
applications are installed normally.


REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

Nokia binaries

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-PT; rv:1.9.0.5)
Gecko/2008121621 Ubuntu/8.04 (hardy) Firefox/3.0.5
Comment 1 Soumya nokia 2009-04-29 11:27:16 UTC
hildon-application-manager does not include maemo-select-menu-location anymore.
Richard can probably comment on this.
Comment 2 Soumya nokia 2009-04-30 09:18:46 UTC
Spoke to Richard here is the reason why hildon-application-manager no longer
has maemo-select-menu-location.

In Fremantle, there are no submenus like "Utility", "Extras", "Settings" etc.
All installed 3rd party software will go under "Applications".
Therefore maemo-select-menu-location is obsolete.

There is currently a bug in UI framework which makes it necessary to restart
the framework after the *.desktop files are installed/un-installed. It is being
worked upon.
Comment 3 Mikko Vartiainen 2009-05-15 15:37:57 UTC
leafpad and other packages have "Depends: maemo-select-menu-location". So
technically this is a bug in hildon-application-manager which provides
maemo-select-menu-location. 

IMO hildon-application-manager should have a dummy maemo-select-menu-location
like in fremantle-alpha or maemo-select-menu-location could be symlinked to
/bin/true. If hildon-application-manager was completely removed from
hildon-application-manager it would basically mean that packaging should be
done separately from diablo and fremantle.
Comment 4 Andre Klapper maemo.org 2009-05-15 17:00:19 UTC
(In reply to comment #3)
> leafpad and other packages have "Depends: maemo-select-menu-location". So
> technically this is a bug in hildon-application-manager which provides
> maemo-select-menu-location. 

It is also a bug in the packages, because maemo-select-menu-location is
deprecated. Hence packages should get fixed too.
Nokia just tested all packages in extras-devel repo and I've filed tickets and
emailed maintainers for all those packages in Extras-Devel that fail with the
same issue (maemo-select-menu-location).
For example the leafpad ticket is at
https://garage.maemo.org/tracker/index.php?func=detail&aid=4074&group_id=712&atid=2668
.
Comment 5 Mikko Vartiainen 2009-05-15 17:28:30 UTC
(In reply to comment #4)
> It is also a bug in the packages, because maemo-select-menu-location is
> deprecated. 

May I correct that deprecated and removed are different things. If
maemo-select-menu-location was deprecated (like in alpha), there would be no
problems.
Comment 6 Andre Klapper maemo.org 2009-09-16 00:29:47 UTC
This has been fixed internally for Fremantle.
Comment 7 Mikko Vartiainen 2009-09-16 00:35:28 UTC
Could you tell how it was fixed?

I think that all relevant packages have already dropped
maemo-select-menu-location depency.
Comment 8 Andre Klapper maemo.org 2009-09-16 15:11:59 UTC
Argh, yes - I was mislead by the internal "FIXED" resolution.
It's more like OBSOLETE...
Comment 9 Pelau Vadim 2010-02-24 21:50:56 UTC
How about gconf-editor?

I find this quite impairing at this time.

Is there any way around it?