Bug 4364 - Logging in to maemo.org via blog page (i.e., not the uppermost login form) doesn't work...
: Logging in to maemo.org via blog page (i.e., not the uppermost login form) do...
Status: RESOLVED FIXED
Product: maemo.org Website
Newstyle
: unspecified
: All All
: High critical (vote)
: ---
Assigned To: unassigned
: newstyle-bugs
: http://maemo.org/community/council/so...
:
:
:
  Show dependency tree
 
Reported: 2009-04-23 17:31 UTC by Tim Samoff
Modified: 2009-05-04 22:38 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tim Samoff (reporter) maemo.org 2009-04-23 17:31:59 UTC
STEPS TO REPRODUCE THE PROBLEM:
Logout of maemo.org and go to a blog post. Click "logged in" in the sentence
"You must be logged in to make comments." under the blog comments. Fill out the
form on the page and click the "LOGIN" button (or hit the Enter key).

EXPECTED OUTCOME:
The user should be logged in and taken back to the originating blog post.

ACTUAL OUTCOME:
Nothing happens.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US;
rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Comment 1 Dave Neary maemo.org 2009-04-24 18:36:42 UTC
Works for me - I click "logged in", and I get automatically logged in.
Comment 2 Tim Samoff (reporter) maemo.org 2009-04-24 18:49:11 UTC
Not me. In fact, even if I do "successfully" login via the top form, I have to
refresh my page for the Midgard toolbar to appear. There is definitely some
whackiness going on.
Comment 3 Josua Dietze 2009-04-24 19:27:09 UTC
I have the reload effect every time I log on - no matter from where I come. See
bug #4366. Do you see your username in the auth area (upper right) after the
first login attempt, before you reload the page manually?
Comment 4 Tim Samoff (reporter) maemo.org 2009-04-24 19:28:41 UTC
No. It remains the login form. I must reload the page to see any changes. I
will continue testing and try to come up with a reproducible report.
Comment 5 Niels Breet maemo.org 2009-04-27 15:57:21 UTC
Should be fixed now.
Comment 6 Josua Dietze 2009-05-04 22:38:26 UTC
(In reply to comment #4)
> No. It remains the login form. I must reload the page to see any changes. I
> will continue testing and try to come up with a reproducible report.

Do you see any changes after the fix? I don't.