Bug 4268 - Footer content needs to be changed/fixed...
: Footer content needs to be changed/fixed...
Status: RESOLVED FIXED
Product: maemo.org Website
Newstyle
: unspecified
: All All
: High critical (vote)
: ---
Assigned To: unassigned
: newstyle-bugs
: http://newstyle.maemo.org
:
:
:
  Show dependency tree
 
Reported: 2009-04-13 18:13 UTC by Tim Samoff
Modified: 2009-04-22 17:26 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tim Samoff (reporter) maemo.org 2009-04-13 18:13:05 UTC
STEPS TO REPRODUCE THE PROBLEM: Global footer.

EXPECTED OUTCOME:
Except where otherwise noted, content on this site is licensed under a Creative
Commons Attribution 3.0 License | Terms of Use | Privacy Policy | Powered by
Midgard CMS

ACTUAL OUTCOME:
Terms of use | Privacy Policy [CC Icon], unless otherwise specified. Powered by
Midgard CMS

OTHER COMMENTS:
Please pay attention to capitalization (e.g., "Terms of Use" as opposed to
"Terms of use"). Make sure 'pipes' are properly colorized so that they are
visible. Since the footer content is rather long, it may work better if
centered (if not, it needs to be pushed to the right so that it is not so close
to the edge of the footer bg graphic).

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US;
rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Comment 1 Niels Breet maemo.org 2009-04-14 17:38:05 UTC
Problem with this text is that it is way too long. It doesn't fit inside the
footer when for example viewing the page on a tablet.

I'll commit it anyway, so you can see it.
Comment 2 Tim Samoff (reporter) maemo.org 2009-04-15 03:30:20 UTC
Well, centering the content (as suggested in the initial bug report) would make
it look better on larger screens, but I understand what you're saying... I
would be fine with changing the text to:

Legal | Terms of Use | Privacy Policy | Powered by Midgard CMS

...where "Legal" links to a page that explains it all. But, I'd love for others
to weigh in on this.
Comment 3 Quim Gil nokia 2009-04-15 09:36:16 UTC
"Powered by Midgard CMS" - is this really needed?

Most of *.maemo.org is actually not powered by Midgard and that kind of notices
are a bit... so... 90's?

If we need to save horizontal space, there we have it.

See also how http://creativecommons.org/ puts the text in 2 lines in their
footer.
Comment 4 Tim Samoff (reporter) maemo.org 2009-04-15 14:03:52 UTC
Thanks, Quim. No one ever asked and we just sort of kept it in order to give
props to Neiman. Also, it is standard practice to leave the "powered by" line
when using an open source CMS. But, I guess you guys pay them, so... Let's
remove it.

There's no quite enough room in the footer background graphic to go to two
lines with the text. We could make that graphic bigger (taller), but I'm not so
sure it would help the design at all.

Any opinions about the "Legal" link?
Comment 5 Quim Gil nokia 2009-04-16 13:38:20 UTC
It's "your" website now so legal, terms of use and etc are only there if you
need them. Nokia will do it's own thing under the *.nokia.com domain.
Comment 6 Tim Samoff (reporter) maemo.org 2009-04-16 14:28:16 UTC
Ok. Good. Let's go with my suggestion and I'll write up text for the "Legal"
page. (Of course, we'll have to alter the other 'footer' page contents as well,
to better represent 'community' views.) And we can remove the "powered by"
stuff.

New content:

Legal | Terms of Use | Privacy Policy

Left justified.
Comment 7 Henri Bergius 2009-04-16 16:35:41 UTC
Having the CC license mentioned even as a hidden link with rel="license" would
allow search engines (and FF extensions, for instance) to know what license the
content is under.
Comment 8 Tim Samoff (reporter) maemo.org 2009-04-16 17:09:26 UTC
Henri, this is a good idea. But, also, users need a place to view "legal" info
if they're curious.
Comment 9 Dave Neary maemo.org 2009-04-16 18:07:26 UTC
There is a "Legal" page. We can certainly link to it in the footer - maybe just
with a "Legal" link? Or in an "About maemo.org" page?
Comment 10 Tim Samoff (reporter) maemo.org 2009-04-16 18:21:12 UTC
The "Legal" link is what I was asking for (Comment #2). With the removal of the
"powered by" link -- making a total of three short links in the footer.
Comment 11 Valério Valério maemo.org 2009-04-17 18:49:22 UTC
The footer also seems to not resize well in some pages, e.g:
http://newstyle.maemo.org/profile/list/

Notes: FF 3.0.5, Ubuntu
Comment 12 Dave Neary maemo.org 2009-04-17 19:09:29 UTC
Comment #11: This is caused by the content <div> missing its </div> I believe
(at least, this is what the DOM inspector is leading me to believe).
Comment 13 Niels Breet maemo.org 2009-04-17 21:15:26 UTC
Yeah, profile style is missing a div. Neithan is aware of that.
Comment 14 Lauri Manner 2009-04-21 23:01:22 UTC
Fixed. The new footer looks odd and empty..
Comment 15 Quim Gil nokia 2009-04-22 08:17:48 UTC
I didn't see that Tim was meaning to remove the CreativeCommons logo and notice
altogether...
Comment 16 Niels Breet maemo.org 2009-04-22 13:27:53 UTC
Guys, can we please come up with a definitive answer? Neithan and I have
changed the footer multiple times now, it would be nice if we did it for the
last time :)
Comment 17 Tim Samoff (reporter) maemo.org 2009-04-22 15:15:27 UTC
The Creative Commons info should now be contained on the "Legal" page... Isn't
this ok? (No, the Legal page has not been edited yet -- and should be.)
Comment 18 Quim Gil nokia 2009-04-22 15:29:15 UTC
alright, my last comment: the footer indeed looks too empty and weird now. What
about bring back the Midgard mention (and we will mention the tool used for the
bugzilla etc templates) and what about adding the CC logo alone. It's ok to
deal with the details in the legal page, but CC is the norm and it is good to
acknowledge it.
Comment 19 Tim Samoff (reporter) maemo.org 2009-04-22 15:53:45 UTC
My only comment is that the small CC looked ugly in the footer. We could just
say "All content CC" and also include a "Legal" link:

All Content CC | Legal | Terms of Use | Privacy Policy | Powered by Midgard,
Mediawiki, etc., & etc...

The "All Content CC" would link to the Creative Commons site.
Comment 20 Dave Neary maemo.org 2009-04-22 17:06:18 UTC
I preter using the CC byline: "CC: Some rights reserved" myself.
Comment 21 Tim Samoff (reporter) maemo.org 2009-04-22 17:26:23 UTC
WFM.:)