Bug 4191 - (int-121042) Account details only partially editable and inconsistent
(int-121042)
: Account details only partially editable and inconsistent
Status: RESOLVED WONTFIX
Product: Email
General
: 5.0/(1.2009.41-10)
: All Maemo
: Low normal with 9 votes (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-03-07 11:55 UTC by Lucas Maneos
Modified: 2010-04-23 18:06 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Lucas Maneos (reporter) 2009-03-07 11:55:06 UTC
SOFTWARE VERSION:
5.2008.43-7

STEPS TO REPRODUCE THE PROBLEM:

1. Configure an IMAP account in modest if one doesn't exist already
2. Try to edit it.

EXPECTED OUTCOME:

All IMAP details can be edited.

ACTUAL OUTCOME:

All fields in the "Incoming" tab (IMAP server hostname & port, TLS/SSL,
authentication) are greyed out.

REPRODUCIBILITY:

Always.  Online state makes no difference, apart from a popup warning that the
account will be disconnected when online.

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.0.7)
Gecko/2009030423 Ubuntu/8.10 (intrepid) Firefox/3.0.7
Comment 1 Andre Klapper maemo.org 2009-03-11 00:38:46 UTC
Confirming.
The Fremantle Spec says for this "Once user has successfully created the
account, the account type cannot be changed."
This only mentions the account *type*, so I hope it's fixed in Fremantle.

@Quim, if you find some time to take a look by opening the "Incoming" tab for
an existing IMAP account in Modest in Fremantle if all fields are still greyed
out...?
Comment 2 Quim Gil nokia 2009-03-11 09:19:38 UTC
Testing with Fremantle w11: the account type can't be changed, but the details
of a specific account (username, incoming server, ssl port, smtp...) can be
edited, yes.
Comment 3 Lucas Maneos (reporter) 2009-03-14 10:53:28 UTC
Does that imply WONTFIX for Diablo?
Comment 4 Andre Klapper maemo.org 2009-03-14 11:39:00 UTC
Yes.
Sorry, Nokia currently does not have resources for this as far as I have been
told here.
Comment 5 Andre Klapper maemo.org 2009-04-28 15:34:29 UTC
Setting Target Milestone to Fremantle SDK beta.
Comment 6 Lucas Maneos (reporter) 2009-05-25 19:37:31 UTC
(In reply to comment #2)
> Testing with Fremantle w11: the account type can't be changed, but the details
> of a specific account (username, incoming server, ssl port, smtp...) can be
> edited, yes. 

Using today's source from git (last commit:
389812a25c06b921408b7a0d965bb8dec6e80245)  the following fields are not
editable:

- User name (incoming)
- Incoming server (IMAP4)
- Use secure authentication
- Port (incoming)
- Secure connection
- User name (SMTP)
- Password (SMTP)
Comment 7 Andre Klapper maemo.org 2009-06-05 15:14:07 UTC
Using Modest in Fremantle w22 this is definitely very very inconsistent.
Removing target milestone.
Comment 8 Andre Klapper maemo.org 2009-06-09 22:49:46 UTC
Forwarding the internal comment and "INVALID" resolution:


> ACTUAL OUTCOME:
> Not being able to edit many account details, plus a good inconsistency.

There is actually no inconsistency, I'll explain why

> What are the reasons that my User names are not editable?

Incoming username is not editable because you have already successfully
connected to the server with that username, so it's correct. Changing the
username makes no sense, you better create a new account.

Outgoing username is not editable if you don't select an authentication
mechanism as it's not needed

> Why can I change the incoming password, but not the outgoing one?

Same answer than before. Outgoing one cannot be edited until you don't select a
secure authentication mechanism.

> Why can't I change the incoming Secure connection, but the outgoing one?
> Why can't I change the incoming Port number, but the outgoing one?

Same. Because you have already successfully completed a connection to the
incoming server. The outgoing port number was not used, connections to outgoing
servers are not started until you really need it.

Closing this bug as invalid for the above reasons.
Comment 9 Lucas Maneos (reporter) 2009-06-10 03:39:30 UTC
(In reply to comment #8)
> Incoming username is not editable because you have already successfully
> connected to the server with that username, so it's correct.

Ok, I can (sort of) see the reasoning.  The outgoing (SMTP) username can be
changed however, even after an email has been sent, so it is inconsistent.

I think the real reason behind this is the filesystem naming scheme (the cache
goes into ~/.modest/cache/mail/imap/<username>__<imaphostname>_<imapport>/),
but there have to be better ways to handle that...

> Outgoing username is not editable if you don't select an authentication
> mechanism as it's not needed

That's correct, listing SMTP username & password in comment 6 was my mistake.

> > Why can't I change the incoming Secure connection, but the outgoing one?
> > Why can't I change the incoming Port number, but the outgoing one?
> 
> Same. Because you have already successfully completed a connection to the
> incoming server.  The outgoing port number was not used, connections to
> outgoing servers are not started until you really need it.

This means that the server configuration (and DNS, where the IMAP server
hostname is concerned) is expected to be immutable after modest has logged in
once.  Not very realistic IMHO.  Also inconsistent with SMTP server
hostname/authentication/security which can be changed even after a successful
connection to it.

Another use case is for testing/debugging: switching the account to 
non-encrypted IMAP when on a secure LAN in order to capture traffic, or
changing the hostname in order to send IMAP traffic through a proxy for the
same reason.
Comment 10 Lucas Maneos (reporter) 2009-11-12 08:57:41 UTC
*** Bug 6118 has been marked as a duplicate of this bug. ***
Comment 11 Keywan Najafi Tonekaboni 2009-11-12 11:57:57 UTC
Hi,

I think the possibility of changing this details is crucial:

Secure authentication
Secure connection
Port

Why?

What if my provider changes the server software and I can't use method X or
they improve there software and I'm able to login with a more secure
connection, which wasn't available before...

I don't understand why it isn't possible to change the servername, but it's
also truth that the need to change it is rare (but once happened to me).

Maybe I should collect all "big design mistakes" and prepare a talk for maemo
summit 2010 ;)
Comment 12 Andre Klapper maemo.org 2009-11-12 12:08:08 UTC
Feel free to vote...
Comment 13 Neil MacLeod maemo.org 2009-12-12 02:23:45 UTC
Firmware: 1.2009.42-11 (N900)

This is nonsense - the reasons given may have some merit, but not allowing
users to change the settings of their accounts once they are setup is complete
rubbish. Expecting users to delete accounts and create new accounts simply
because one setting needs to be changed is ridiculous beyond belief. As has
been suggested elsewhere, the real reason may lie elsewhere...

As it is I'm  trying to setup an account in Modest so that I can login and send
& receive email via my ISPs POP mail server. This is proving to be problematic
due to their unclear methods of authentication and encryption. Due to the
design of Modest I can't change the secure authentication or port settings on
the incoming server for the account I have setup, but I need to change this to
find the right setting. And creating new accounts each time is a total pain.

Please allow all account settings to be modified after the account is setup. It
really is ridiculous to prevent users from changing the setup of their own
account.

Can we reopen this bug? Why is it invalid?
Comment 14 Uwe Kaminski 2009-12-12 09:58:31 UTC
I agree, this would be nice to have.
Comment 15 Lucas Maneos (reporter) 2010-01-12 04:36:24 UTC
*** Bug 7825 has been marked as a duplicate of this bug. ***
Comment 16 Andre Klapper maemo.org 2010-04-23 18:06:52 UTC
Nokia currently has no plans to change the current behaviour. :-/