Bug 4176 - (int-104021) hald-addon-bme-dev is in nokia-binaries & closed for no good reason
(int-104021)
: hald-addon-bme-dev is in nokia-binaries & closed for no good reason
Status: RESOLVED FIXED
Product: System software
HAL
: 5.0-alpha
: All Maemo
: Low enhancement with 1 vote (vote)
: 5.0-beta
Assigned To: Quim Gil
: hal-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-03-03 09:29 UTC by Carsten Munk
Modified: 2009-04-28 15:34 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Carsten Munk (reporter) maemo.org 2009-03-03 09:29:27 UTC
SOFTWARE VERSION:
Fremantle 5.0-alpha

STEPS TO REPRODUCE THE PROBLEM:

Wanting to install hald-addon-bme-dev, and utilize it in similar fashion to
mce-dev which is a development header for a closed source component with a DBus
interface, comparable to libconic, etc.

EXPECTED OUTCOME:

Ability to install hald-addon-bme-dev from fremantle/sdk, free, seperated from
the closed source component, just like mce-dev, as hald-addon-bme-dev is just a
DBus interface to hald-addon-bme and does not in any depend on linking with
hald-addon-bme, binary nor library. 

BME DBus interface has already been largely documented by community in examples
such as Advanced Power (garage.maemo.org/projects/advanced-power), early in 770
times (http://stefans.datenbruch.de/nokia770/),
http://lists.maemo.org/pipermail/maemo-developers/2007-March/045042.html ,
http://www.internettablettalk.com/forums/showthread.php?t=25874 ,  and battery
reporting part is easily visible in 'lshal'. BME DBus interface is also easily
visible through dbus-monitor.

ACTUAL OUTCOME:

hald-addon-bme-dev is provided in nokia-binaries instead of in free component.
Reasons for this may be because it is built from hald-addon-bme source package. 

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

It is also not trivial wether it is legal for GPL programs to utilize
hald-addon-bme-dev, and hence a open dev package might be useful to encourage
development.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6)
Gecko/2009011913 Firefox/3.0.6
Comment 1 Soumya nokia 2009-03-03 10:12:46 UTC
Re-assigning to  System Software to evaluate this.
Comment 2 Andre Klapper maemo.org 2009-03-03 10:25:32 UTC
hald-addon-bme itself is covered by 
https://wiki.maemo.org/Why_the_closed_packages (not the corresponding -dev
package).
Should probably be added to section "packages are included in the
nokia-binaries metapackage offered with the Maemo SDK"?
Comment 3 Quim Gil nokia 2009-03-04 09:03:05 UTC
hald-addon-bme-dev is a transitional package and it's only there to satisfy
current dependencies. ou can safely ignore it. It'll go away once we get the
transition to hal battery namespace interface usage done for our product
components (mce, system-ui, statusbar-battery).

hald-addon-bme provides the hal battery namespace attributes to hal and it's
documented here:
http://people.freedesktop.org/~david/hal-spec/hal-spec.html#device-properties-battery
Comment 4 Andre Klapper maemo.org 2009-04-28 15:34:10 UTC
Setting Target Milestone to Fremantle SDK beta.