Bug 4139 - Autobuilder fails to build packages because of conflicts in base packages
: Autobuilder fails to build packages because of conflicts in base packages
Status: VERIFIED FIXED
Product: maemo.org Website
Autobuilder
: unspecified
: All Linux
: Low blocker (vote)
: ---
Assigned To: Niels Breet
: repositories@maemo.bugs
: https://garage.maemo.org/builder/diab...
:
:
:
  Show dependency tree
 
Reported: 2009-02-20 21:49 UTC by wellu
Modified: 2009-02-22 12:42 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description wellu (reporter) 2009-02-20 21:49:56 UTC
REPRODUCIBILITY:
always

For some reason autobuilder fails to build (any) packages. Seems that the
problem is related to debianutils_2.29maemo2_armel.deb as it conflicts with
passwd in the build system. apt-get simply fails when installing the build
dependencies.

See URL for details.
Comment 1 Jeremiah C. Foster 2009-02-21 14:39:04 UTC
When you say "See URL for details" are you referring to the autobuild log? Or
another URL?
Comment 2 Jeremiah C. Foster 2009-02-21 15:09:54 UTC
From build log;
dpkg: error processing /var/cache/apt/archives/debianutils_2.29maemo2_armel.deb
(--unpack):
 trying to overwrite `/usr/sbin/add-shell', which is also in package passwd

Any time you try to write over core packages you are going to get this message.

Have you tested your build locally? I would point you to the relevant section
of the Maemo policy guide; 

"package installation and un-installation MUST be tested on a device that
does not have extra software installed, before the package is uploaded to the
repositories. Testing package installation in Scratchbox is not enough."
Comment 3 wellu (reporter) 2009-02-21 15:25:53 UTC
(In reply to comment #1)
> When you say "See URL for details" are you referring to the autobuild log? Or
> another URL?
> 

I'm referring to the URL field in Bugzilla of course.
Comment 4 Daniel Martin Yerga 2009-02-21 15:28:43 UTC
The problem here is someone has uploaded a new version of debianutils to the
extras repository. This new version conflict with the passwd package, as the
log indicate. 

So if some package needs install debianutils to be built (very usual) the
process will fail, because the autobuilder will install the last version
available (the one in extras).

The problematic package is here:
binaries:
http://repository.maemo.org/extras-devel/pool/diablo/free/d/debianutils/
source:
http://repository.maemo.org/extras-devel/pool/diablo/free/source/d/debianutils/

The version used in Maemo per default is here:
http://repository.maemo.org/pool/diablo/free/d/debianutils/
Comment 5 wellu (reporter) 2009-02-21 15:35:44 UTC
(In reply to comment #2)
> From build log;
> dpkg: error processing /var/cache/apt/archives/debianutils_2.29maemo2_armel.deb
> (--unpack):
>  trying to overwrite `/usr/sbin/add-shell', which is also in package passwd
> 
> Any time you try to write over core packages you are going to get this message.

Er, right.. This is not *my* package that is causing the problem here as you
can see. See the URL for details.


> Have you tested your build locally? I would point you to the relevant section
> of the Maemo policy guide; 

I've tested the build locally and the previous version has been built using the
autobuilder. Speedometer 0.31, for example, has been succesfully built using
autobuilder. This is not a problem in my package dependencies but a
configuration problem in autobuilder.


> "package installation and un-installation MUST be tested on a device that
> does not have extra software installed, before the package is uploaded to the
> repositories. Testing package installation in Scratchbox is not enough."

Ahem.. As you can see the build does not even start as the autobuilder fails
when apt-getting some base packages that have nothing to do with my package. As
said, it seems to be some kind of conflict between debianutils and passwd.
Comment 6 Jeremiah C. Foster 2009-02-21 21:46:15 UTC
I have replaced the old versions of debianutils with newer ones:

debianutils_2.17maemo2

Please try to upload and build again. 

Thank you.
Comment 7 wellu (reporter) 2009-02-22 10:41:15 UTC
Offending package was removed and the build works again so marking as verified.

IMHO this really isn't a fix for the underlying problem which is the
possibility for anyone to break the autobuilder by submitting packages to
extras-devel. Let's not reopen this bug if this happens again as the real fix
isn't removing packages by hand whenever this happens. Real fix would be to
limit the sources.list in autobuilder or something similar..
Comment 8 Jeremiah C. Foster 2009-02-22 12:42:59 UTC
(In reply to comment #7)

> IMHO this really isn't a fix for the underlying problem which is the
> possibility for anyone to break the autobuilder by submitting packages to
> extras-devel. 

I agree.

> Let's not reopen this bug if this happens again as the real fix
> isn't removing packages by hand whenever this happens. Real fix would be to
> limit the sources.list in autobuilder or something similar..

There is work ongoing to address these issues. Work will be done to improve
quality assurance of new packages as well as stability of the repo.