Bug 4131 - False login status in maemo.org
: False login status in maemo.org
Status: RESOLVED FIXED
Product: maemo.org Website
General
: unspecified
: All Linux
: Low normal (vote)
: ---
Assigned To: Niels Breet
: general@maemo.org
: http://maemo.org
:
:
:
  Show dependency tree
 
Reported: 2009-02-18 12:58 UTC by Timo Härkönen
Modified: 2009-09-15 11:43 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Timo Härkönen (reporter) 2009-02-18 12:58:18 UTC
STEPS TO REPRODUCE THE PROBLEM:
Login to maemo.org

EXPECTED OUTCOME:
User is shown as logged in by showing the logged user's name and the floating
midgard bar is visible.

ACTUAL OUTCOME:
Page looks as the user hasn't logged in. The logged status is shown after
navigating to a page in maemo.org that you haven't visited before logging in or
by refreshing the page. The pages you have visited before logging in also look
like you haven't logged in. Refreshing works with those pages also.

REPRODUCIBILITY:
always

OTHER COMMENTS:
The problem seems to concern also the logout functionality in similar manner.

Not tested on other OS's or browsers other than the ones described below.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.6)
Gecko/2009020911 Ubuntu/8.10 (intrepid) Firefox/3.0.6
Comment 1 Andre Klapper maemo.org 2009-02-18 14:42:02 UTC
This sounds like bug 3788 which should have been fixed as per bug 3788 comment
24
Comment 2 Timo Härkönen (reporter) 2009-02-25 13:24:35 UTC
Seems to be the same bug except this one concerns the maemo.org login behavior
(not wiki.maemo.org as in bug 3788).
Comment 3 Niels Breet maemo.org 2009-02-25 16:48:18 UTC
Timo: Are you going through a proxy? Can you configure your browser to not
cache pages and see if it still happens? This way we can test if it is a local
issue.

I can't reproduce it myself. Using multiple browsers and multiple accounts.
Comment 4 Timo Härkönen (reporter) 2009-02-25 17:59:50 UTC
I'm not using proxy but I am usually behind NAT so I this time I used a direct
connection. I erased all cookies, browsing history, etc. and disabled browsing
history but I couldn't find where to disable page caching on firefox. Results
with firefox were the same as before. I tried login/logout also with IE7 with
all page caching options (that I could find in it) disabled and the maemo.org
pages worked as they should.

It seems that the problem it that the browser is caching pages and not updating
them after login/logout.

I can try if it works with firefox also if someone tells me how to disable page
caching in it.
Comment 5 Uwe Kaminski 2009-04-09 13:52:30 UTC
For me this is a bug too.

I'm not behind a proxy and using Firefox 3.06.
Comment 6 Andre Klapper maemo.org 2009-06-02 12:38:55 UTC
Reassigning to Niels.
Comment 7 Niels Breet maemo.org 2009-09-14 22:14:00 UTC
Is this still happening? There were some changes last month to fix issues with
login. This bug should be solved at the same time.
Comment 8 Timo Härkönen (reporter) 2009-09-15 07:18:11 UTC
(In reply to comment #7)
> Is this still happening? There were some changes last month to fix issues with
> login. This bug should be solved at the same time.
> 

It's not happening anymore so this one can be closed.