Bug 408 - (int-31055) Bluetooth stops working
(int-31055)
: Bluetooth stops working
Status: CLOSED FIXED
Product: Connectivity
Bluetooth
: 2.1
: All All
: Medium normal (vote)
: ---
Assigned To: Maemo QA (deprecated)
: bluetooth-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2006-02-08 20:27 UTC by Peter Westerström
Modified: 2007-09-03 00:17 UTC (History)
6 users (show)

See Also:


Attachments
Some logs showing hci0 in a broken state (13.35 KB, text/plain)
2006-06-18 03:09 UTC, Jeremy Shaw
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Peter Westerström (reporter) 2006-02-08 20:27:17 UTC
I've been using gpsdrive with a bluetooth gps a couple of weeks now. I
am experiencing the bluetooth connection to stop working after all
between a few minutes to half an hour.
After that happens no bluetooth commands works, rfcomm, hcitool scan
reports nothing.

The same happens when I'm using my bluetooth keyboard. After a while I
can no longer connect it.

I'm using retail 3.2005.51-13.
--
Note: More people have experienced similar problem, see maemo-users mailing list.
Comment 1 Maemo QA (deprecated) 2006-05-08 17:48:12 UTC
Claiming ownership.
Comment 2 Maemo QA (deprecated) 2006-05-08 17:52:13 UTC
I'm unable to verify this bug with latest product image due to missing
equipment.

Could someone please verify if this is still an issue with the latest product
image (2006-13)?
Comment 3 Peter Westerström (reporter) 2006-05-08 19:08:42 UTC
Ok, I will try to test this with the latest image.
Comment 4 Maemo QA (deprecated) 2006-05-08 19:32:25 UTC
(In reply to comment #3)
> Ok, I will try to test this with the latest image.

Thanks, I really appreciate the help.
Comment 5 Marius Gedminas 2006-05-26 19:09:57 UTC
I have experienced the problem with firmware version 5.2006.13-7.  Maemo Mapper
stops receiving new data from my Bluetooth GPS after about 20 minutes of usage.
Comment 6 Hans J. Koch 2006-05-26 23:25:26 UTC
(In reply to comment #5)
I can confirm that. I also use 5.2006.13-7 and have the same problems. The 
Bluetooth connection fails after a few minutes. This is reproducible.
Comment 7 Johan Hedberg nokia 2006-05-27 00:26:23 UTC
I've noticed that the firmware of the Bluetooth chip on the 770 crashes (or
something similar) sometimes. In those cases the only thing that helps is to
powercycle the chip using e.g. "hciconfig hci0 reset" or by going to
offline-mode and back to normal-mode. Not sure whether this is the cause of the
problems described in this bug, though. We *might* be able to get an updated
firmware to the 2006 OS release, but at least currently the internal releases
still contain the old firmware.

What I find strange is that there are very few problems reported related to
other RFCOMM connections using e.g. filemanager to access your phone or DUN
connections.
Comment 8 Maemo QA (deprecated) 2006-05-29 11:31:10 UTC
Bug has been reported to upstream maintainer.
Comment 9 Jeremy Shaw 2006-06-18 03:09:50 UTC
Created an attachment (id=76) [details]
Some logs showing hci0 in a broken state

The output of hciconfig -a, dmesg, etc, showing hci0 in a broken state.
Comment 10 Maemo QA (deprecated) 2006-06-20 17:08:39 UTC
Information has been forwarded, thank you for providing it!
Comment 11 Joe LaPenna 2006-06-21 11:14:33 UTC
This bug is still present in the IT2006 software beta. I don't a bluetooth
device with me right now, otherwise I'd attach more worthwhile information.
Comment 12 Ulrich VAN DEN HEKKE 2006-07-25 12:10:37 UTC
Is the problem is corrected on IT2006 Software ?
Comment 13 Marius Gedminas 2006-07-27 01:03:10 UTC
Sadly, yes, and it is even worse.  When Maemo Mapper loses the bluetooth GPS
connection on IT2006, closing the cover and opening it won't bring the
connection back.  In fact, I haven't found a way to do that short of rebooting
the device.

hcitool inq in an xterm returns this error:

  Inquiring ...
  Inquiry failed.: Connection timed out

and the following message appears in dmesg:

  hci_cmd_task: hci0 command tx timeout
Comment 14 Marius Gedminas 2006-07-29 13:32:12 UTC
Correction: sudo hciconfig eth0 reset also fixes the problem.

It is possible that closing the cover used to perform the reset in OS2005.  It
is also possible that it doesn't do so in OS2006 because I disabled the
"disconnect when cover on device" option in connectivity settings.
Comment 15 Maemo QA (deprecated) 2006-08-03 16:56:53 UTC
Re-assign
Comment 16 Andrey Brindeyev 2006-09-17 00:31:03 UTC
It looks like that bluetooth chip stops working after appearing following line
in kernel log:
"Interrupt but no reason irq 0xc1".

Data simply stops updating in Maemo-mapper. Going offline and online, switching
GPS in Maemo-mapper on, off and on again solved problem (because GPS does not
notice about BT chip failure in Nokia 770 and continues to send data to it - all
three lamps are blinking as usual).

I using following GPS HW: Nokia LD-3W
Comment 17 Andrey Brindeyev 2006-09-17 00:33:24 UTC
I'm using OS2006 edition with kernel, patched for 2G MMC support. Same problems
were on official OS2006 kernel.
Comment 18 Jeremy Shaw 2006-10-04 07:12:02 UTC
Is there anything I can do to help fix this bug? I bought the Nokia 770 for my 
girlfriend, who is a writer, so she could take it with her everywhere and write 
whenever she wants.

Paired with a bluetooth keyboard, this works extremely well -- except for the 
fact that the bluetooth crashes more than a dozen times a day causing the OS to 
repeat the last key that was pressed -- which is sometimes the delete key.

I am sure you can imagine that having your keyboard stop working more than a 
dozen times a day, month after month, gets old pretty fast.

I realize that a keyboard is perhaps not a high priority for the 770 market. 
But VoIP does seems to be -- and I can not imagine using a bluetooth headset, 
knowing it will likely crap out in the middle of a call.
Comment 19 Ulrich VAN DEN HEKKE 2006-11-06 18:37:52 UTC
For me, since the last update from Nokia (this month), the problem is resolve.
The connection don't break.

Thanks.
Comment 20 JF HEINTZ 2006-11-24 13:11:41 UTC
Hello,

I am using NAVMAN GPS 4400, a bluetooth GPS receiver and maemo mapper (latest 
version 1.3.2 ).
I have updated the firmware to the latest one I found: SU-18_2006SE_2.2006.39-
14_PR_F5_MR0_ARM.bin .
When I am connecting to the GPS, it seems to work well (the GPS receiver says 
the connection is done) but I have nothing with maemo-mapper. If I restart the 
device, I sometimes get one exact position, but I have nothing more. I have to 
restart the Nokia to get another one, but it is not always working.

I tried with anither GPS receiver (an HOLUX) and everything is working fine, I 
have my position updated constantly.
I tried the NAVMAN GPS 4400 with another bluetooth devide (a cell phone) and 
everything works fine for this one too.

I imagine an incompatibility with Nokia 770 and NAVMAN GPS 4400 but it 
sometimes works.

I can give you stack trace or everything you need if you give me the way to 
get it :)

Thanks,

JF HEINTZ
Comment 21 Neil MacLeod maemo.org 2006-11-27 08:04:17 UTC
JF HEINTZ - you seem to be experiencing something similar to what I'm seeing in
bug 860 when using a Sony Ericsson W950i phone, that is the Bluetooth stack in
the 770 is flakey with some devices while with others it works great.
Comment 22 Neil MacLeod maemo.org 2006-11-27 08:04:58 UTC
Blast - I mean bug 865 not 860!
Comment 23 Jake Kunnari 2007-04-18 15:57:55 UTC
Fixed in latest IT OS2006SE.
Comment 24 elmano carvalho 2007-07-13 00:01:53 UTC
Verified and closed.