Bug 4067 - Message body will not be displayed in modest if sender uses Thunderbird + pgp/mime
: Message body will not be displayed in modest if sender uses Thunderbird + pgp...
Status: RESOLVED DUPLICATE of bug 3369
Product: Email
General
: 4.1.3 (5.2008.43-7)
: ARM Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-02-04 11:31 UTC by Uwe Kaminski
Modified: 2009-02-09 13:31 UTC (History)
1 user (show)

See Also:


Attachments
example message for this issue (1.98 KB, message/rfc822)
2009-02-05 13:40 UTC, Uwe Kaminski
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Uwe Kaminski (reporter) 2009-02-04 11:31:26 UTC
SOFTWARE VERSION:
I used WinXP + Thunderbird 2.0.0.19 + EnigMail 0.95.7


STEPS TO REPRODUCE THE PROBLEM:
1. Install Thunderbird
2. Install Enigmail
3. Configure the application with your personal pgp key(s)
4. In a new message window select pgp/mime and select sign message
5. enter some content into the message body
6. send the message
7. open this message on your tablet using modest (standard mail client)

EXPECTED OUTCOME:
Message will be shown. This includes the message body.

ACTUAL OUTCOME:
Only subject is displayed in modest. The rest of the mail seems to be empty.

REPRODUCIBILITY:
always

MS Outlook Express seems to have the same problem: It only shows Subect and
Header stuff but no body. The only way to read the body in Outlook Express is
to read the source code of the message (Press Ctrl + F3).

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.5)
Gecko/2008120122 Firefox/3.0.5
Comment 1 Andre Klapper maemo.org 2009-02-04 14:20:52 UTC
Hi,
can you please attach a complete received message (remove any confidential data
 before) so we can take a look at the mime structure?

Bug 3369 and http://bugzilla.gnome.org/show_bug.cgi?id=266147 might be somehow
related here.
Comment 2 Uwe Kaminski (reporter) 2009-02-05 13:40:05 UTC
Created an attachment (id=1118) [details]
example message for this issue
Comment 3 Andre Klapper maemo.org 2009-02-09 13:31:30 UTC
Yepp, it's the same as bug 3607 which is a dup of bug 3369 - not parsing the
text/plain part of a multipart/* message.


<snip>
Content-Type: multipart/signed; micalg=pgp-sha1;

 protocol="application/pgp-signature";

 boundary="------------enigBD59EE9F30BFBB7D062BEFBA"


This is an OpenPGP/MIME signed message (RFC 2440 and 3156)

--------------enigBD59EE9F30BFBB7D062BEFBA
</snip>

*** This bug has been marked as a duplicate of bug 3369 ***