Bug 4053 - (int-152519) Confusing behaviour when saving to a file that matches an existing directory
(int-152519)
: Confusing behaviour when saving to a file that matches an existing directory
Status: RESOLVED FIXED
Product: Images and Camera
Image viewer
: 5.0/(2.2009.51-1)
: All Maemo
: Low normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: image-viewer-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-01-29 12:32 UTC by timeless
Modified: 2010-03-15 20:54 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description timeless (reporter) 2009-01-29 12:32:55 UTC
Steps:
1. open file manager
2. select the images folder
3. tap new folder
4. enter "Z.png"
5. tap ok
6. open images
7. app menu>image>save a copy...
8. enter "Z"
9. tap ok

Actual Results:
8. (?) Replace existing file of same name?
9. Not Allowed

Expected Results:
a. don't show me a dialog that talks about a file that doesn't exist
b. don't give me an error that says 'not allowed', it doesn't mean anything to
a user (or a translator)
Comment 1 Andre Klapper maemo.org 2009-03-30 17:37:11 UTC
Updated status for Fremantle welcome.
Comment 2 Andre Klapper maemo.org 2009-05-28 18:37:40 UTC
WONTFIX for Diablo (not critical).
Fremantle status welcome... -> moreinfo
Comment 3 Lucas Maneos 2009-12-16 02:57:09 UTC
In 1.2009.42-11 (using a Z.jpg directory due to bug 7015)

Actual Results:
8. "Overwrite original file?" (say yes)
9. "Saving Image Z"
10. No error message, Z.jpg directory left intact and still empty, temporary
JPEG file named .imgvwr8N4R4U left behind.
Comment 4 Andre Klapper maemo.org 2010-01-13 18:49:55 UTC
Internal moreinfo:

"After creating folder name with j.peg under Images folder:
1.If trying to rename any image with "z" name it will display"Image name is
already in Use"   (or)
2.Trying to copy any image with "z" name to the Images folder Pop up will
display  with "Replace existing folder of same name?z.jpg" .If press yes ,it
will remove the folder "z.jpg" and file "z" will be copied to the folder.

It is the expected Behaviour.

Is these the same issue your talking?"
Comment 5 timeless (reporter) 2010-01-14 01:04:48 UTC
> Is these the same issue your talking?"

No. Please follow the steps to reproduce. This bug (filed in the Image viewer
component) is about ... the Image viewer, not the file manager.
Comment 6 Andre Klapper maemo.org 2010-02-09 19:29:18 UTC
This has been fixed in package
imageviewer-ui 3.4.05.1+0m5
which is part of the internal build version
10.2010.05-8
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-03-15 20:54:23 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).