Bug 4002 - (int121253/int-118198) Grey out (instead of hiding) Memory cards in File Manager when USB connected
(int121253/int-118198)
: Grey out (instead of hiding) Memory cards in File Manager when USB connected
Status: RESOLVED FIXED
Product: UI Specification
General
: 5.0/(1.2009.42-11)
: ARM Maemo
: Low enhancement with 5 votes (vote)
: Harmattan
Assigned To: Quim Gil
: ui-specification-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-01-14 12:15 UTC by benson
Modified: 2010-06-09 12:23 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description benson (reporter) 2009-01-14 12:15:59 UTC
SOFTWARE VERSION:
5.2008.43-7

STEPS TO REPRODUCE THE PROBLEM:
0. Have at least one SD card in tablet
1. Connect tablet to computer with USB cable
2. Open File manager
3. Look in left (tree) pane

EXPECTED OUTCOME:
All SD cards in the tablet are visible; SD cards currently inaccessible (in use
over USB) would be grayed out.

ACTUAL OUTCOME:
SD cards that are used over USB do not appear at all.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
n/a

OTHER COMMENTS:

This can evidently be confusing for new users, who may connect their tablet to
their PC, drag files to it, then look in the File manager for those files
without disconnecting. One example in <a
href="http://www.internettablettalk.com/forums/showthread.php?t=26189">this
thread</a> at itT.

If a user tries to select a USB-used SD, maybe a message box should pop up
indicating the reason the SD card is unavailable and/or instructions to make it
available, e.g.:

"$CARDNAME in use. Disconnect USB cable."


User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030707
Comment 1 Andre Klapper maemo.org 2009-01-14 15:30:09 UTC
I think I'm going to vote for this one too, as I was also confused by it. :-)

This is still a valid request for the Fremantle Specs about File management:
  "When the Device is connected to PC with USB
  [...]
  The memory card branch is removed from the Hierarchical Listbox"

WONTFIX for Diablo - Nokia will not change any Diablo UI Specifications
anymore, as far as I know.
Comment 2 Quim Gil nokia 2009-01-25 21:20:05 UTC
Sound like an interesting proposal.
Comment 3 Andre Klapper maemo.org 2009-06-08 13:13:03 UTC
This is a WONTFIX for Fremantle and it will be considered to display a
"connected to USB" info message/icon instead.
Comment 4 Quim Gil nokia 2009-06-08 13:19:52 UTC
Wait, wait. The problem has been acknowledge but has been considered to be not
big enough to change the Fremantle work now.

Reopening and targetting Harmattan.
Comment 5 Andre Klapper maemo.org 2010-06-09 12:23:01 UTC
This will work fine in Harmattan. Closing.