Bug 3987 - Documentation links broken
: Documentation links broken
Status: RESOLVED FIXED
Product: Developer Guide
maemo.org wiki
: 4.1.x
: All Linux
: Low normal (vote)
: ---
Assigned To: Jarmo Tikka
: documentation@maemo.org
: http://maemo.org/maemo_training_mater...
:
:
:
  Show dependency tree
 
Reported: 2009-01-07 11:12 UTC by Jonathan Steinert
Modified: 2010-05-17 16:44 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jonathan Steinert (reporter) 2009-01-07 11:12:15 UTC
http://maemo.org/maemo_training_material/maemo4.x/

Link at bottom for source code of examples is broken (404)

http://maemo.org/maemo_training_material/maemo4.x/files/

Assigned to General because there is no "Documentation" component in bugzilla.

Cheers
Comment 1 Quim Gil nokia 2009-01-07 14:15:30 UTC
Thanks! Confirmed.

Error 404: Page could not be found.
The requested URL /maemo_training_material/maemo4.x/files/ could not be found
on this server.

Wed, 07 Jan 2009 14:13:45 +0200


Moving to right product-component.
Comment 2 Andre Klapper maemo.org 2009-05-20 15:19:59 UTC
...and this is still valid after 5 months, sigh.
Is Jarmo the correct assignee for such stuff at all?
Does it make sense to CC Dave?

STEPS:
1. Go to http://maemo.org/maemo_training_material/maemo4.x/ .
2. Try any of the links.

RESULT: 404

SOLUTION: Please remove completely as this has been moved to
http://maemo.org/development/training/ .
Comment 3 Dave Neary maemo.org 2009-05-20 20:59:24 UTC
The problem is I don't know how to modify the links on the original page, and I
don't know where the files really are.

Where is this stuff stored? On what server? How was it uploaded? Isn't the 4.x
stuff completely outdated now?

I definitely want to stay CCed, but it's because I want to learn how this is
done.
Comment 4 Dave Neary maemo.org 2009-05-20 21:11:25 UTC
Look at http://maemo.org/maemo_training_material/maemo4.x/html/

The problem is that the directories got moved to "_Chinook" but the links
didn't get updated. I don't know where the source files are kept or how they're
generated, but I probably should.

From what I can see, the 4.x training material is linked from
http://maemo.org/development/training/chinook/ - and I have corrected all the
links there.

The root page you point to shouldn't be linked to from anywhere (if it is, it's
probably only here that it's still linked) - and all of the links are correct
in the places where I have control over them.

Is that good enough to close this bug? Or can you point me to any page where
there's a link to http://maemo.org/maemo_training_material/maemo4.x/ ?
Comment 5 Andre Klapper maemo.org 2009-05-25 18:14:51 UTC
(In reply to comment #4)
> The problem is that the directories got moved to "_Chinook" but the links
> didn't get updated. I don't know where the source files are kept or how they're
> generated, but I probably should.

Can you investigate here?
Comment 6 Jarmo Tikka nokia 2009-05-28 09:48:44 UTC
Valid links for maemo training material are in mameo.org Dcoumentation pages
here: http://maemo.org/development/training/ (index page)
http://maemo.org/development/training/maemo_technology_overview_content.html
http://maemo.org/development/training/maemo_getting_started_content.html
http://maemo.org/development/training/maemo_application_development_content.html
http://maemo.org/development/training/maemo_platform_development_content.html

Chinook version of training courses are no longer supported as from training
material point of view Chinook and Diablo are so close together that there is
no point to maintain Chinook anymore. Diablo training material can  be used
also for Chinook if needed. Most probably nobody wants to have Chinook courses
as Diablo platform can be flashed to all devices...
Comment 7 Dave Neary maemo.org 2009-05-28 13:30:56 UTC
Hi Jarmo,

The point is that the old links are still referenced (in blog entries, on the
website in some places, and on the page linked in the URL field here). I have
minimised the effect by ensuring that the new training material is referenced
everywhere, but the fact is that previously working links don't work any more -
and so we need to fix that.

There are two ways to fix that which I can see: 
1. Ensure the old links redirect to Chinook training material
2. Ensure that the old links redirect to Diablo training material

Unfortunately, I have no idea how to install redirects with Midgard, and I
don't know where these pages are stored on the web server, or have access to
the server, to manually set up redirects.

Dave.
Comment 8 Jarmo Tikka nokia 2009-12-28 17:03:44 UTC
I do not know either how Midgard pages could be redirected. We have this
generic problem with Midgard that couple of times in year we move stuff around
and although we try to maintain internal integrity (maemo.org site internal
links are usually fixed) there are a lot of references from outside maemo.org
site that cannot be fixed by us.

I close this now as fixed and let's try not to move that Maemo training
material anymore from this URL http://maemo.org/development/training/

Starting to use Maemo Info Center for official documentation solves this
problem somewhat as it introduces link to the latest Mameo platform release 
http://library.maemodocs.nokia.com/ which redirects to the altest platform
specific URL like 

http://library.maemodocs.nokia.com/fremantle/index.jsp for now and to 
http://library.maemodocs.nokia.com/harmattan/index.jsp when Harmattan docs will
be available
Comment 9 Dave Neary maemo.org 2010-01-05 13:11:00 UTC
Henri knows how to redirect Midgard pages, as does Rambo & Neithan.
Comment 10 Andre Klapper maemo.org 2010-05-17 16:44:12 UTC
[Rearrangement of Documentation bug reports.]
Mass-moving old closed Developer Platform > Documentation tickets.
You can filter bugmail by searching for this comment.