Bug 3972 - Improve the usability of maemo.org site
: Improve the usability of maemo.org site
Status: RESOLVED FIXED
Product: maemo.org Website
General
: 4.1
: All All
: Medium enhancement (vote)
: ---
Assigned To: Dave Neary
: general@maemo.org
: http://maemo.org
:
:
:
  Show dependency tree
 
Reported: 2008-12-30 11:31 UTC by Jarmo Tikka
Modified: 2009-04-28 18:43 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jarmo Tikka (reporter) nokia 2008-12-30 11:31:18 UTC
STEPS TO REPRODUCE THE PROBLEM:

Go to maemo.org and try to find out what documents and examples are available
for certain tehnology area or to have an overview of the whole documentation
available.

EXPECTED OUTCOME:

From maemo.org front page it is clear what is the latest maemo release and
where it is documented. No need to go through the whole menu structure to find
out that. For latest (and older) maemo releases available documentatin can be
found also based on technology are it covers (in addition to maemo release).

ACTUAL OUTCOME:

To find out what is the latest maemo release you have to go through
annuncements or site menu structure. To find out documentation to latest maemo
release you have to go through all submenu items from Development menu (that
include documentation for all releases)

OTHER COMMENTS:

See bug 3803 for earlier discussions. Some key comments copied below.
****
Changed Severity to enhancement and target milestone to Fremantle. Current
maemo.org has usability problems that it is very difficult to find anything
from the site :). 

I just copy this item below from my todo list for maemo.org as proposal for new
spec:

mameo.org usability issues
- current structure of site does not allow user to see what maemo release
specific documentation is available in maemo.org without going through the
whole menu structure 
- enable easy access to all maemo release specific documentation with new
release specific summary pages 
- release info pages include basic release info and links to all release
specific documentation 
- get rid of current site structure where user has to first choose (or quess)
what type of document he needs to read (API doc, how-to, training material,
...) and then choose for which maemo release that needs to be done (2.2, 3.x,
4.0.x 4.1.x, ..) 
- instead change maemo.org site structure to support easy access for maemo
release specific documentation (maemo release summary pages) 
- instead change maemo.org site structure to support easy access for maemo
technology area specific documentation (maemo technology summary pages) 
- review maemo.org front page to better support easy access to maemo.org
services and site sections for the latest maemo version (e.g. to the latest SDK
release, documents, search, wiki, bugzilla, planet, garage, mailing lists,
repositories, lxr, ...) 
- add site map page (information and links to maemo.org pages and sections on
one page) 
  - maemo mailing lists 
  - IRC channels 
  - RSS feeds 
  - repositories available and their usage 
  - bugzilla, wiki, planet, etc 
  - external maemo related sites 
  - most important open source projects maemo uses/hosts 
--------------------------------------------------------------------------------
Comment #5 from luarvique@gmail.com   2008-12-08 16:36:26 GMT+3 [reply] 
I would suggest setting lower, more practical, short range goals:

1. Survey available documentation/howto/reference pages.
2. Create a SINGLE easily navigated page with all the documentation
   for the latest release (4.1 and whatever parts of 4.0 still apply).
3. Create similar SINGULAR pages for each older release we have got the
   documentation for.

These goals are easier to achieve, do not really rely on Fremantle, and will be
of immediate help to developers.

Please, refer to the "Development" section of the mockup at

http://fms.komkon.org/MaemoMain.html

This is how I see the single-point documentation page.
--------------------------------------------------------------------------------
Comment 1 Andre Klapper maemo.org 2008-12-30 13:13:39 UTC
*** Bug 3973 has been marked as a duplicate of this bug. ***
Comment 2 Eero Tamminen nokia 2008-12-30 16:55:59 UTC
> Please, refer to the "Development" section of the mockup at:
> http://fms.komkon.org/MaemoMain.html

This seems pretty nice.  There's too much stuff (e.g. blogs / announcements
shouldn't be on the same page with documentation index) though, was this really
intended to be single page?
Comment 3 Quim Gil nokia 2008-12-30 17:05:24 UTC
This enhancement request is a bit redundant since there is a lot of work being
done in maemo.org throught the regular sprint process.

See 

http://wiki.maemo.org/Task:Improving_maemo.org
http://wiki.maemo.org/Task:Improving_maemo.org/Development

And other documentation and mockups available from those pages.
Comment 4 luarvique 2008-12-30 17:10:23 UTC
(In reply to comment #2)
> > Please, refer to the "Development" section of the mockup at:
> > http://fms.komkon.org/MaemoMain.html
> This seems pretty nice.  There's too much stuff (e.g. blogs / announcements
> shouldn't be on the same page with documentation index) though, was this really
> intended to be single page?
No, it was simply a mockup and I modeled all the requested pages in a single
HTML document. You can ignore the rest of this mockup, just the Documentation
part is relevant to this bug tracker.
Comment 5 luarvique 2008-12-30 17:13:26 UTC
(In reply to comment #3)
> http://wiki.maemo.org/Task:Improving_maemo.org
> http://wiki.maemo.org/Task:Improving_maemo.org/Development
Looking at these documents, I can't help but wonder whether the result will be
better than the current design or even worse.
Comment 6 Quim Gil nokia 2008-12-30 17:30:59 UTC
(In reply to comment #5)
> Looking at these documents, I can't help but wonder whether the result will be
> better than the current design or even worse.

Such statement is not useful for any progress. Your feedback is welcome at
https://lists.maemo.org/mailman/listinfo/maemo-community , where the discussion
has been ongoing for a couple of months now. You can find thee the people
working on this, and even help them.
Comment 7 Dave Neary maemo.org 2009-01-05 16:54:07 UTC
(In reply to comment #5)
> > http://wiki.maemo.org/Task:Improving_maemo.org
> > http://wiki.maemo.org/Task:Improving_maemo.org/Development
> Looking at these documents, I can't help but wonder whether the result will be
> better than the current design or even worse.

As Quim said in comment #6, this comment alone is not useful. We are having an
active and ongoing conversation about the revised Maemo website on the
maemo-community mailing list, and your comments and reactions are welcome
there. Any revisions you propose, if they are good ideas, will be integrated
into the design.

The time to participate in this discussion is now, though - we're already
working with designers on getting the new site ready, and I hope it will be
available for release soon now. If you want to add comments here, I will
receive them, but really the best place to reach everyone involved in the new
design, and thus advocate your ideas for the new design, is on the
maemo-community mailing list.
Comment 8 Dave Neary maemo.org 2009-04-28 18:43:21 UTC
Closing this bug as FIXED with the release of the new redesign. If there are
any specific changes which you would like to request to the new site, please
open individual bugs for each request.