Bug 3956 - (int-116012) osso-applet-accounts can't use IRC/SIP/GTalk port > 32767
(int-116012)
: osso-applet-accounts can't use IRC/SIP/GTalk port > 32767
Status: VERIFIED FIXED
Product: Chat & Call & SMS
General
: 5.0-beta
: All Linux
: Low normal with 1 vote (vote)
: 5.0 (1.2009.41-10)
Assigned To: rtcomm@maemo.org
: communication-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-12-23 22:40 UTC by ubIx
Modified: 2009-10-22 07:02 UTC (History)
4 users (show)

See Also:


Attachments
Screenshot of the error message (68.85 KB, image/png)
2008-12-23 22:59 UTC, ubIx
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description ubIx (reporter) 2008-12-23 22:40:25 UTC
SOFTWARE VERSION:    5.2008.43-7 and osso-accounts-plugin-idle  0.2-1.4
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM: assign a "new chat" with IRC and a port > 32767

EXPECTED OUTCOME: highest value is 32767

ACTUAL OUTCOME:

REPRODUCIBILITY:  every time if a new chat was created
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED:  osso-accounts-plugin-idle  0.2-1.4

OTHER COMMENTS:   Create a new IRC chat account and open extended settings

User-Agent:       --
Comment 1 ubIx (reporter) 2008-12-23 22:59:10 UTC
Created an attachment (id=1075) [details]
Screenshot of the error message

Screenshot of the error message of "osso-accounts-plugin-idle" 0.2-1.4 if a IRC
port > 32767 will be used
Comment 2 ubIx (reporter) 2008-12-23 23:07:20 UTC
I will use a IRC with a port above 32767 (for example 46667) but on the Nokia
standard chat tool with "osso-accounts-plugin-idle" in Version 0.2-1.4 it
doesn't work.
Comment 3 Lassi Syrjälä nokia 2008-12-29 15:37:36 UTC
As a workaround, one could use the mc-account cli tool:

To get the account name, do:
$ mc-account list

To set a port higher than is allowed by the UI:
$ mc-account set <account name> int:port=46667
Comment 4 ubIx (reporter) 2008-12-29 21:23:22 UTC
(In reply to comment #3)
> As a workaround, one could use the mc-account cli tool:
Create chat on port 6667 => no connectio

> To get the account name, do:
> $ mc-account list
output are:
idle1 ((null))
idle0 ((null))

> To set a port higher than is allowed by the UI:
> $ mc-account set <account name> int:port=46667
with:
mc-account set idle1 int:port=46667
set with no output
But the Chat Button blink green/read
Comment 5 Andre Klapper maemo.org 2009-01-14 16:29:00 UTC
ub1x, do you know if there is a reason for not supporting ports > 32767?
I wonder because there are other apps out there that also do not support this,
e.g. http://windrop.sourceforge.net .
So there might be some reason, and this reason might make this an enhancement
request instead of a real bug.

As far as I know RTP traditionally uses the 16384-32767 range, but this is just
common and not defined by any RFC like 3550.


Reducing severity as a workaround has been offered.
Comment 6 ubIx (reporter) 2009-01-14 22:06:43 UTC
Hi Andre,

I find on my /etc/services that the ports are defined in RFC4340, Section 19.9. 
In this I found the following:
"The Well Known Ports are those from 0 through 1023, the Registered Ports are
those from 1024 through 49151, and the Dynamic and/or Private Ports are those
from 49152 through 65535."
For me (I'm not an expert), is it a false defined variable (? I don't know if
its the right word for this) - The value should be a unsigned integer and not a
signed.
Comment 7 Andre Klapper maemo.org 2009-03-24 14:46:05 UTC
Mikhail, do you know if this is a useful restriction and if this restriction is
still valid in Fremantle?
If it is, is it worth to change (by importing the ticket)?
Thanks in advance.
Comment 8 Lucas Maneos 2009-03-24 21:48:15 UTC
This is not specific to IRC, the GUI doesn't allow setting SIP or XMPP
accounts' ports to values > 32767 either.  Reassign to Control panel or UI
spec?

There really isn't a good reason for not being able to access half the
available port space.  A signedness issue (comment 6) sounds likely - my best
guess is that the check is comparing with INT16_MAX instead of UINT16_MAX (but
I can't prove it).
Comment 9 Andre Klapper maemo.org 2009-05-28 18:44:54 UTC
Mikhail, do you know if this is a useful restriction and if this restriction is
still valid in Fremantle?
If it is, is it worth to change (by importing the ticket)?
Thanks in advance.
Comment 10 Mikhail Zabaluev nokia 2009-05-29 12:30:28 UTC
(In reply to comment #9)
> Mikhail, do you know if this is a useful restriction and if this restriction is
> still valid in Fremantle?
> If it is, is it worth to change (by importing the ticket)?

Idle has not been a product component and it still isn't for what I can tell.
We need to make clear who should maintain the extra components, and forward the
bug accordingly.
Comment 11 Lucas Maneos 2009-05-29 14:36:11 UTC
This seems to affect all account types (at least SIP and XMPP).  I guess I
should have changed product/component/summary after comment 8, sorry for the
confusion.  I *think* osso-applet-accounts is the right package but I could be
wrong.
Comment 12 Mikhail Zabaluev nokia 2009-05-29 14:53:56 UTC
(In reply to comment #11)
> This seems to affect all account types (at least SIP and XMPP).  I guess I
> should have changed product/component/summary after comment 8, sorry for the
> confusion.

Ah, sorry about the confusion.
Please import the bug so that we can verify it's properly fixed in Fremantle.
Comment 13 Andre Klapper maemo.org 2009-05-31 14:37:03 UTC
The current Fremantle Spec correctly says "The port number should be in range
1-65536" and this issue has been FIXED in the code a few days ago internally.
Hence closing as FIXED for Fremantle.
WONTFIX for Diablo as only critical issues will receive fixes if at all.


STEPS TO REPRODUCE for Diablo 5.2008.43.7:
1. Go to Settings > Control Panel > Connectivity > Accounts
2. Set up a new account by clicking "new"
a3. Choose Service == Google Talk and click "Advanced"
a4. Deactivate "Auto-detect STUN"
a5. Enter STUN port == 35600
b3. Choose Service == IRC and click "Advanced"
b4. Enter Port == 35600
c3. Choose Service == SIP and click "Advanced"
c4. Enter Port == 35600

ACTUAL OUTCOME FOR ALL TESTCASES:
Get "Maximum value is 32767" popup.