Bug 3942 - (int-96579/int-117876) Reply quoted with multiple mime parts shows signature instead of message text
(int-96579/int-117876)
: Reply quoted with multiple mime parts shows signature instead of message text
Status: RESOLVED DUPLICATE of bug 3369
Product: Email
General
: 5.0-beta
: All All
: Medium major (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-12-20 10:13 UTC by Andrew Flegg
Modified: 2009-05-19 19:26 UTC (History)
3 users (show)

See Also:


Attachments
Received email from maemo-developers demonstrating problem (8.42 KB, text/plain)
2008-12-20 10:14 UTC, Andrew Flegg
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Andrew Flegg (reporter) maemo.org 2008-12-20 10:13:47 UTC
SOFTWARE VERSION:
4.2008.36-5 & 5.2008.43-7 (at least)

STEPS TO REPRODUCE THE PROBLEM:
* Get the attached email into modest somehow (I received it from
  maemo-developers)
* Set plain text composition as the default:
    Tools > Settings > Composing > Default mesage format: Plain text
* Reply to the message

EXPECTED OUTCOME:
Composition window shows:

    <blockquote>
    On Fri, 19 Dec 2008 10:54:57 +0800, Alex T. W. LEUNG wrote:
    >
    > Hi maemo team,
    >
    > Here is my wish:
    [...]

    -- 
    my signature
    </blockquote>

ACTUAL OUTCOME:
Composition window shows:

    <blockquote>

    ----- Original message ------
    >    
    > _______________________________________________
    > maemo-developers mailing list
    > maemo-developers@maemo.org
    > https://lists.maemo.org/mailman/listinfo/maemo-developers

    --
    my signature
    </blockquote>

REPRODUCIBILITY:
sometimes

EXTRA SOFTWARE INSTALLED:
n/a

OTHER COMMENTS:
This looks like it could be related to multipart MIME emails, and in the
attached example there are two parts of type text/plain - one the original
email, the other the mailing list signature applied by the mailing list
software powering maemo-*.

Also, the attribution line in the expected outcome is under #2563.


User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB;
rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Comment 1 Andrew Flegg (reporter) maemo.org 2008-12-20 10:14:30 UTC
Created an attachment (id=1071) [details]
Received email from maemo-developers demonstrating problem
Comment 2 Andre Klapper maemo.org 2008-12-22 17:02:46 UTC
Confirming - I could reproduce this constantly.
Comment 3 Quim Gil nokia 2009-05-10 02:05:50 UTC
Can someone send me an email at quimgil gmail to test it with Fremantle? Thanks
Comment 4 Lucas Maneos 2009-05-10 16:46:43 UTC
(In reply to comment #3)
> Can someone send me an email at quimgil gmail to test it with Fremantle? Thanks

Sent today's maemo-developers digest.  BTW this looks like it has the same root
cause as bug 3369.
Comment 5 Quim Gil nokia 2009-05-19 00:05:14 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Can someone send me an email at quimgil gmail to test it with Fremantle? Thanks
> 
> Sent today's maemo-developers digest.  BTW this looks like it has the same root
> cause as bug 3369.

To start with, the only content I can see in that email is the footer.

_______________________________________
maemo-developers mailing list
(((email)))
(((listinfo URL)))

In any case, the result after pressing the reply button is:

|
--
(((signature)))
----- Original message -----
> _______________________________________
> maemo-developers mailing list
> (((email)))
> (((listinfo URL)))
Comment 6 Andrew Flegg (reporter) maemo.org 2009-05-19 00:12:38 UTC
Sounds like it's not FIXED.
Comment 7 Andre Klapper maemo.org 2009-05-19 19:12:26 UTC
Sergio said that there are currently no plans to fix this because there hasn't
been time for that. Hence still valid in Fremantle.

"If you have several plain text mime parts there is no easy way to know which
one is the important part. So the solution would be to show them all."
Comment 8 Andrew Flegg (reporter) maemo.org 2009-05-19 19:16:39 UTC
(In reply to comment #7)
>
> "If you have several plain text mime parts there is no easy way to know which
> one is the important part. So the solution would be to show them all."

So why isn't showing them all an option? Seems to be a pretty important part of
dealing with modern email, and just bluntly not handling it - for two releases
- seems to reinforce the quality issues with modest (just when it was looking
so shiny in Fremantle)
Comment 9 Andre Klapper maemo.org 2009-05-19 19:26:13 UTC
Yes, Sergio said that this is the same issue as bug 3369.

*** This bug has been marked as a duplicate of bug 3369 ***