Bug 3917 - (int-95830) Missing Large File Support (CONFIG_LFS) in Busybox
(int-95830)
: Missing Large File Support (CONFIG_LFS) in Busybox
Status: RESOLVED FIXED
Product: Core
Busybox
: 4.1.2 (4.2008.36-5)
: N810 Linux
: Low normal (vote)
: 5.0-alpha
Assigned To: unassigned
: busybox-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-12-07 23:13 UTC by Penguinbait
Modified: 2009-03-02 13:36 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Penguinbait (reporter) maemo.org 2008-12-07 23:13:28 UTC
SOFTWARE VERSION:
(Control Panel > General > About product) 
36-5

STEPS TO REPRODUCE THE PROBLEM:
Both 'test' and 'rm' and perhaps other tools fail to work on files greater than
2GB.  I recently ran into this problem while working on a backup solution.  I
could with GNU tar greater files larger than 2GB on ext2 FS.  However any
'test' command ran against the files greater than 2GB fail.  Additionally
attempting to remove the file using 'rm' fails as follows:

NOKIA:/TRG/backup ROOT#rm 040200-120608-36120-FULL.tar
rm: cannot stat '040200-120608-36120-FULL.tar': Value too large for defined
data type

I was able to remove the file by running the following.
echo xxx > 040200-120608-36120-FULL.tar
rm 040200-120608-36120-FULL.tar

EXPECTED OUTCOME:
'rm' no output file would be deleted
'test'  All command fail, and exit '1' while they should be exit 0 

ACTUAL OUTCOME:
'rm'
rm: cannot stat '040200-120608-36120-FULL.tar': Value too large for defined
data type

'test' has no output but always exits '1' when complete


REPRODUCIBILITY:
(always/sometimes/once)
ALWAYS

EXTRA SOFTWARE INSTALLED:
NONE

OTHER COMMENTS:
PLEASE INCLUDE FULL GNU TOOLS SUITE IN MAEMO5

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1)
Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1
Comment 1 Ryan Abel maemo.org 2008-12-08 00:32:09 UTC
Is the URL actually relevant to this bug?
Comment 2 Penguinbait (reporter) maemo.org 2008-12-08 00:58:00 UTC
(In reply to comment #1)
> Is the URL actually relevant to this bug?
> 
Uh no, it asked for a URL so I gave it one ;)
Comment 3 Andre Klapper maemo.org 2008-12-09 17:17:52 UTC
I need a mmc card larger than 2GB to test this myself.
...and the Busybox upstream bugtracker has been down for two weeks.

> PLEASE INCLUDE FULL GNU TOOLS SUITE IN MAEMO5
Fremantle will ship a more recent version of Busybox (Diablo includes 1.6.1).
Comment 4 David Horn 2008-12-10 00:03:27 UTC
I can duplicate this problem with the Diablo busybox as well.  Just to test a
theory, I also built a new busybox with the CONFIG_LFS=y (Large File Support)
enabled, and it fixes this problem.

I tested wih a custom busybox 1.6.1, and a busybox 1.13.1 build, and either one
can work with LFS, but unfortunately the default busybox does not have this
enabled.
Comment 5 Andre Klapper maemo.org 2008-12-10 00:41:07 UTC
Confirming as per last comment.
Comment 6 David Horn 2008-12-15 17:46:19 UTC
Adding Eero (eero.tamminen@nokia.com) to the cc: list on this bug since it is
busybox related.
Comment 7 Andre Klapper maemo.org 2008-12-15 17:56:04 UTC
Update: Internal ticket closed as WONTFIX for Diablo, haven't received an
answer about the Fremantle state yet.
Comment 8 Andre Klapper maemo.org 2009-01-18 00:42:14 UTC
Fixed for Fremantle. CONFIG_LFS=y has been set.