Bug 3852 - (int-92269) Boot from mmc/usb: root ext3 filesystem gets mounted as ext2
(int-92269)
: Boot from mmc/usb: root ext3 filesystem gets mounted as ext2
Status: RESOLVED INVALID
Product: System software
File system
: 4.1.2 (4.2008.36-5)
: All All
: Low normal (vote)
: ---
Assigned To: unassigned
: file-system-bugs
:
: community-diablo, easyfix, patch
:
:
  Show dependency tree
 
Reported: 2008-11-10 21:58 UTC by Miguel Angel
Modified: 2010-02-14 14:38 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Miguel Angel (reporter) 2008-11-10 21:58:23 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
Diablo 2008-36
STEPS TO REPRODUCE THE PROBLEM:
Make a ext3 partition on one of the mmc cards and clone system into it.
Configure tablet to boot from mmc
Boot and check the mounted filesystems

EXPECTED OUTCOME:
/ mounted as ext3

ACTUAL OUTCOME:
/ mounted as ext2

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
none that matters, it is a initfs issue

OTHER COMMENTS:
filesystem modules are inserted in wrong order in linuxrc, if ext2.ko is
inserted before ext3.ko, /proc/filesystems will show ext2 before ext3, then
busybox's mount will probe ext2 before ext3 and mount any ext3 filesystem as
ext2.
To avoid that, ext3.ko must be inserted before ext2.ko

FIX:
Line 10 of linuxrc should read:
FS_MOUDLES="mbcache jdb ext3 ext2"

User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5) KHTML/3.5.9 (like
Gecko) SUSE
Comment 1 Andre Klapper maemo.org 2008-11-11 15:04:18 UTC
ext3 file systems are also valid ext2 file system, while it's not the other way
round. Hence a valid request.

Current state of /mnt/initfs/linuxrc in 4.2008.36-5:
FS_MODULES="mbcache ext2 jbd ext3"
Comment 2 Andre Klapper maemo.org 2008-12-14 18:08:07 UTC
Miguel,
the internal copy of this bug was closed as invalid because

"When mounting, you may always specify '-t ext3' parameter. You should dig the
initfs script which is doing the mounting and add '-t ext3' there. Relaying on
module insertion order is fundamentally wrong."

Comments?
Comment 3 Andre Klapper maemo.org 2009-01-02 15:02:23 UTC
No comments here for two weeks, hence closing as INVALID too.
Comment 4 Miguel Angel (reporter) 2009-04-03 18:29:12 UTC
What is fundamentally wrong then is busybox's mount, because it relies on
module order to autodetect the filesystem type.
Changing linuxrc to "mount -t ext3" will have the effect that when inserting an
ext2 formatted mmc, then it will be unable to automount it, and won't be able
to boot from it.
Comment 5 Miguel Angel (reporter) 2010-02-14 14:38:24 UTC
Marking patches of interest to Diablo (Maemo4) community updates, please excuse
the noise.