Bug 3850 - "GPS display" window of Map should give progress information
: "GPS display" window of Map should give progress information
Status: RESOLVED WONTFIX
Product: Map
General
: 4.1.2 (4.2008.36-5)
: All All
: High enhancement with 1 vote (vote)
: ---
Assigned To: unassigned
: map-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2008-11-10 16:10 UTC by Vincent Lefevre
Modified: 2008-12-30 16:56 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Vincent Lefevre (reporter) 2008-11-10 16:10:27 UTC
"GPS display" window of Map should give progress information until first fix
can be obtained. Indeed, though I get gray bars for several satellites, the
first fix can be very long to obtain, say more than 15 minutes.

Progress information should help users to see if they may get a fix soon. It
can also provide useful data for debugging purpose.
Comment 1 Quim Gil nokia 2008-11-17 09:29:00 UTC
Maps is developed by Navicore, an external team. But before even thinking of
asking them...

Is it possible to announce progress in any predictable way? You might have 6
satellites looking like almost get a fix but then drop down to fewer. This is
specially true e.g when driving a car in a city.

For instance, Nokia Maps (e.g. in the E71) shows a "signal strength" status
icon showing whether the current position is based in many stallites (full
level, green), just a few (mid level, yellow), nor not enough/AGPS only.
Comment 2 Quim Gil nokia 2008-12-17 18:10:31 UTC
Any comments? Otherwise I will resolve it as wontfix since, as explained, I´m
not sure such feature would provide really predictable information to users.
Comment 3 Vincent Lefevre (reporter) 2008-12-18 02:47:22 UTC
(In reply to comment #1)
> Maps is developed by Navicore, an external team. But before even thinking of
> asking them...

It could be a separate utility, e.g. a part of "GPS location".

> Is it possible to announce progress in any predictable way? You might have 6
> satellites looking like almost get a fix but then drop down to fewer.

Such information is interesting (progress information should be detailed, e.g.
per satellite). The user may want to know if he'd rater wait for the data to be
completed or he should move somewhere else. Say, after 10 minutes at the same
place, I don't know if I should wait a bit more or if a fix is hopeless.
Comment 4 Neil MacLeod maemo.org 2008-12-22 14:52:14 UTC
(In reply to comment #2)
> Any comments? Otherwise I will resolve it as wontfix since, as explained, I´m
> not sure such feature would provide really predictable information to users.

How do Apple do it? ;-)
Comment 5 Quim Gil nokia 2008-12-22 16:28:09 UTC
(In reply to comment #4)
> How do Apple do it? ;-)

You could ask them.  :) 

Maybe the problem here is to understand what we mean by "progress information".
If the signal strength bar offered by Nokia Maps in S60 is considered by you
"progress information" then I guess we will have it in Maemo too. If you mean
something else please explain.

Also note that Google Maps in S60 doesn't offer "progress information" either.

Both Nokia Maps and Google Maps provide a fix within few seconds in S60
devices, based on A-GPS and the cellular data connection. The need of progress
information is less urgent when you get quick fixes reliably...

Since Maemo 5 will also have cellular data connection, I guess most users will
get a quick fix they will find good enough, without waiting for the real GPS to
provide the accurate fix.
Comment 6 Neil MacLeod maemo.org 2008-12-22 17:04:04 UTC
I think (In reply to comment #5)
> (In reply to comment #4)
> > How do Apple do it? ;-)
> You could ask them.  :) 

My loyalty to this project has prevented me from taking the Apple route, though
it would be interesting to compare their approach with Maemo as they seem to
have UIs down to a fine art.

> The need of progress information is less urgent when you get quick fixes reliably...
> 
> Since Maemo 5 will also have cellular data connection,

Lets face it, if the GPS worked as described this bug almost certainly wouldn't
be required, or it could be handled at a much lower priority (errr... lower
than low even! :)) Maemo 5 or Maemo 4 will make no difference unless the bugs
in the underlying system are fixed.

Bug 3851 is probably the closest thing we have to zeroing in on the current and
ongoing problems with GPS/AGPS - if bug 3851 is fixed this bug could be closed
as WONTFIX.

If you want to add some additional progress feedback to the acquisition display
- which I admit would be nice - I would suggest doing this via dbus messages as
any heavily sanitised user-friendly progress information may be all but
useless, nice to see but not much help at diagnosing a problem.

Perhaps a log of the dbus messages could be made available via an application
menu "Log..." option - App Manager has a diagnostic log, so why not GPS?

Since the GPS component is closed we don't even know what diagnostic
information is available thus we are somewhat ill equipped to know what
additional feedback can be made available unless we compare Maemo with other
GPS implementations. Users of other GPS devices (Garmin etc.) may be able to
offer suggestions.

On a slight tangent, migrating the Maps "grey bar" GPS acquisition display and
world-map display into the Control Panel GPS widget would be a good idea - that
kind of functionality should be centralised and available to all location-aware
apps, having it only available in Maps while having no GPS display/feedback at
all in the GPS Control Panel widget is crazy.
Comment 7 Vincent Lefevre (reporter) 2008-12-22 18:38:38 UTC
(In reply to comment #5)
> Maybe the problem here is to understand what we mean by "progress information".

Something that could explain why after 15 minutes, the user still hasn't got a
fix, though 5 satellites are visible with good signal strength. The tablet
receives data, and the user may want to know things like how much information
is new (and may be useful) and so on.

Under what conditions exactly does one get a fix?

> If the signal strength bar offered by Nokia Maps in S60 is considered by you
> "progress information" then I guess we will have it in Maemo too. If you mean
> something else please explain.

I don't know what the signal strength bar is on the S60 (I don't have one). But
the bars in Maps on the N810 don't give sufficient information: one doesn't
know whether data have been missed. Also satellites may disappear/reappear, and
one doesn't know what's going on at all (are some data cached? discarded? etc).

> Both Nokia Maps and Google Maps provide a fix within few seconds in S60
> devices, based on A-GPS and the cellular data connection. The need of progress
> information is less urgent when you get quick fixes reliably...

Note that one doesn't necessarily have a connection to the Internet or other
devices. And this is in such cases that progress information would be the most
useful (because it will take more time before getting a fix).
Comment 8 Quim Gil nokia 2008-12-25 16:41:24 UTC
I will resolve this as WONTFIX only to be safe, although you will probably will
find the issues behind this report fixed in Maemo 5. A basic status bar will
provide the information about the AGPS and satellites connection. This and the
performance of the GPS and the location framework will be enough for the
average user.

Neil, the decision of adding or not an indicator in the UI is done on the
assumption that the system works. If there is a bug in the system then the
solution is to fix it.

Comment #6 contains som interesting ideas that are not in the scope of this
report. Feel free opening new enhancement requests for them.

(In reply to comment #7)
> Something that could explain why after 15 minutes, the user still hasn't got a
> fix, though 5 satellites are visible with good signal strength. The tablet
> receives data, and the user may want to know things like how much information
> is new (and may be useful) and so on.
> 
> Under what conditions exactly does one get a fix?

I don't think any indicator could answer these questions to the user, nor give
any temptative, realistic time to get a fix in the conditions described.



> I don't know what the signal strength bar is on the S60 (I don't have one). 

The green bar at the bottom right of the imag at
http://europe.nokia.com/A41407067 . It starts at red (no satellites), goes to
yellow when there are some staellites at view but no fix, and green when has
enough satellites to get a fix.

> But
> the bars in Maps on the N810 don't give sufficient information: one doesn't
> know whether data have been missed. Also satellites may disappear/reappear, and
> one doesn't know what's going on at all (are some data cached? discarded? etc).

The "grey bars" info of satellites can be found in Nokia Maps, Maemo Mapper,
etc. They won't be able to give you any progress information either.


> > Both Nokia Maps and Google Maps provide a fix within few seconds in S60
> > devices, based on A-GPS and the cellular data connection. The need of progress
> > information is less urgent when you get quick fixes reliably...
> 
> Note that one doesn't necessarily have a connection to the Internet or other
> devices. And this is in such cases that progress information would be the most
> useful (because it will take more time before getting a fix).

Except that you really can't assess "progress" based on satellites connections.
If you didn't get a fix under a minute or so then it is going to be difficult
to predict any progress. If you are in the move it will be even more
complicated or impossible.
Comment 9 Vincent Lefevre (reporter) 2008-12-25 22:42:12 UTC
(In reply to comment #8)
> I don't think any indicator could answer these questions to the user, nor give
> any temptative, realistic time to get a fix in the conditions described.

I was not asking for a temptative time, just to know if there was some progress
or not, and how much. Currently I don't know anything. I supposed that 3
satellites were enough. But...

> > I don't know what the signal strength bar is on the S60 (I don't have one). 
> 
> The green bar at the bottom right of the imag at
> http://europe.nokia.com/A41407067 . It starts at red (no satellites), goes to
> yellow when there are some staellites at view but no fix, and green when has
> enough satellites to get a fix.

That would be better. But one still needs to know how long one may need to
wait.

> The "grey bars" info of satellites can be found in Nokia Maps, Maemo Mapper,
> etc. They won't be able to give you any progress information either.

I noticed that, hence this RFE.

> If you didn't get a fix under a minute or so then it is going to be difficult
> to predict any progress.

I'm not asking for a prediction. But some information of what has been done. Or
why it is taking so long. The grey bars in Map do not provide reliable
information: I can sometimes get a fix with 3 satellites, sometimes nothing
with 6 or 7 satellites. Sometimes after more than 10 minutes. So, I don't know
whether it is worth to wait for a fix or not.
Comment 10 Vincent Lefevre (reporter) 2008-12-26 16:29:27 UTC
(In reply to comment #8)
> If you didn't get a fix under a minute or so then it is going to be difficult
> to predict any progress.

Reopening since this contradicts what is said on

    http://en.wikipedia.org/wiki/Time_to_first_fix

"This almanac is transmitted repeatedly over 12.5 minutes." So, assuming that
the almanac is not present or not valid[*], waiting for 12.5 minutes is normal,
and getting information about the almanac would be useful, such as: Is it
complete? Otherwise how many percents? Are there "holes" (meaning that one
would have to wait for a second cycle)? Or an estimated time before getting the
almanac completely, assuming no interruptions.

[*] I suppose that this is the cause of not getting a fix, and remember that
I'm not using AGPS. Also, IIRC, I had upgraded Map since the last successful
fix.
Comment 11 tz 2008-12-26 21:10:39 UTC
One thing I did in minigpsd was to include in my taskbar/statusbar/window icon
the status of the satellites.  The dots go from small to large as it gets a
lock, and from deep red to orange to yellow to white (think something like
steel heating).

It isn't optimal (I'm still working on visibility v.s. size v.s. annoyance),
but at least it displays the status as it sees it and you can see if the
satellites are all to one side or dispersed and get an idea of their signal
strength.

I can't decipher the "globe" for the navicore gps status panel.  Nearly every
other device uses something like I did though they usually don't integrate
strength on the circular map.

There is also a $P?NOK sentence which I would assume was designed to give some
status.
Comment 12 tz 2008-12-30 16:39:22 UTC
It is $PNOKU and apparently doesn't show data until there is a lock, but it
appears to have other interesting information.
Comment 13 Quim Gil nokia 2008-12-30 16:56:05 UTC
(In reply to comment #10)
> (In reply to comment #8)
> > If you didn't get a fix under a minute or so then it is going to be difficult
> > to predict any progress.
> Reopening since this contradicts what is said on
>     http://en.wikipedia.org/wiki/Time_to_first_fix

The reasons explained at Comment #8 for resolving this request as WONTFIX are
several and actually none of them was the sentence you are quoting (that could
have been more accurate, I agree).

We don't expect users having to rely on such indicator to solve their location
problems and this is why we don't plan to work on anything like this.

Thank you for your understanding.