Bug 383 - Annoying clicks when audio player stopped and cover is on
: Annoying clicks when audio player stopped and cover is on
Status: CLOSED FIXED
Product: X-Discontinued
Audio player (770)
: 2.1
: 770 All
: Low minor (vote)
: 1.1
Assigned To: Maemo QA (deprecated)
: audio-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2006-01-24 00:21 UTC by Neil MacLeod
Modified: 2008-12-06 16:21 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Neil MacLeod (reporter) maemo.org 2006-01-24 00:21:30 UTC
With headphones attached if I stop the audio player from playing a track but
leave the audio player active, and then put on the cover placing the 770 into
standy the 770 will play annoying clicks through the headphones - loud enough to
be heard in a quiet office.

If the cover is removed, the clicks stop. If the audio player is closed and the
cover replaced then there are no further clicks.

Anyone ealse hearing this? It's not consistently repeatable, but it has happened
on several occassions.

I'm running 3.2005.51-13 firmware.
Comment 1 Neil MacLeod (reporter) maemo.org 2006-02-04 00:22:28 UTC
OK this is more serious - with headphones connected but the cover closed, I'm
sure the constant clicking contributes to the rapid run down of the battery.
Comment 2 Jussi Kukkonen 2006-02-04 18:37:07 UTC
Confirming. I've encountered this with headphones/closed cover.
I'm also using the 2005.51-13 image.
Comment 3 Maemo QA (deprecated) 2006-05-04 13:29:50 UTC
Claiming ownership.
Comment 4 Maemo QA (deprecated) 2006-05-04 13:32:09 UTC
I'm unable to reproduce this issue with the latest product image (2006-13).
Could someone please verify? I've been pulling and pushing the cover off/on for
15 minutes now.
Comment 5 Neil MacLeod (reporter) maemo.org 2006-05-17 04:03:24 UTC
I'm still getting the annoying clicks with 2006.13-7.

In order for me to reproduce this:

1. Headphones connected
2. Open an MP3 playlist (say for an entire album)
3. Replace cover over 770 so that the screen is covered, leaving the audio
player playing the selected playlist
4. At the end of the playlist (still with the cover over the screen) the music
will stop, there will be a few seconds of silence and then the annoying clicks
will start and the 770 will continue clicking until the battery runs down.
Comment 6 Maemo QA (deprecated) 2006-05-17 14:36:40 UTC
(In reply to comment #5)
> I'm still getting the annoying clicks with 2006.13-7.
> 
> In order for me to reproduce this:
> 
> 1. Headphones connected
> 2. Open an MP3 playlist (say for an entire album)
> 3. Replace cover over 770 so that the screen is covered, leaving the audio
> player playing the selected playlist
> 4. At the end of the playlist (still with the cover over the screen) the music
> will stop, there will be a few seconds of silence and then the annoying clicks
> will start and the 770 will continue clicking until the battery runs down.

OK, I was now able to reproduce this behavior. As a note to step 4, few seconds
translated into ~20-30 seconds on my test device. Also, the bug was reproducable
every 5th time, or so, not every time.

However, after being able to reproduce this issue with 2006.13-7, I tried to
reproduce it with the latest IT2006 image and was unable to reproduce the issue. 

Thus, marking bug as FIXED and setting target milestone to Internet Tablet 2006
Software Edition. Please verify the fix after the IT2006SE image has been
publicly released.
Comment 7 elmano carvalho 2007-07-18 16:23:07 UTC
Verfied and Fixed