Bug 3817 - All .desktop files should go to /usr/share/applications/ (deprecate use of /usr/share/applications/hildon/)
: All .desktop files should go to /usr/share/applications/ (deprecate use of /u...
Status: RESOLVED WONTFIX
Product: System software
File system
: 5.0/(2.2009.51-1)
: All Linux
: Low enhancement (vote)
: Harmattan
Assigned To: unassigned
: file-system-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-10-23 22:42 UTC by Thomas Perl
Modified: 2012-03-24 11:41 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Thomas Perl (reporter) 2008-10-23 22:42:47 UTC
On Desktop Linux (Debian, Ubuntu, etc..), .desktop file are installed into
/usr/share/applications/. Maemo forces developers to put .desktop files into
/usr/share/applications/hildon/, creating one additional step for porting
existing apps.

Please fix this by recommending and defaulting to using
/usr/share/applications/ for .desktop files and deprecating the use of
/usr/share/applications/hildon/.

Relevant documentation/specification/"standards":

http://standards.freedesktop.org/menu-spec/latest/ar01s02.html
Comment 1 Quim Gil nokia 2008-10-27 09:34:11 UTC
Good point. Added to http://wiki.maemo.org/Mainstream_Linux_Alignment
Comment 2 Eero Tamminen nokia 2008-10-27 17:52:40 UTC

*** This bug has been marked as a duplicate of bug 1303 ***
Comment 3 Thomas Perl (reporter) 2010-01-11 23:29:57 UTC
(Quoting comment #22 in bug 1301)
> The fact is that Nokia won't fix this in Hildon anymore. Resolving as WONTFIX.

I'm re-opening this bug now, as Quim said in bug 1301 that
~/.local/share/applications won't be supported in Hildon, and this bug (3817)
isn't really a duplicate, as described in my comment 5 to bug 1303:

(Quoting comment #5 in bug 1301)
> Eero: bug 3817 is about getting rid of /usr/share/applications/hildon.
> Although the bugs are related, I just wanted to note that moving from
> /usr/share/applications/hildon to /usr/share/applications is the thing that
> needs to be fixed for bug 3817. Is this what's intended?
> 
> Bug 3817 is also mentioned in http://wiki.maemo.org/Mainstream_Linux_Alignment

I don't expect /usr/share/applications/hildon/ to go away in Fremantle times,
but this should be fixed in Harmattan by using the standard
/usr/share/applications/ location instead of /usr/share/applications/hildon/.

Andre: I don't think that I'm supposed to set the "Target Milestone" field, so
please bring this to the right people's attention :) I've updated the Version
field, though, as it's still an issue in the latest Fremantle version (again,
I'm not expecting this to be fixed in Fremantle times, but suggesting that
Harmattan should have that fix).
Comment 4 Andre Klapper maemo.org 2010-01-19 19:40:39 UTC
Looks like currently for Harmattan only /usr/share/applications/ exists, and no
/usr/share/applications/hildon/ , so this might end up as "Fixed in Harmattan"
(yikes!).
Comment 5 Andre Klapper maemo.org 2012-03-24 11:41:09 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )