Bug 3806 - (int-90375) wlan0 still up after disconnecting from Netopia Cayman 3347WEU
(int-90375)
: wlan0 still up after disconnecting from Netopia Cayman 3347WEU
Status: RESOLVED DUPLICATE of bug 3992
Product: Connectivity
WiFi
: 4.1.2 (4.2008.36-5)
: N810 All
: Medium major (vote)
: ---
Assigned To: unassigned
: wifi-bugs
:
:
:
: 2602
  Show dependency tree
 
Reported: 2008-10-16 19:36 UTC by Vincent Lefevre
Modified: 2009-01-18 00:52 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Vincent Lefevre (reporter) 2008-10-16 19:36:38 UTC
SOFTWARE VERSION:
4.2008.36-5

STEPS TO REPRODUCE THE PROBLEM:
1. Start wifi connection.
2. Enable the home applet "Internet radio".
3. Play some radio (e.g. the default one).
4. Disconnect.
5. Respond "Cancel" to the error msg box "Connection to stream lost.
Reconnect?"

EXPECTED OUTCOME:
The wlan0 interface should no longer be up.

ACTUAL OUTCOME:
The wlan0 interface is sometimes still up. More precisely, "ifconfig" outputs:

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:234934 errors:0 dropped:0 overruns:0 frame:0
          TX packets:234934 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11781451 (11.2 MiB)  TX bytes:11781451 (11.2 MiB)

wlan0     Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:39840 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7058 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:10337989 (9.8 MiB)  TX bytes:1021610 (997.6 KiB)

and "iwconfig" outputs:

wlan0     IEEE 802.11b/g  ESSID:"vinc17"  
          Mode:Managed  Channel:0  Access Point: Not-Associated   
          Bit Rate=0 kb/s   Tx-Power=19 dBm   Sensitivity=0/200  
          RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:70/0  Signal level:-24 dBm  Noise level:-94 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

REPRODUCIBILITY:
sometimes

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

Access Point is:
  Netopia Model 3347W Wireless DSL Ethernet Switch
  Running Netopia SOC OS version 7.5.0
  Product ID 1225.

802.11 Wireless Settings
  * Enable Wireless             On
  * Wireless ID (ESSID)         vinc17
  * Enable Multiple Wirel. IDs  Off
  * Default Channel             6
  * Enable Closed System Mode   Off
  * Block Wireless Bridging     Off
  * Privacy                     Off - No Privacy

Wireless MAC Authentication
  * Enable Wireless MAC Authentication: On

[This is a follow-up to bug 3738]
Comment 1 Andre Klapper maemo.org 2008-10-20 12:06:02 UTC
Thanks, great report!

Could not reproduce in general here, but I don't have that router of course -
wlan0 vanishes after disconnecting.

What does "sometimes" mean? 1 out of 10 attempts?
Comment 2 Vincent Lefevre (reporter) 2008-10-20 13:21:10 UTC
(In reply to comment #1)
> What does "sometimes" mean? 1 out of 10 attempts?

I think a bit more often, but I'm not sure.

Also, I don't think that playing some radio has any effect: with radio, the
problem occurs randomly, but it also occurs randomly with no radio (however I
don't know if something like the auto-update feature is accessing the network).

Is there a way to log what happens when disconnecting?
Comment 3 Andre Klapper maemo.org 2008-10-20 16:27:16 UTC
First thing that comes to my mind is a tcpdump package capture, but might be
the wrong level. See
http://maemo.org/development/documentation/man_pages/tcpdump.html for more
information.
Comment 4 Vincent Lefevre (reporter) 2008-10-30 04:09:27 UTC
A few hours ago, I left home without disconnecting first. Of course, an
automatic disconnection occurred because the router could no longer be reached.
But the wlan0 remained up and running (though usually, under apparently the
same conditions, it goes down).
Comment 5 seager 2008-11-17 17:37:00 UTC
(In reply to comment #4)
> A few hours ago, I left home without disconnecting first. Of course, an
> automatic disconnection occurred because the router could no longer be reached.
> But the wlan0 remained up and running (though usually, under apparently the
> same conditions, it goes down).
> 

This bug is *bad*. When wifi fails to disconnect properly it TURNS OFF
power management on wlan0 and the battery starts to drain *fast* (tablet
only lasts a few hours on idle). The failure to disconnect does not happen
always, but more often than not for me. I've tried various things as
workaround in a cron job: rmmod and modprobe cx3110x, restart wlancond 
and icd2. None work perfectly since they seem to make new connections 
difficult to establish ...
Comment 6 Vincent Lefevre (reporter) 2009-01-18 00:52:04 UTC
In bug 3738, urb said:
> Only very recently, I eventually realized that this bug has never ever
> occurred to me with any AP when the tablet was configured to acquire its
> IP address via DHCP. Therefore, this bug seems to only apply to connections
> having static IP address (Connectivity settings -> Connections -> Edit ->
> Next -> Next -> Advanced -> IP Addresses -> unchecked "Auto-retrieve IP
> address" box).

I also use a static IP address ("Auto-retrieve IP address" box is unchecked).
So, I assume this is the same problem.

Like urb in bug 3738, I mark this bug as a duplicate of bug 3992.

*** This bug has been marked as a duplicate of bug 3992 ***