Bug 3788 - After logging in to Wiki, immediately not logged on next page
: After logging in to Wiki, immediately not logged on next page
Status: RESOLVED FIXED
Product: maemo.org Website
Wiki
: unspecified
: All Linux
: High normal with 3 votes (vote)
: ---
Assigned To: Niels Breet
: midgard@maemo.org
:
:
:
:
  Show dependency tree
 
Reported: 2008-10-07 23:53 UTC by Matan Ziv-Av
Modified: 2009-02-25 13:34 UTC (History)
12 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Matan Ziv-Av (reporter) 2008-10-07 23:53:20 UTC
STEPS TO REPRODUCE THE PROBLEM:

1. Go to a wiki page ( http://wiki.maemo.org/Why_the_closed_packages for
example)
2. Choose "log in" in top right corner
3. Login.
4. Top right cornel has user name.
5. Select "Return to Why the closed packages." link.

EXPECTED OUTCOME:

"Return to Why the closed packages." page with logged in user.

ACTUAL OUTCOME:

"Return to Why the closed packages." page with "log in" link instead.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
No such problems in other pages (garage, maemo.org, bugzilla). 

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; es-ES; rv:1.9.0.2)
Gecko/2008092318 Fedora/3.0.2-1.fc9 Firefox/3.0.2
Comment 1 Quim Gil nokia 2008-10-08 09:02:11 UTC
I'm following your steps and works for me. Maybe is it something with your
local cache?
Comment 2 Matan Ziv-Av (reporter) 2008-10-08 14:56:22 UTC
I have exactly the same problem with Konqueror - first time I used Konqueror
for accessing Maemo.

This problem persists after clearing cache in FF 3.0.2.

This problem also exists when connecting through a different ISP, on a
different computer with FF 1.5. 

Both ISPs do not use any proxies (transparent or otherwise).
Comment 3 Dave Neary maemo.org 2008-10-08 15:44:44 UTC
Just checking - do you have any funny cookies-related settings? If you try
through https rather than http do you have the same trouble?
Comment 4 Matan Ziv-Av (reporter) 2008-10-08 15:57:48 UTC
I don't think I have any funny cookies settings: all cookies related keys in
about:config are at default values, I don't have similar problems at other
sites, I tried with three different browsers.

Starting with https://wiki... results in exactly the same behaviour.
Comment 5 mike morrison 2008-10-22 12:16:06 UTC
I have the same problem and the same steps to reproduce. 

I tried both http and https with firefox 3.0.3 and seamonkey 1.1.12 under
ubuntu intrepid. No luck :(
Comment 6 Andrew Flegg maemo.org 2008-10-29 21:04:30 UTC
Other users also seem to be experiencing this, although it WFM:

http://www.internettablettalk.com/forums/showthread.php?p=237652#post237472

Additionally there've been users on IRC, and in other ITT threads (links
unavailable at the moment). So it seems to be user-specific somehow.
Comment 7 TerrenceGF 2008-10-29 22:35:07 UTC
I can confirm.

(1) Go to https://wiki.maemo.org/Special:Userlogin
(2) Enter username and password, check (or not) "Remember my login on this
computer, click "Log in" button.
(3) See "Login successful" page with "Return to Main Page", My username is
shown in the upper right corner of the page.
(4) Click on ANY link, I'm no longer logged in and just my IP address is shown
in upper right corner of the page.

I have tried MSIE 7, Firefox 3.0.3, Opera 9.61 on two XP machines as well as
the web browser on my N800.  Cookies enabled, not using privoxy, cache cleaned
out (or not).  Still can't login.  Thus, I can't upload images.

I also tried http:// but still no joy.
Comment 8 Andrew Flegg maemo.org 2008-10-30 10:58:15 UTC
(In reply to comment #7)
> I can confirm.
> 
> (1) Go to https://wiki.maemo.org/Special:Userlogin
> (2) Enter username and password, check (or not) "Remember my login on this
> computer, click "Log in" button.

Your username is? Let's not have any variety on the steps and say this checkbox
is checked.

> (3) See "Login successful" page with "Return to Main Page", My username is
> shown in the upper right corner of the page.

What is the URL shown in the address bar at this point?

> (4) Click on ANY link, I'm no longer logged in and just my IP address is shown
> in upper right corner of the page.

Exactly *which* link did you click? "Return to Main Page"? Once you've clicked
a specific link (and, please, specify it) what is the URL shown in the address
bar?

> I have tried MSIE 7, Firefox 3.0.3, Opera 9.61 on two XP machines as well as
> the web browser on my N800.  Cookies enabled, not using privoxy, cache cleaned
> out (or not).  Still can't login.  Thus, I can't upload images.

In Firefox, once you're at the login successful page & the page you go to next,
can you check the cookies for wiki.maemo.org:

  1) Right click on the page, and select "View Page Info"
  2) Switch to the "Security" tab on the Page Info dialogue box.
  3) Click "View Cookies", list the names of the cookies for "wiki.maemo.org".
     For example, I have mediawiki_mw_Token, ..._UserName, ..._UserId and
     mediawiki_mw__session.
Comment 9 Quim Gil nokia 2008-10-30 11:09:18 UTC
Can it be that old users of the MediaWiki have stored some cookie or something
that new users don't have, and hence the problem?

Since some weeks there is a load balanced server infrastructure and perhaps
this is a side effect of it.
Comment 10 TerrenceGF 2008-10-30 17:12:59 UTC
Okay, I will try to be extremely specific this time.

(1) On Windows XP with SP 3, start Firefox 3.0.3.  Select menu "Tools->Clear
Private Data" to clear everything (cookies, cache, saved passwords).  Restart
Firefox.
(2) Go to https://wiki.maemo.org/Special:Userlogin
(3) Enter username "terrencegf", password "*******", check "Remember my login
on this computer" checkbox, click "Log in" button.
(4) URL is now
https://wiki.maemo.org/index.php?title=Special:Userlogin&action=submitlogin&type=login
. Text is "Login successful".  Upper right corner shows "terrencegf" as user.  
(5) Click "Return to Main Page" link.
(6) URL is now https://wiki.maemo.org/Main_Page . Upper right corner shows my
IP address rather than "terrencegf".  
(7) Click "Upload File" link.
(8) URL is now https://wiki.maemo.org/Special:Upload . Text is "Not logged in.
You must be logged in to upload files."

Tried the above with MSIE 7 and Opera 9.6 with similar results.

Also, I tried clicking on "Upload File" immediately after login (skipping steps
(5) and (6) basically), and got the same results in step (8).
Comment 11 Jarmo Lahtiranta 2008-11-04 14:10:38 UTC
(In reply to comment #9)
> Can it be that old users of the MediaWiki have stored some cookie or something
> that new users don't have, and hence the problem?
> Since some weeks there is a load balanced server infrastructure and perhaps
> this is a side effect of it.

It is certainly not a cookie, because I have the same behaviour no matter where
I log in. I've tried in places where there is no chance I've ever been to
Maemo.org before. I'm guessing the problem is on the server side.
Comment 12 Quim Gil nokia 2008-11-04 14:13:48 UTC
upper case / lower case in your userid? Spaces or non-ASCII strict characters?
New users, old users?

Please provide more data in your reports so we find the pattern.
Comment 13 Jarmo Lahtiranta 2008-11-04 15:34:35 UTC
The behaviour is the same as described on earlier comments. I'm an old user. No
special chars in username, it is all lowercase: naranek
Comment 14 maemo 2008-11-04 16:07:07 UTC
My login name is "z2n".

My password consists of lower-case letters, a non-numeric/non-alphabetic
character, and lower case letters. The password is 9 characters long.

[ I know this is not a strong password...someone else can do the combinatorics
and figure out the degree of entropy. :) ]
Comment 15 Matan Ziv-Av (reporter) 2008-11-04 16:22:10 UTC
My login is matan.
Comment 16 Quim Gil nokia 2008-11-04 23:43:18 UTC
High priority, as agreed at http://wiki.maemo.org/Maemo.org_Sprints/November_08
meeting.
Comment 17 rob miller 2008-11-10 13:50:39 UTC
furthermore, my ip shows as 127.0.0.1.  http://whatsmyip.org/ and
https://www.grc.com/ are able to determine my ip correctly.
Comment 18 Matan Ziv-Av (reporter) 2008-11-10 16:06:13 UTC
(In reply to comment #17)
> furthermore, my ip shows as 127.0.0.1.  http://whatsmyip.org/ and
> https://www.grc.com/ are able to determine my ip correctly.
> 

Accessing wiki using http:// shows IP address 127.0.0.1, but using https://
shows the correct address.
Comment 19 Dave Neary maemo.org 2008-11-10 16:42:34 UTC
Hi Matan,

This is known behaviour, and it's normal for everyone who is not correctly
authentified on the wiki.

Unfortunately, it doesn't get us any closer to an answer.

Dave.
Comment 20 Valério Valério maemo.org 2008-11-20 23:35:37 UTC
I've the same behavior described here.
My user name is "vdvsx" and my password is 12 char's alphanumeric.
When I'm in the "Login successful" page I only have one cookie:
"mediawiki_mw__session".
I'm using FF 3.0.4 in Ubuntu 8.04.
Comment 21 mike morrison 2008-11-24 21:47:11 UTC
(In reply to comment #9)
> Since some weeks there is a load balanced server infrastructure and perhaps
> this is a side effect of it.
> 

perhaps this is the issue (a fix is listed in the comments):

https://bugzilla.wikimedia.org/show_bug.cgi?id=13082
Comment 22 Dave Neary maemo.org 2008-11-28 19:08:12 UTC
Niels? I know you mentioned this to me on IM. Does this apply to our server?

Dave.
Comment 23 Niels Breet maemo.org 2008-12-01 13:45:20 UTC
I am working on this now. I have managed to trigger the behavior with a test
user, so now I can finally do some debugging.
Comment 24 Niels Breet maemo.org 2008-12-01 14:49:49 UTC
I think I have found the problem and have created some code to fix this issue.

Please test if this fixes your issues.
Comment 25 Jarmo Lahtiranta 2008-12-01 15:16:21 UTC
It seems resolved. I can now LOG IN and STAY IN! Thanks!
Comment 26 Dave Neary maemo.org 2008-12-01 15:34:38 UTC
Out of interest (and for future googlers) what was the problem in the end, and
what was the fix?

Dave.
Comment 27 Niels Breet maemo.org 2008-12-01 15:53:51 UTC
We have our own auth module to authenticate against garage. There was a bug
where a local wiki account wasn't created on successful first time
authentication against garage. So at the time the cookies should be set, the
account wasn't known in the mediawiki database. This caused the cookies not to
be set at all.

Resolving as FIXED, please reopen if there are still issues with login.
Comment 28 Andre Klapper maemo.org 2009-02-25 13:29:56 UTC
Bug 4131 sounds very similar to this and is a new one.
Comment 29 Niels Breet maemo.org 2009-02-25 13:34:08 UTC
(In reply to comment #28)
> Bug 4131 sounds very similar to this and is a new one.
> 

No, those are different services and also different servers. Not related.