Bug 3768 - Problems with browser/update
: Problems with browser/update
Status: RESOLVED INVALID
Product: Browser
MicroB engine
: 4.1 (4.2008.23-14)
: N800 Windows
: Low normal (vote)
: ---
Assigned To: unassigned
: microb-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2008-10-04 11:48 UTC by Izreal
Modified: 2008-10-07 16:56 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Izreal (reporter) 2008-10-04 11:48:25 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:Up-date to the latest firmware version, Set your
browser to Mozilla's start-up page, check for plug-in add-ons, try to download
one.

EXPECTED OUTCOME:When closing the browser you will be indicated to up-date
applications, open application manager and check for up-dates. The program will
find an up-date which is the latest OS version to date but, with no data to
load. Either do so or not the updating logo will appear in the right hand
corner and you will not be abe to use your browser from then on. Even after
Flashing the device with earlier versions. When installing a version
successfully you will have a problem with the device connecting to the internet
with WLAN or Mobile devices' Modem.

ACTUAL OUTCOME:
Current Problem
REPRODUCIBILITY:
(once, so far.)

EXTRA SOFTWARE INSTALLED:gweled,Imajik, Garnet,LXDoom, Maemo Prism Port,
MPlayer, Canola 2,Video recorder, Camera, FM Radio, USB Services, Media
Streamer, J-Peg Motion Streamer,Xtournal, Python 2.5, Pythonify 2.5, Maemo Pan.

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1)
Gecko/2008070208 Firefox/3.0.1
Comment 1 Izreal (reporter) 2008-10-04 11:51:37 UTC
Up-dating to the latest Os Firmware version should be ceased immediately, until
this major problem is resolved.
Comment 2 Ryan Abel maemo.org 2008-10-06 06:51:09 UTC
Thanks for reporting this bug.

This bug report isn't very useful because it doesn't describe the bug well. If
you have time and can still reproduce the bug, please read
https://bugs.maemo.org/page.cgi?id=bug-writing.html and add a more useful
description to this bug.
Comment 3 Quim Gil nokia 2008-10-06 08:45:45 UTC
This doesn't look like a critical bug. Please look at
https://bugs.maemo.org/page.cgi?id=fields.html#bug_severity for more
information.
Comment 4 Andre Klapper maemo.org 2008-10-06 12:31:04 UTC
Err... did you file the problem under "Expected outcome"? After reading this
three times I still don't get it.

I tend to close this as INVALID. Izreal, please take a look at the link that
Ryan provided and improve this bug report. Thanks.
Comment 5 Eero Tamminen nokia 2008-10-07 16:56:52 UTC
Setting as INVALID, bug description is incomprehensible/useless.  A proper bug
report describing the actual steps, in the order they were done & with enough
details so that the steps can actually be reproduced and proper description of
what happened as a result should be reported instead.


> Set your browser to Mozilla's start-up page, check for plug-in add-ons, try to download one.

As an example of the steps to reproduce, I tried something that seemed to be
about the above described use-case:
- go to "mozilla.com"
- tap "Add-ons" on the top of the page
- tap "No-script" thing lower at the add-ons page
- Tap "Add to Firefox" button (although my Browser clearly isn't Firefox),
- OK couple of dialogs about the component I'm installing not being
  from Nokia and potentially breaking things

Then browser downloads the extension and asks about browser restart. After I've
closed all browser windows and started a new Browser, the no-script thing is
listed in the "Menu" -> "Tools" -> "Components..." as enabled.

Browser seems to work fine, but the No-script thing itself doesn't seem to have
any effect. This is probably because the device Browser isn't Firefox and the
add-on page states that "Works with Firefox 1.5.0.4" (which UI is AFAIK done
mostly with JavaScript & XUL unlike the UI of the device browser).

-> Either the Mozilla.com www-site or the device browser could maybe check the
add-on component compatibility a bit better before install.