Bug 3750 - symlinks within MyDocs break update of pre-installed-documentation-rx44, SSU fails
: symlinks within MyDocs break update of pre-installed-documentation-rx44, SSU ...
Status: RESOLVED FIXED
Product: Settings and Maintenance
Software updater
: 4.1.2 (4.2008.36-5)
: N810 Maemo
: Medium major with 5 votes (vote)
: 5.0 (1.2009.41-10)
Assigned To: unassigned
: software-update-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-09-30 01:59 UTC by sconf
Modified: 2009-03-26 13:31 UTC (History)
12 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description sconf (reporter) 2008-09-30 01:59:40 UTC
SOFTWARE VERSION: 4.2008.36-5

STEPS TO REPRODUCE THE PROBLEM:
create symbolic link in /home/user/MyDocs/.documents
(maybe remove pre-installed user guide pdf files...) 

EXPECTED OUTCOME:
Seamless Softawe Update from 4.2008.xx to 4.2008.36-5

ACTUAL OUTCOME:
pre-installed-documentation-rx44 package fails to update and last
steps of SSU fail. No errors, user confused but system working.


REPRODUCIBILITY: noticed once 

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
To (apparently) complete SSU I had to 
  -create dummy file in /usr/share/pre-installed/MyDocs/.documents
  -remove symbolic link in /home/user/MyDocs/.documents  

User-Agent:       Mozilla/5.0 (X11; U; Linux armv6l; fi-FI; rv:1.9a6pre)
Gecko/20080828 Firefox/3.0a1 Tablet browser 0.3.7
RX-34+RX-44+RX-48_DIABLO_4.2008.36-5
Comment 1 Andre Klapper maemo.org 2008-09-30 15:03:40 UTC
(In reply to comment #0)
> STEPS TO REPRODUCE THE PROBLEM:
> create symbolic link in /home/user/MyDocs/.documents
> (maybe remove pre-installed user guide pdf files...) 

> OTHER COMMENTS:
> To (apparently) complete SSU I had to 
>   -create dummy file in /usr/share/pre-installed/MyDocs/.documents
>   -remove symbolic link in /home/user/MyDocs/.documents  

So you softlinked /home/user/MyDocs/.documents against
/usr/share/pre-installed/MyDocs/.documents or what? I don't get it.
Explicit steps apreciated, with explicit ln -s commands.

Just to compare, default is:
Nokia-N810-23-14:~# ls -la /home/user/MyDocs/ 
drwxr-xr-x    4 user     users           0 Sep 25 13:36 .documents
Nokia-N810-23-14:~# ls -la /usr/share/pre-installed/MyDocs/
drwxr-xr-x    2 root     root            0 Sep 29 14:09 .
drwxr-xr-x    4 root     root            0 Jun 12 19:05 ..
Comment 2 sconf (reporter) 2008-09-30 16:41:19 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > STEPS TO REPRODUCE THE PROBLEM:
> > create symbolic link in /home/user/MyDocs/.documents
> > (maybe remove pre-installed user guide pdf files...) 
> 
> So you softlinked /home/user/MyDocs/.documents against
> /usr/share/pre-installed/MyDocs/.documents or what? I don't get it.
> Explicit steps apreciated, with explicit ln -s commands.
> 

I had created softlink *in* /home/user/MyDocs/.documents, so in my case it was
   cd /home/user/MyDocs/.documents
   ln -s /media/mmc1/mmapper/Maps .

I had also removed all the pre-installed pdf files from 
/home/user/MyDocs/.documents (mainly User Guides), but I'm not sure if this
affected to problems.  So maybe add
   rm /home/user/MyDocs/.documents/*.pdf
   rm /home/user/MyDocs/.documents/*/*.pdf

Next step: Use Application Manager to try SSU upgrade to 4.2008.36-5
Result: No automatic reboot, no error messages
        Tabled seemed to be functional, but
        "Control-panel->about product" not increased
Next step: tried 
   Manual reboot
   apt-get upgrade
Result: Error from "pre-installed-documentation-rx44", something about
         "/usr/share/pre-installed/MyDocs/.documents/*"
Next step: tried
   touch /usr/share/pre-installed/MyDocs/.documents/foo
   apt-get upgrade
Result: Error from "pre-installed-documentation-rx44", *but* now complains
about
        "/home/user/MyDocs/.documents/Maps"
Next step:
   rm /home/user/MyDocs/.documents/Maps
   apt-get upgrade
Result: No errors, "Control panel-> about product" correct, everything looks
ok.

I hope this helps.  Sorry I can not downgrade my OS and try the steps, but this
is my understanding how it happened.
Comment 3 Kamen Bundev 2008-10-01 09:45:23 UTC
This happened to me in rx34 too.
Comment 4 Pierre Amadio 2008-10-01 10:06:36 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Ryan Abel maemo.org 2008-10-01 12:13:47 UTC
Upping severity. It's leaving people without a working network selection
dialog, and, thus, no internet connectivity (which makes it particularly
difficult to fix the problem).
Comment 6 kenneth 2008-10-01 13:41:11 UTC
one could probably even bump it to critical as it would not surprise me that it
could result in reboot loops, given how brittle the SSU setup seems to be...
Comment 7 Helge Münnich 2008-10-01 22:45:51 UTC
(In reply to comment #2)

> Result: No errors, "Control panel-> about product" correct, everything looks
> ok.
> 
> I hope this helps.  Sorry I can not downgrade my OS and try the steps, but this
> is my understanding how it happened.
> 

Oh yeah, it helps!! Thanks, Thanks, Thanks
Comment 8 sconf (reporter) 2008-10-02 10:11:12 UTC
(In reply to comment #2)
>    apt-get upgrade
> Result: No errors, "Control panel-> about product" correct, everything looks
> ok.
> 
If you are suffering from this problem, there is one more thing to be aware.
I had to use command
     flash-and-reboot
to get kernel updated.  I can just hope there are no more missing steps from
complete SSU update.
Comment 9 Andre Klapper maemo.org 2008-10-02 16:31:37 UTC
Also related to bug 3602?
Comment 10 Helge Münnich 2008-10-02 18:12:43 UTC
(In reply to comment #8)
> (In reply to comment #2)
> >    apt-get upgrade
> > Result: No errors, "Control panel-> about product" correct, everything looks
> > ok.
> > 
> If you are suffering from this problem, there is one more thing to be aware.
> I had to use command
>      flash-and-reboot

What do you mean with the command flash-and-reboot?
A complete re-flashing?

> to get kernel updated.  I can just hope there are no more missing steps from
> complete SSU update.
>
Comment 11 sconf (reporter) 2008-10-03 13:54:03 UTC
(In reply to comment #10)
"flash-and-reboot" in tablet xterm command line.  Not complete re-flash.

It would be great if somebody has a link to information showing further SSU
steps that might be missing after reaching error-free "apt-get dist-upgrade".
Comment 12 tuukka.tolvanen nokia 2008-10-05 20:15:39 UTC
Here's one case:

~ $ ls -lahd MyDocs/.documents
lrwxrwxrwx 1 user users 16 Aug 13 20:38 MyDocs/.documents -> /media/mmc2/docs

Attempted "OS2008 Feature upgrade 1:4.2008.36-5" via appmgr.

~ $ ssh root@127.1 apt-get -f install
...
Setting up pre-installed-documentation-rx44 (5.4) ...
mv: cannot rename '/usr/share/pre-installed/MyDocs/.documents/*': No such file
or directory
dpkg: error processing pre-installed-documentation-rx44 (--configure):
 subprocess post-installation script returned error exit status 1
Comment 13 tuukka.tolvanen nokia 2008-10-05 20:35:51 UTC
    also, symlink .images -> /media/mmc2/foo gives
Setting up pre-installed-documentation-rx44 (5.4) ...
chown: /home/user/MyDocs/.images: Operation not permitted
    and fails.
Comment 14 Vincent Lefevre 2008-10-06 11:48:06 UTC
The new summary probably doesn't cover all the cases. Indeed it has been
reported that the problem also occurs when the directory is empty (but there
may be another condition for the failure). On my N810, SSU failed (I don't know
the real reason, though, since I got no error messages), but I didn't have a
symlink here. However I don't remember if the directory in question was
removed, was empty or had bad permissions: perhaps I did a "chmod 644
MyDocs/.documents/*" (which can probably lead to a failure as well), though
this is a bit unlikely.
Comment 15 Andre Klapper maemo.org 2008-10-07 13:15:46 UTC
If I remember correctly, Marius has already excluded the
pre-installed-documentation from future SSUs.

If so, would this workaround the problem so this report could be closed?
Comment 16 Vincent Lefevre 2008-10-07 13:21:44 UTC
(In reply to comment #15)
> If I remember correctly, Marius has already excluded the
> pre-installed-documentation from future SSUs.

Are pre-installed-images and pre-installed-sounds concerned too?
Comment 17 Quim Gil nokia 2009-01-24 23:05:16 UTC
CCing Ville sinc he is looking at the idea of leaving content folders totally
out of the SSU, which is also related to Bug 2602 (osso-software-version-rx*4
dependencies prevent removing many unnecessary packages)

This is currently the 4th most voted bug (and the 3 most voted belong to the
browser and are being addressed for what I know). 

I think it's already fixed in Diablo (did the last update in December cause any
problems like the ones reported here?) and I'd say it will not be an issue in
Fremantle but I'm not sure.
Comment 18 sconf (reporter) 2009-01-25 23:00:05 UTC
(In reply to comment #17)
> 
> I think it's already fixed in Diablo (did the last update in December cause any
> problems like the ones reported here?) and I'd say it will not be an issue in
> Fremantle but I'm not sure.
>
Bug is still there.  It did not ruin Dec SSU (for me at least), but updating
pre-installed-documentation-rx44 fails. For me the specific issues seems to be
that I have some random symbolic link in directory
"/home/user/MyDocs/.documents". See comment #2.
Comment 19 Marius Vollmer nokia 2009-01-26 10:38:28 UTC
(In reply to comment #18)

> Bug is still there.  It did not ruin Dec SSU (for me at least), but updating
> pre-installed-documentation-rx44 fails.

Correct.  The pre-installed-documentation packages are still shit, but SSU is
not affected anymore since it does not include any package matching
pre-installed-* (because they are shit).
Comment 20 Chris Pitchford 2009-03-19 23:05:36 UTC
I've just unboxed a brand new N810. I've connected it to my wireless lan and
performed an upgrade through the app manager. It's rebooted..All good so far..
I've checked for updates again and it shows one package available:

OS2008 feature upgrade: 4.2008.36-5

It fails to upgrade: 
Application packages missing: pre-installed-documentation-rx44 (=5.4)

This device has been on for 20 minutes and nothing has tampered with..
Comment 21 Ryan Abel maemo.org 2009-03-19 23:19:24 UTC
(In reply to comment #20)
> I've just unboxed a brand new N810. I've connected it to my wireless lan and
> performed an upgrade through the app manager. It's rebooted..All good so far..
> I've checked for updates again and it shows one package available:
> 

Rather than going through each update individually, you should just reflash to
the latest update.[1]


[1]http://wiki.maemo.org/Updating_the_tablet_firmware
Comment 22 Eero Tamminen nokia 2009-03-20 10:18:36 UTC
(In reply to comment #21)
> Rather than going through each update individually, you should just reflash
> to the latest update.[1]

The benefit of reflashing instead of upgrading is that the flash images are
"prelinked" which means that things start marginally faster and use less RAM.

If you have changed the device configuration or have your own data files on it,
just take a backup before reflashing and then restore the settings.

(The benefit of upgrading instead of reflashing is that when reflashing, you
may lose 3rd party applications configuration settings or data if that
application doesn't support the device backup feature.  If something goes wrong
with the upgrade, you may need to reflash anyway.)
Comment 23 Chris Pitchford 2009-03-20 11:27:35 UTC
(In reply to comment #22)
> (In reply to comment #21)
> > Rather than going through each update individually, you should just reflash
> > to the latest update.[1]
> 
> The benefit of reflashing instead of upgrading is that the flash images are
> "prelinked" which means that things start marginally faster and use less RAM.
> 
> If you have changed the device configuration or have your own data files on it,
> just take a backup before reflashing and then restore the settings.
> 
> (The benefit of upgrading instead of reflashing is that when reflashing, you
> may lose 3rd party applications configuration settings or data if that
> application doesn't support the device backup feature.  If something goes wrong
> with the upgrade, you may need to reflash anyway.)
> 

I downloaded the missing package after a bit of googling about the place, after
which the upgrade worked fine!
Could this missing package not be added to the public repository containing the
"dist upgrade" meta package? At least then it would give someone upgrading an
old system the chance to upgrade without error?

I've re-flashed too.. though the "windows" software claimed there was no
upgrade.. Normally I'd use the linux/mac tool, but I only had access to a
windows machine at the time..
Comment 24 Quim Gil nokia 2009-03-26 13:31:02 UTC
In Fremantle the content of /home/user/MyDocs/ is not part of the flashing
image and the SSU updates. Therefore anything you do there won't be touched by
flashing or updating.

Therefore resolving this bug as FIXED in Fremantle.