Bug 3749 - Select connection broken after upgrade
: Select connection broken after upgrade
Status: RESOLVED WORKSFORME
Product: Connectivity
Networking
: 4.1.2 (4.2008.36-5)
: N810 Linux
: Low major with 5 votes (vote)
: ---
Assigned To: unassigned
: networking-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2008-09-30 00:28 UTC by Laurent GUERBY
Modified: 2010-01-10 19:52 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Laurent GUERBY (reporter) 2008-09-30 00:28:15 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
 4.2008.23-14

STEPS TO REPRODUCE THE PROBLEM:
saw icon with packages to update, clicked on it, clicked update all in the app
manager

EXPECTED OUTCOME:
successfull upgrade

ACTUAL OUTCOME:
got a few confusing dialogs (don't remenber) then got back to the app manager
with updates still to be done but disconnected from my wifi. When I click on
the "Select Connection" I get an empty list and "Searching" stays here forever.
Even my predefined GSM connection which usually gets displayed first before
wifi scan completes isn't listed in the list. I rebooted twice but no change.

REPRODUCIBILITY:
(always/sometimes/once)
once?

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Is there a way to relaunch wifi as root from xterm so I can finish this upgrade
without reflashing?

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1)
Gecko/2008072820 Firefox/3.0.1
Comment 1 Laurent GUERBY (reporter) 2008-09-30 02:41:43 UTC
With IRC people help I tried /etc/init.d/networking restart
Then I removed all chinook repo, then apt-get update
then:

Nokia-N810-23-14:~# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies.
  osso-software-version-rx44: Depends: adobe-flashplayer (= 2.51-1) but 2.53-1
is installed
                              Depends: apt (= 0.7.6maemo2) but 0.7.6maemo3 is
installed
                              Depends: browser-neteal (= 0.0.17.1) but 0.0.18-1
is installed
                              Depends: hildon-desktop (= 1:2.0.18-1) but
1:2.0.18-1fix1 is installed
                              Depends: hildon-im-common-virtual-settings (=
3.8.38-1) but 3.8.39-1 is installed
                              Depends: hildon-im-fkb (= 3.8.38-1) but 3.8.39-1
is installed
                              Depends: hildon-im-hwr (= 3.8.38-1) but 3.8.39-1
is installed
                              Depends: hildon-im-scv (= 3.8.38-1) but 3.8.39-1
is installed
                              Depends: hildon-im-thumb-scv (= 3.8.38-1) but
3.8.39-1 is installed
                              Depends: hildon-im-vkb (= 3.8.38-1) but 3.8.39-1
is installed
                              Depends: hildon-im-wc (= 3.8.38-1) but 3.8.39-1
is installed
                              Depends: hildon-input-method (= 1:2.0.2-1) but
1:2.0.4-1 is installed
                              Depends: hildon-input-method-configurator (=
0.0.18-3) but 0.0.19-1 is installed
                              Depends: hildon-input-method-plugins-western (=
3.8.38-1) but 3.8.39-1 is installed
                              Depends: hildon-input-method-widgets (= 3.2.16-1)
but 3.2.18-reversion-part-1 is installed
                              Depends: hildon-task-navigator-bookmarks (=
1:0.13.3-3) but 1:0.13.3-4 is installed
                              Depends: icd2 (= 0.48) but 0.56 is installed
                              Depends: icd2-network-wlan-config (= 0.47) but
0.47-diablo1 is installed
                              Depends: libconic0 (= 0.16) but 0.16-0.1 is
installed
                              Depends: libdbus-glib-1-2 (= 0.74-0osso5) but
0.74-0osso6 is installed
                              Depends: libhildon-im-hwrarea3 (= 3.2.16-1) but
3.2.18-reversion-part-1 is installed
                              Depends: libhildon-im-ui3 (= 1:2.0.2-1) but
1:2.0.4-1 is installed
                              Depends: libhildon-im-vkbrenderer3 (= 3.2.16-1)
but 3.2.18-reversion-part-1 is installed
                              Depends: libhildon-im-wordcompletion3 (=
3.2.16-1) but 3.2.18-reversion-part-1 is installed
                              Depends: libhildon1 (= 2.0.4-1) but 2.0.5-1 is
installed
                              Depends: libhildondesktop0 (= 1:2.0.18-1) but
1:2.0.18-1fix1 is installed
                              Depends: libhildonfm2 (= 1:2.0.5) but 1:2.0.6.1
is installed
                              Depends: libhildonwm0 (= 1:2.0.18-1) but
1:2.0.18-1fix1 is installed
                              Depends: libicd-network-dun (= 0.17) but 1:0.18
is installed
                              Depends: libicd-network-ipv4 (= 0.14) but 0.15 is
installed
                              Depends: libicd-network-wlan (= 0.47) but
0.47-diablo1 is installed
                              Depends: libicd2 (= 0.48) but 0.50 is installed
                              Depends: libloudmouth1-0 (= 1.3.3-0osso4) but
1.3.3-0osso5 is installed
                              Depends: libmodest-dbus-client (= 1.0-2008.23-2)
but 1.0-2008.30-1 is installed
                              Depends: libncurses5 (= 5.4-3.osso4) but 5.5-1mh2
is installed
                              Depends: libnspr4 (= 1.0.4-60.9) but 1.0.4-60.14
is installed
                              Depends: libnss3 (= 1.0.4-60.9) but 1.0.4-60.14
is installed
                              Depends: libnss3-certs (= 1.0.4-60.9) but
1.0.4-60.14 is installed
                              Depends: libsmbclient (= 3.0.23c-1osso9) but
3.0.23c-1osso11 is installed
                              Depends: libtinymail-1.0-0 (= 1.0.0-svn3690) but
1.0.0-svn3725 is installed
                              Depends: libtinymail-camel-1.0-0 (=
1.0.0-svn3690) but 1.0.0-svn3725 is installed
                              Depends: libtinymail-gnomevfs-1.0-0 (=
1.0.0-svn3690) but 1.0.0-svn3725 is installed
                              Depends: libtinymail-maemo-1.0-0 (=
1.0.0-svn3690) but 1.0.0-svn3725 is installed
                              Depends: libtinymailui-1.0-0 (= 1.0.0-svn3690)
but 1.0.0-svn3725 is installed
                              Depends: libtinymailui-gtk-1.0-0 (=
1.0.0-svn3690) but 1.0.0-svn3725 is installed
                              Depends: maemo-launcher (= 0.30-1) but 0.31-3 is
installed
                              Depends: microb-eal (= 0.3.7-1.15) but 0.3.7-1.16
is installed
                              Depends: microb-engine (= 1.0.4-60.9) but
1.0.4-60.14 is installed
                              Depends: modest (= 1.0-2008.23-2) but
1.0-2008.30-1 is installed
                              Depends: modest-search-plugin (= 2007.45.1) but
2008.23.1 is installed
                              Depends: nokia-repository (= 5.6) but 5.7 is
installed
                              Depends: samba-common (= 3.0.23c-1osso9) but
3.0.23c-1osso11 is installed
E: Unmet dependencies. Try using -f.

Any idea?
Comment 2 Laurent GUERBY (reporter) 2008-09-30 02:43:00 UTC
Nokia-N810-23-14:~# apt-cache policy osso-software-version-rx44
osso-software-version-rx44:
  Installed: 1:4.2008.23-14
  Candidate: 1:4.2008.36-5
  Version table:
     1:4.2008.36-5 0
        500 http://catalogue.tableteer.nokia.com ./ Packages
 *** 1:4.2008.23-14 0
        100 /var/lib/dpkg/status
Comment 3 Laurent GUERBY (reporter) 2008-09-30 02:44:44 UTC
Nokia-N810-23-14:~# apt-get dist-upgrade -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies...Done
Calculating upgrade... Failed
The following packages have unmet dependencies.
  hildon-initscripts: Depends: osso-af-startup but it is not going to be
installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by
held packages.
Comment 4 Steve Veltkamp 2008-09-30 04:37:48 UTC
This is critical for those of us who depend on WIFI.

I confirm it happened after recent (late Sep 2008) upgrades

Some in forums, including myself, report that WIFI does connect automatically
to  known access points, but we are unable to search for or access new ones.
I'm about to go on trip, so this makes Tablet no longer Internet Tablet.
Comment 5 Laurent GUERBY (reporter) 2008-09-30 10:55:22 UTC
Playing with apt-get -f I finally managed to finish the upgrade so hopefully
this bug did not force me to reflash.
Comment 6 Andre Klapper maemo.org 2008-09-30 14:14:49 UTC
> got a few confusing dialogs (don't remenber)

Would be very helpful to have the exact dialog strings to track this down.

> Some in forums, including myself, report that WIFI does connect automatically
> to  known access points, but we are unable to search for or access new ones.

Please provide explicit links to forums. The more valuable information we have,
the better.
This only refers to updating from 4.2008.23-14 to 4.2008.36-5 without having
4.2008.30-2 installed?

Steve: Also N810?
Comment 7 Steve Veltkamp 2008-09-30 16:56:38 UTC
I am on Diablo/N810 - not sure of version path because I just followed the
statusbar prompt that there were updates available through Application Manager.

The dialogs I encountered were mostly unable to install missing dependency type
messages of hildon-something, though they led off with a Flash version problem.
One of the  button choices said Install Anyway or Continue, and I did. Note - I
assumed that if it said it couldn't be installed, it would be skipped and
continuing would move on to the next. Another button choice said Cancel, and I
assumed that would cancel the whole update process, which is not what I wanted.

Forum threads I know of are 228677 (Connection Status Bar App Malfunction) and
23958 (Seamless Software Upgrade). Of note in second is that there are those
(Posts 194, 214) who say their system was relatively clean and still have
problem. I did have rotate-modified kernel installed.
Comment 8 Dmitry 2008-10-01 08:26:30 UTC
same problem. N800, Diablo. Ran updates on Sep 30, 2008 with the same failure.
Ended up enabling "automatically connect" in connections preferences so
launching browser connected me to newarest "known" WiFi AP, after which apt was
able to pick things up
Comment 9 Andre Klapper maemo.org 2009-03-30 17:36:07 UTC
So is this still an issue also in 5.2008.43-7 for anybody here?
Comment 10 Andre Klapper maemo.org 2009-07-28 19:20:56 UTC
So is this still an issue also in 5.2008.43-7 for anybody here?
Comment 11 Quim Gil nokia 2009-09-14 08:55:53 UTC
The silence is read as a WORKSFORME.
Comment 12 redpenguinmail 2010-01-10 19:52:26 UTC
(In reply to comment #11)
> The silence is read as a WORKSFORME.
> 

I'm still having this issue, trying every solution here and on other parts of
the Internets.