Bug 3748 - (int-87680/int-142763) Erroneous "Game not started yet" message
(int-87680/int-142763)
: Erroneous "Game not started yet" message
Status: RESOLVED FIXED
Product: Games
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Low minor with 5 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: games-general-bugs
:
: patch
:
:
  Show dependency tree
 
Reported: 2008-09-30 00:00 UTC by luarvique
Modified: 2010-03-15 21:10 UTC (History)
8 users (show)

See Also:


Attachments
proposed patch to hildon-games-wrapper-1.9.4 (1.69 KB, patch)
2009-10-06 23:55 UTC, Javier S. Pedro
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description luarvique (reporter) 2008-09-30 00:00:17 UTC
SOFTWARE VERSION:
4.2008.36-5 but the problem occurs starting with the first Diablo release.

STEPS TO REPRODUCE THE PROBLEM:
Run any game using a standard Maemo game opening screen, start the gameplay.

EXPECTED OUTCOME:
The gameplay will run normally without any extra messages.

ACTUAL OUTCOME:
After a short while (10-15 seconds), the game displays the "Game not started
yet" banner. The banner disappears after a few seconds and does not seem to
affect the gameplay. It is somewhat confusing though.

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2008-09-30 14:53:53 UTC
OK, I start Mahjong from the menu on my N810. And I wait for half a minute -
nothing happens. I press the "Play" button. I wait for another half a minute
and nothing happens. Did I mis something, or can I just not reproduce this?

N810, N800? (Yes, please do use the hardware field. ;-)
Comment 2 luarvique (reporter) 2008-09-30 14:57:02 UTC
(In reply to comment #1)
> OK, I start Mahjong from the menu on my N810. And I wait for half a minute -
> nothing happens. I press the "Play" button. I wait for another half a minute
> and nothing happens. Did I mis something, or can I just not reproduce this?
Ok, it does happen in Mahjong, but let us go with my last use case:

1. Start Tetris (or whatever it is called in Maemo).
2. Immediately start the game, do not wait for half a minute.
3. Play normally for a few minutes (make it 5 minutes to be sure).

Sometime in that period you should see the problem.

> N810, N800? (Yes, please do use the hardware field. ;-)
N810. Don't think it matters though.
Comment 3 Andre Klapper maemo.org 2008-09-30 15:20:18 UTC
Ah. Confirming.
Comment 4 Eero Tamminen nokia 2008-10-06 18:54:12 UTC
Maybe this has something to do with Blocks and Marbles games being SDL programs
whereas e.g. Mahjong and Chess are (I think) Hildon/Gtk programs?

(The launchers for all of these are also Hildon/Gtk)
Comment 5 verhees 2008-10-08 22:08:05 UTC
I can confirm this bug and can tell that it appaers in maemodrac too
Comment 6 luarvique (reporter) 2008-10-08 22:42:26 UTC
(In reply to comment #5)
> I can confirm this bug and can tell that it appaers in maemodrac too
And Maemo Sweeper too.
Comment 7 Andre Klapper maemo.org 2008-11-04 13:45:11 UTC
Getting rid of wrong "Start screen" component -> Marbles.
Comment 8 Andre Klapper maemo.org 2009-04-07 11:25:28 UTC
Fixed for Fremantle.
Comment 9 john 2009-04-22 06:44:01 UTC
Well there's an option here labeled 'Leave as RESOLVED FIXED', but it is the
only option available.

I'm getting this message now every time i try to play marbles.  I have tried
uninstalling, and reinstalling.

I'm puzzled, seeing this bug marked as closed with no fix given.


Nokia N810 Internet Tablet
Internet Tablet OS: maemo Linux based OS2008
Version: 5.2008.43-7

[1|root@Nokia-N810-36-5|~]cat /etc/debian_version
testing/unstable

[1|root@Nokia-N810-36-5|~]uname -a
Linux Nokia-N810-36-5 2.6.21-omap1 #2 Tue Oct 14 11:25:25 EEST 2008 armv6l
unknown

Filename:
pool/maemo4.1.2/free/k/kernel-diablo/kernel-diablo_2.6.21-200842maemo1.2_all.deb

Filename: ./osso-lmarbles_1.5.15-0_armel.deb

I'm in no hurry ... it's just a game.

j
Comment 10 Ryan Abel maemo.org 2009-04-22 10:47:41 UTC
(In reply to comment #9)
> I'm puzzled, seeing this bug marked as closed with no fix given.
> 

The bug is not CLOSED, the bug is RESOLVED, and you'll clearly see that the
Target Milestone is marked as "Fremantle". This means that the fix is in the
code, and will be released with Fremantle.
Comment 11 john 2009-04-22 14:45:58 UTC
Thank you for clarifying.  I did not recognize the word 'Fremantle', and did
not think to check the target milestone.  I appreciate the pointers and will
pay closer attention next time.

:-)
Comment 12 luarvique (reporter) 2009-10-03 23:57:39 UTC
This bug still appears in Fremantle.
Comment 13 john 2009-10-04 00:10:08 UTC
It also appears that Fremantle isn't compatible with the n810 :(
The problem did go away for me though when I re-flashed Diablo.  It would be
nice to have an easier fix if it happens again.

-- 
john
Comment 15 Andre Klapper maemo.org 2009-10-04 01:02:24 UTC
(In reply to comment #12)
> This bug still appears in Fremantle.

In SDK beta 2? Or do you have access to internal versions?
I cannot reproduce it here in the latest internal Fremantle build when running
"Blocks".

(In reply to comment #13)
> It also appears that Fremantle isn't compatible with the n810 :(

For your interest the Mer project aims to provide a community backport of
Fremantle for N8x0 devices. See http://wiki.maemo.org/Mer for more information.
Comment 16 Andre Klapper maemo.org 2009-10-04 15:43:45 UTC
I could reproduce this once in internal 1.2009.40-10 when using DrNokSnes and
playing "Chrono Trigger" (first SNES game I found when googling) - "Game not
started yet" popup is shown after ~15 seconds.
Not happening when restarting it though.

The fix for this was included in osso-games-startup 1.6.14-1+0m5.
SDK beta1 already included 1.6.15-2+0m5.

Javis, osso-games-startup is used by DrNokSnes, right?
Wondering whether this could be a DrNokSnes implementation issue or a platform
issue. I assume the latter, though...
Comment 17 Javier S. Pedro 2009-10-05 01:12:25 UTC
This is probably caused because "the fix" was to essentially create a special
case for "known" SDL games using osso-games-startup: marbles and blocks. 

However, the real issue, which is hildon-games-wrapper not returning a reply to
the game_run method, is not fixed. Ideally, hgw_context_init could do so, since
it pops the initial game_run d-bus method call that spawned the game process.

That means this reopened bug should not only affect DrNokSnes, but also
MaemoDrac and other SDL games using hildon-games-wrapper.
Comment 18 Javier S. Pedro 2009-10-05 01:17:48 UTC
(In reply to comment #17)
> ...hgw_context_init could do so...

Sorry, I meant hgw_context_get_start_command.


Also, this happens on Diablo too, but the banner is hidden because DrNokSnes
doesn't disable Xsp when the banner appears and thus it is left "outside" the
screen.
Comment 19 Andre Klapper maemo.org 2009-10-05 12:23:43 UTC
(In reply to comment #17)
> This is probably caused because "the fix" was to essentially create a special
> case for "known" SDL games using osso-games-startup: marbles and blocks. 

Internal comment is "fixed by not showing banner if SDL game is launched and
DBus method is game_run or game_restart". Don't have access to the patch itself
though. Does that help?
Comment 20 Javier S. Pedro 2009-10-06 23:44:18 UTC
My complain is that the definition of "SDL Game" is too narrow: 

Straight from osso-games-startup as in Fremantle final SDK:
> (!g_strcmp0(service, "com.nokia.osso_lmarbles")) || (!g_strcmp0(service,
> "br.org.indt.maemoblocks")))

The above needs to be removed and the underlying issue fixed in
hildon-games-wrapper.
Comment 21 Javier S. Pedro 2009-10-06 23:55:40 UTC
Created an attachment (id=1401) [details]
proposed patch to hildon-games-wrapper-1.9.4

And this patch tries to fix that, replying to the D-Bus game_run method_call
when hgw_context_get_start_command() is called (or hgw_context_compat_check())
by the game.

It fixes the issue for me in Diablo's Marbles and Blocks, and also Fremantle's
DrNokSnes. Don't have Fremantle games, so please test.
Comment 22 EC 2010-01-05 17:22:54 UTC
I can confirm this bug in Battle Gweled (Fremantle)
Comment 23 Tuomo Tanskanen 2010-01-05 17:28:37 UTC
(In reply to comment #22)
> I can confirm this bug in Battle Gweled (Fremantle)

Also happening with Crazyparking game.
Comment 24 Andre Klapper maemo.org 2010-01-05 17:34:00 UTC
Yes, of course this happens with any game using the osso-games startup. That's
why this bug is already CONFIRMED, but not FIXED.
No need for more confirmations. :)
Comment 25 Tuomo Tanskanen 2010-01-05 18:28:25 UTC
(In reply to comment #24)
> Yes, of course this happens with any game using the osso-games startup. That's
> why this bug is already CONFIRMED, but not FIXED.
> No need for more confirmations. :)

Sorry for the spam then. I figured CONFIRMED would be a real state and that the
bug was REOPENED (-> not CONFIRMED), but reading thru Status help again
reveaved its not that, its !UNCONFIRMED actually. Lesson learnt, I'll STFU now.
Comment 26 Javier S. Pedro 2010-02-01 02:38:22 UTC
Andre: more accurately, the issue is within hildon-games-wrapper, thus it
happens with any game depending on hildon-games-wrapper0 package. Games using
osso-games-startup (this is "the launcher") but not the wrapper are not
affected.

According to apt-cache rdepends hildon-games-wrapper0, the list is:
- drnoksnes (though 1.2.6 onwards doesn't depend on hildon-games-wrapper0 since
I got tired of its many unfixed bugs)
- battlegweled
- crazyparking
- mancala

I suggest you test the patch I made to hildon-games-wrapper (it applies cleanly
to latest versions) and confirm it works.
Comment 27 Andre Klapper maemo.org 2010-02-25 18:19:15 UTC
This has been fixed in package
hildon-games-wrapper 1.9.4-5+0m5
which is part of the internal build version
10.2010.08-12
(Note: 2009/2010 is the year, and the number after is the week.)

I have tested this with Crazy Parking in 10.2010.08-12.
No popup is displayed anymore.

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 28 Andre Klapper maemo.org 2010-03-15 21:10:36 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).