Bug 3728 - (int-125495) Modest reports email username / password incorrect when it is correct
(int-125495)
: Modest reports email username / password incorrect when it is correct
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(1.2009.42-11)
: N810 Maemo
: Medium normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-09-20 10:57 UTC by Matthew Lynch
Modified: 2010-01-14 12:27 UTC (History)
10 users (show)

See Also:


Attachments
log file (61 bytes, text/plain)
2008-11-11 02:26 UTC, Matthew Lynch
Details
New log file created whilst bug reproduced (2.86 KB, text/plain)
2008-11-12 09:17 UTC, Matthew Lynch
Details
Screenshot demonstrating the previous comment (42.01 KB, image/gif)
2009-06-23 10:10 UTC, Lucas Maneos
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Matthew Lynch (reporter) 2008-09-20 10:57:41 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM: frequently, when retrieving email from my
ntlworld.com account, the new email client in the Diablo feature upgeade
displays the account settings with an error.  This only started after the
upgrade to Diablo

EXPECTED OUTCOME: email retrieval with no errors

ACTUAL OUTCOME: reports 'incrrect username/password'

REPRODUCIBILITY: at least once every 3-4 hours
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED: none

OTHER COMMENTS: I can only resolve the problem if I overwrite my password with
the same password!

User-Agent:       Mozilla/5.0 (X11; U; Linux armv6l; en-GB; rv:1.9a6pre)
Gecko/20080716 Firefox/3.0a1 Tablet browser 0.3.7
RX-34+RX-44+RX-48_DIABLO_4.2008.30-2
Comment 1 Andre Klapper maemo.org 2008-09-22 14:27:22 UTC
Thanks for reporting this bug.

> SOFTWARE VERSION:
> (Control Panel > General > About product)

Please enter this information.

> This only started after the upgrade to Diablo

from Chinook, or do you refer to the SSU update?

POP or IMAP?

To debug the connection to the mail server, please start a X Terminal window
and enter
    export "CAMEL_DEBUG"="all"
to enable the debug mode of the mail library. After that, enter
    /usr/bin/maemo-summoner /usr/bin/modest.launch showui > log 2>&1
to start the email application. Then try to connect to the mail server. Attach
the logfile named "log" here (please check for confidential data before
attaching).
Comment 2 Matthew Lynch (reporter) 2008-11-11 01:09:32 UTC
this occurs  both when modest downloads email headers and when opening an email

Is anyone looking into this?
Comment 3 Matthew Lynch (reporter) 2008-11-11 02:08:34 UTC
ok, followed the instructions to create a log file : 

~ $ export "CAMEL_DEBUG"="all"
~ $ usr/bin/maemo-summoner/usr/bin/modest.launch showui > log 2>&1

started modest and the error ocurred

can't find a file named log in file manager, even using search
Comment 4 Matthew Lynch (reporter) 2008-11-11 02:26:31 UTC
Created an attachment (id=1033) [details]
log file

managed to copy it somewhere it can be seen by the Ui, an operation not for the
layman !!
Comment 5 Daniel Martin Yerga 2008-11-11 21:40:46 UTC
(In reply to comment #4)
> Created an attachment (id=1033) [details] [details]
> log file
> 
> managed to copy it somewhere it can be seen by the Ui, an operation not for the
> layman !!
> 

This log isn't useful because you are running the command wrongly:

maemo-summoner /usr/bin/modest.launch showui > log 2>&1

Note the space between maemo-summoner and the rest of the command.

If you want to have the log in a visible directory (for example in the
Documents), run it this way:

maemo-summoner /usr/bin/modest.launch showui > /home/user/.documents/log 2>&1


A bit more on topic, I have seen sometimes Modest says the username/password
incorrect message, but it's only when the imap Gmail server (I use Gmail) isn't
working. But perhaps it's a different problem (a minor problem in my case) than
the one you are having.
Comment 6 Matthew Lynch (reporter) 2008-11-12 09:17:17 UTC
Created an attachment (id=1035) [details]
New log file created whilst bug reproduced

In reading it I notice reference to 'account settings' - the dialog is started
when the error is reported teling me that the username/password is incorrect
Comment 7 Andre Klapper maemo.org 2008-11-20 20:50:52 UTC
/usr/bin/modest[4134]: GLIB WARNING ** default - err: You cancelled when you
had to enter a password

So do you get exactly this popup window too, or how is it labeled?

Is ntlworld.com a public and free webmail service one could get a test account
for?
Comment 8 Matthew Lynch (reporter) 2008-11-20 22:46:20 UTC
(In reply to comment #7)
> /usr/bin/modest[4134]: GLIB WARNING ** default - err: You cancelled when you
> had to enter a password
> 
> So do you get exactly this popup window too, or how is it labeled?
> 
> Is ntlworld.com a public and free webmail service one could get a test account
> for?
> 
Yes the dialog appears, it is labelled "Pop account setting for Ntl" the dialog
that I can call up by editing the account. Prior to it opening, a message
flashes up stating 'User name or password incorrect"

ntlworld.com is a pay subscription service from Virgin Media, one of the
largest UK ISPs.  I doubt the problem is with the service as it appeared
immediately after the upgrade from Chinook to Diablo.  Also, my wife has an
n800 of her own, uses the same ntlworld email account but with Chinook and does
not have this problem.
Comment 9 Andre Klapper maemo.org 2008-12-29 16:37:05 UTC
Is this still an issue in 5.2008.43-7? Modest has received 30 fixes for that
version...

Chinook shipped a completely different Email application.
Comment 10 jkramer 2009-03-14 11:30:53 UTC
I can confirm this bug with an up-to-date OS2008 Diablo install on the N810
with an GMail account. Most of the time it works, but then (without any changes
at the mail account setup) I keeps telling me that the login/password is
incorrect and pops up the settings window. Re-rentering the correct password
does not help. I also deleted the account from the mail client setup and
created it again (with correct login/password), with no effect. It's not a
problem with GMail, since everything works fine with mutt on my notebook at the
same time.
The only thing the helps (sometimes) is a complete restart of the system.
Probably it's enough to kill modest and start it again, but at least for me in
never worked.
Comment 11 Matthew Lynch (reporter) 2009-03-14 14:26:38 UTC
Still happening to my Nokia every time I use it.  It will not go away.  All I
can do is change the last letter in the password 4-5 times before I eventually
get it to allow me to access my email.  This is immensely frustrating and I am
seriously considering junking Nokia next time I buy a tablet purely as a result
of the poor quality so-called 'upgrades' that have been issued since I bought
the machine.

Wish I could go back to the original email client but as a non-techie I've no
idea how to.
Comment 12 Quim Gil nokia 2009-03-20 23:06:50 UTC
I got this error message trying to connect to Gmail. What happened actually was
that the Gmail server was having problems as I couldn't browse mail.google.com
with my laptop. Apparently Modest misinterpreted a weak/no connection with a
wromng password.
Comment 13 Andre Klapper maemo.org 2009-06-23 00:56:39 UTC
Anybody brave and willing to test this again by checking out Modest from git at
https://git.maemo.org/projects/modest/gitweb?p=modest ?
Comment 14 Lucas Maneos 2009-06-23 10:09:07 UTC
(In reply to comment #13)
> Anybody brave and willing to test this again by checking out Modest from git

Sure :-)

Steps to reproduce:

1. Stop the IMAP server (or use iptables to block access to it, etc).
2. Start modest.

Outcome:

A big blue dialog (~ 1/3 of the screen height, full width) with the message
"Unable to connect to <server>.  Server name or port number may be incorrect."
appears.  Tapping on anything or pressing ESC brings up the account details
dialog.

However:
- The message doesn't go away so it's a bit hard to see/edit the account
details.
- The server name or port number cannot be edited anyway (bug 4191).
Comment 15 Lucas Maneos 2009-06-23 10:10:01 UTC
Created an attachment (id=1245) [details]
Screenshot demonstrating the previous comment
Comment 16 Lucas Maneos 2009-06-23 10:19:40 UTC
(In reply to comment #14)
> - The message doesn't go away so it's a bit hard to see/edit the account
> details.

Correction: it does go away, but other non-connectable accounts' banners stay
visible.  In the above case I have two IMAP accounts configured via a perdition
proxy running on localhost, and stopped the proxy.  After cancelling both
accounts' edit dialogs no banners were shown.
Comment 17 Andre Klapper maemo.org 2009-08-31 23:01:47 UTC
*** Bug 5005 has been marked as a duplicate of this bug. ***
Comment 18 Andre Klapper maemo.org 2009-09-16 18:18:48 UTC
This issue has been FIXED in the internal Fremantle version.

Unfortunately this is a WONTFIX for Diablo as Diablo is in maintenance mode and
Nokia will only provide bugfixes for critical issues if at all.
For your interest the Mer project aims to provide a community backport of
Fremantle for N8x0 devices. See http://wiki.maemo.org/Mer for more information.
Comment 19 Lucas Maneos 2009-09-20 17:39:56 UTC
(In reply to comment #18)
> This issue has been FIXED in the internal Fremantle version.

Sounds like this is really "internal", as I can't verify with the public modest
trunk (last commit: Fri Sep 18 16:55:05 2009 +0200)

Steps to reproduce:
1. Stop IMAP server.
2. Start modest and wait a few seconds for it to try to connect.

Outcome:
"User name or password incorrect" banner (goes away after a few seconds) and
IMAP4 account settings dialog where user name, incoming server and port fields
are not editable.
Comment 20 Lucas Maneos 2009-10-12 21:02:20 UTC
*** Bug 5320 has been marked as a duplicate of this bug. ***
Comment 21 Lucas Maneos 2009-10-12 21:04:28 UTC
Still present in 1.2009.41-10.  That /should/ include the fix from 4 weeks ago,
right?
Comment 22 Quim Gil nokia 2009-10-13 12:25:35 UTC
fwiw int-136015 refers to a POP3 account while comment #19 refers to IMAP.
Comment 23 luarvique 2009-10-13 12:54:44 UTC
(In reply to comment #22)
> fwiw int-136015 refers to a POP3 account while comment #19 refers to IMAP.
The problem occurs with either type of accounts, on the latest firmware
(2009.40-10). In addition, POP3 support is generally broken (as in "does not
work once you try mundane things"), but it deserves a separate bug.

As this report is marked "RESOLVED FIXED in 5.0beta2", I suggest someone
reviews it and reopens it for 2009.40-10.
Comment 24 Andre Klapper maemo.org 2009-10-13 13:03:02 UTC
Seems that internal ticket 125495 covers this way better which just got fixed
(not verified yet hence not closing).
Comment 25 Andre Klapper maemo.org 2009-10-19 15:17:13 UTC
According to the internal ticket this is fixed after the week43 release,
however I have my doubts and ask people that have access to internal builds to
please check this and add comments here.
I'll also take a look myself.

The next public release after week 43 (x.2009.43-y) will include this.
Comment 26 Lucas Maneos 2009-10-22 06:16:21 UTC
*** Bug 3424 has been marked as a duplicate of this bug. ***
Comment 27 Andre Klapper maemo.org 2009-10-22 21:41:33 UTC
*** Bug 4024 has been marked as a duplicate of this bug. ***
Comment 28 Andre Klapper maemo.org 2009-11-29 01:11:02 UTC
*** Bug 6395 has been marked as a duplicate of this bug. ***
Comment 29 Andre Klapper maemo.org 2010-01-14 12:27:48 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.