Bug 3726 - (SebaSOFT) libpng: Support for animated PNG backgrounds
(SebaSOFT)
: libpng: Support for animated PNG backgrounds
Status: CLOSED INVALID
Product: Desktop platform
Home
: 4.1.1 (4.2008.30-2)
: All Maemo
: High enhancement with 1 vote (vote)
: ---
Assigned To: unassigned
: home-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-09-18 20:01 UTC by SebaSOFT
Modified: 2009-09-21 11:29 UTC (History)
5 users (show)

See Also:


Attachments
Animated PNG that show if your image viewer supports it (10.98 KB, image/png)
2008-09-18 20:09 UTC, SebaSOFT
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description SebaSOFT (reporter) 2008-09-18 20:01:02 UTC
SOFTWARE VERSION: 4.2008.23-14
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM: Load the animated PNG from this site.
http://people.mozilla.com/~dolske/apng/demo-1.png
Put it in a tablet as the background. If it says DOESN'T SUPPORT then animated
PNG's are not supported.

EXPECTED OUTCOME: The above PNG has 2 frames, so it should appear the second
frame saying DOES SUPPORT.

ACTUAL OUTCOME: DOESN'T SUPPORT

REPRODUCIBILITY:always
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED:none

OTHER COMMENTS:Related links. There is even a patch for libpng.
http://en.wikipedia.org/wiki/APNG
http://www.libmng.com/pub/png/
http://dl.ambiweb.de/mirrors/www.libpng.org/pub/png/pngfaq.html#animation
http://littlesvr.ca/apng/

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/525.13 (KHTML, like Gecko) Chrome/0.2.149.29 Safari/525.13
Comment 1 SebaSOFT (reporter) 2008-09-18 20:09:11 UTC
Created an attachment (id=940) [details]
Animated PNG that show if your image viewer supports it
Comment 2 Andre Klapper maemo.org 2008-09-22 13:40:35 UTC
Enhancement request, even more because APNG is an unofficial extension to the
PNG standard.

With regard to battery life I dislike the idea of supporting this.

4.2008.30-2 ships libpng12-0 1.2.8rel-1osso5 so this requires manual
backporting and a LOT of testing first.
Comment 3 SebaSOFT (reporter) 2008-09-23 18:03:55 UTC
You can always stop animations on screen block. Or even put a checkbox on the
wallpaper setting window (Show animated).

The merge shouldn't be too intrusive as this is another format ans (if you
want) another file extension (apng).

Ovbiously I'm not talking a full motion pictue as background, but a sutil glow
variation of something would be neat.

See:
http://bp1.blogger.com/_iTGXYFIkfkA/RhZGKU7YjKI/AAAAAAAAA_Y/uBG7e6CTpD4/s1600-h/Animated+wallpapers-6.gif
http://bp2.blogger.com/_iTGXYFIkfkA/RhZGhk7YjPI/AAAAAAAABAA/5y_HDBM8gIg/s1600-h/Animated+wallpapers-11.gif
Comment 4 Andre Klapper maemo.org 2008-09-25 16:48:04 UTC
Sigh, I should set enhancement too when I write that.
And as I said: This is not standardized at all. Let's see what we can do...
Comment 5 Eero Tamminen nokia 2008-09-29 18:29:07 UTC
> Put it in a tablet as the background.

Desktop background?  Uh... That gets composited with Task Navigator
and Statusbar, their icons, any of the enabled applets, Home menu
text etc.  This might be reasonable in Image viewer, but not in
Desktop (imagine that and large RSS applet together, *Shudder*)...


> You can always stop animations on screen block.

It should stop also whenever it's not visible.
Comment 6 Quim Gil nokia 2008-12-29 15:38:20 UTC
Setting HIGH visibility for exposure.
Comment 7 Quim Gil nokia 2009-09-21 08:55:41 UTC
This is a good proposal for http://maemo.org/community/brainstorm/ . Please
create a new entry there if you or someone wants to push for it.

The problem is that you want animated backgrounds in the desktop. Animated PNGs
is one potential solution but there might be more.

Resolving this enhancement request as INVALID since it's the best option
available, not because the request is invalid per se,