Bug 3708 - (int-88484) N810 draws excessive power when AP has multiple ESSIDs
(int-88484)
: N810 draws excessive power when AP has multiple ESSIDs
Status: RESOLVED WONTFIX
Product: Connectivity
WiFi
: 4.1.3 (5.2008.43-7)
: N810 Linux
: Low major (vote)
: ---
Assigned To: unassigned
: wifi-bugs
: http://andrew.triumf.ca/reqauth/PSM/
: moreinfo, use-time
:
:
  Show dependency tree
 
Reported: 2008-09-14 11:29 UTC by Andrew Daviel
Modified: 2010-03-10 21:28 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Andrew Daviel (reporter) 2008-09-14 11:29:11 UTC
SOFTWARE VERSION: RX-34+RX-44+RX-48_DIABLO_4.2008.23-14_PR_MR0

If the N810 WiFi is configured to use Power Save mode, when connected to a
Proxim AP4000M which is broadcasting multiple ESSIDs, the N810 consumes power
as if Power Save is not enabled. If the AP4000M broadcasts only one ESSID, the
power consumption is low, as expected. Our organization uses one SSID for
visitors and one for staff, assigning addresses on separate VLANs, so that
turning off SSIDs is not an option.

The URL given lists some network capture files.
Comment 1 Ryan Abel maemo.org 2008-09-14 12:24:09 UTC
(In reply to comment #0)
> SOFTWARE VERSION: RX-34+RX-44+RX-48_DIABLO_4.2008.23-14_PR_MR0
> 

Please remember to update to the latest release before reporting bugs.
Comment 2 Andrew Daviel (reporter) 2008-09-14 13:03:23 UTC
That is the latest version, as per http://tabletsdev.maemo.org/nokia_N810.php
Comment 3 Ryan Abel maemo.org 2008-09-14 16:03:43 UTC
(In reply to comment #2)
> That is the latest version, as per http://tabletsdev.maemo.org/nokia_N810.php
> 

Yes, but it's not the latest release:
http://wiki.maemo.org/Seamless_Software_Update
Comment 4 Andrew Daviel (reporter) 2008-09-14 21:25:48 UTC
The updater was not running; half the time it runs out of space so I have to
remove packages to run it, and it conflicts with my apt configuration (I use
dpkg and apt-get, not the GUI). Anyhow, after removing apache2, the Nokia user
guides and the example files from MyDocs, I now have
RX-48_DIABLO_4.2008.30-2_PR_MR0.
I will be away for a week so won't have a chance till later to see if the
problem persists.
Comment 5 Andre Klapper maemo.org 2008-09-15 14:37:22 UTC
I could not find any internal ticket about Proxim AP4000M, so this is very
likely still valid for 4.2008.30-2.
Comment 6 Andrew Daviel (reporter) 2008-09-17 04:29:27 UTC
just to clarify, aklapper, it is not the AP4000 which draws excessive power, it
is the N810.
Comment 7 Andrew Daviel (reporter) 2008-09-26 21:22:55 UTC
I confirm that the battery discharge rate at my workplace is the same
with RX-48_DIABLO_4.2008.30-2_PR_MR0 as with
RX-34+RX-44+RX-48_DIABLO_4.2008.23-14_PR_MR0

(As per the prompt, the username and password for
http://andrew.triumf.ca/reqauth/PSM/ are both "test")
Comment 8 Kalle Valo nokia 2008-11-04 18:25:25 UTC
I'm guessing that the Proxim is sending multiple beacons in multiple ESSID mode
which confuse the wlan firmware in N810. I would like to see network dump of
the beacons. I think this file would contain what I'm interested:

http://andrew.triumf.ca/reqauth/PSM/mad27.home.test.beacon.cap

But wireshark/tshark cannot read it properly:

$ tshark -r mad27.home.test.beacon.cap | head -5
  1   0.000000              ->              WTAP_ENCAP = 21  
  2   0.000018              ->              WTAP_ENCAP = 21  
  3   0.000032              ->              WTAP_ENCAP = 21  
  4   0.024151              ->              WTAP_ENCAP = 21  
  5   0.075365              ->              WTAP_ENCAP = 21  
$ md5sum mad27.home.test.beacon.cap 
0a49e74b9775a2993edd7d432d4b9a79  mad27.home.test.beacon.cap

Is the file corrupted?

But just to clarify, I would like to see all frames the AP transmits. The
bigger the capture file the better :)
Comment 9 Andrew Daviel (reporter) 2008-11-07 21:38:27 UTC
Works for me. Upgraded my desktop to FC9 since submitting this, but with
wireshark-1.0.3-1.fc9.x86_64

$  tshark -r  /home/andrew/N810/psm/mad27.home.test.beacon.cap|head -5
  1   0.000000 Proxim_7f:5e:71 -> Broadcast    IEEE 802.11 Beacon frame,
SN=1791, FN=0, Flags=........, BI=100, SSID="test"
  2   0.000018 Cisco-Li_77:87:47 -> Broadcast    IEEE 802.11 Beacon frame,
SN=674, FN=0, Flags=........, BI=100, SSID="Home"
  3   0.000032              -> Cisco-Li_77:87:47 (RA) IEEE 802.11
Acknowledgement, Flags=........
  4   0.024151 Proxim_7f:5e:70 -> Broadcast    IEEE 802.11 Beacon frame,
SN=1792, FN=0, Flags=........, BI=100, SSID=Broadcast
  5   0.075365 Proxim_7f:5e:71 -> Broadcast    IEEE 802.11 Beacon frame,
SN=1793, FN=0, Flags=........, BI=100, SSID="test"
b

MD5 checks out:
md5sum /home/andrew/N810/psm/mad27.home.test.beacon.cap
0a49e74b9775a2993edd7d432d4b9a79 
/home/andrew/N810/psm/mad27.home.test.beacon.cap

The laptop I was using for wireless capture was stolen last week. I don't have
a good replacement yet. 

I recall that some versions of wireshark may not understand Prism headers,
which I may have
included because they provide more information.
http://www.802.11mercenary.net/prism-strip/
Comment 10 Andrew Daviel (reporter) 2009-01-13 04:19:48 UTC
I still have the problem.
I have a new laptop capable of capturing wireless traffic if more data is
required.
Comment 11 Andre Klapper maemo.org 2009-03-24 14:17:00 UTC
> But just to clarify, I would like to see all frames the AP transmits. The
> bigger the capture file the better :)

-> moreinfo, though fixing this for Diablo is very unlikely as priorities and
ressources have mostly moved to Fremantle, except for critical Diablo issues.
Comment 12 Andrew Daviel (reporter) 2009-03-24 19:35:04 UTC
(summary was misleading - it's the N810 not the Proxim that draws power)

I can  easily capture all AP data at my workplace, but I do not wish to place
unfiltered data on a public website. Sharing with individuals is OK, if I can
send a password in private mail.

I can configure a Proxim AP on a private network, but it is more difficult as
my PC does not support multiple VLANs properly. Nevertheless, I can do this if
it may lead to a solution.

Will Freemantle be available for the N810 ? If the code base is similar, this
problem may exist there too.
Comment 13 Andre Klapper maemo.org 2009-04-02 15:44:39 UTC
(In reply to comment #12)
> Will Freemantle be available for the N810 ? If the code base is similar, this
> problem may exist there too.

I think the code is a bit different, and providing Fremantle for the N810 might
be complicated, that's why for example Nokia supports the Mer project to fill
the gap. (My point of view; and off-topic for this bugtracker though.)
Comment 14 Andre Klapper maemo.org 2009-12-30 15:51:53 UTC
This report was filed against Maemo4 ("Diablo").
The N900 and Maemo5 ("Fremantle") have been available for some time now.

If you own an N900, we kindly ask you to retest this with Maemo5 if possible,
and update this report by describing whether this still happens and which exact
Maemo5 version you use (Settings > General > About product).

This is unfortunately a WONTFIX for Maemo4 as Maemo4 is in maintenance mode and
Nokia will only provide bugfixes for critical issues if at all, as Nokia
currently seems to concentrate on Maemo5 and future Maemo releases. Hence
without any status updates, this report will be closed within the next months.

Sorry that your issue could not be fixed for Maemo4. For your interest the Mer
project aims to provide a community backport of Maemo5 for 770/N8x0 devices.
See http://wiki.maemo.org/Mer for more information.
Comment 15 Andre Klapper maemo.org 2010-03-10 21:28:03 UTC
Unfortunately we are currently unable to do anything more about this report.
Until more information about its status for Maemo5 is available, I'm resolving
the report as WONTFIX for Maemo4 (Diablo).
Please feel free to reopen this bug if you can still reproduce this in Maemo5.