Bug 3704 - Browserd Leaks Huge Chunks of Memory When Killed
: Browserd Leaks Huge Chunks of Memory When Killed
Status: RESOLVED INVALID
Product: Browser
MicroB engine
: 4.1.1 (4.2008.30-2)
: N810 Maemo
: Medium normal with 1 vote (vote)
: ---
Assigned To: unassigned
: microb-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2008-09-13 12:49 UTC by luarvique
Modified: 2008-09-22 14:33 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description luarvique (reporter) 2008-09-13 12:49:27 UTC
SOFTWARE VERSION:
Latest Diablo release.

STEPS TO REPRODUCE THE PROBLEM:
Start MicroB, load some problematic pages (see
https://bugs.maemo.org/show_bug.cgi?id=3703 for example), kill browserd
manually several times, quit MicroB.

EXPECTED OUTCOME:
The available memory amount (as reported by CPU load applet) should be the same
as before MicroB has been started.

ACTUAL OUTCOME:
The memory amount gradually decreases and very soon the tablet starts running
out of memory and slows to a crawl.

REPRODUCIBILITY:
always

OTHER COMMENTS:
The problem appears to be related to browserd allocating large chunks of shared
memory which (due to Linux shared memory implementation) continue to linger
after browserd is unexpectantly killed.
Comment 1 luarvique (reporter) 2008-09-13 12:56:01 UTC
Software version:
4.2008.30-2
Comment 2 timeless 2008-09-13 23:35:37 UTC
i think you probably want to install:
sp-memusage - memory usage reporting tool
sp-smaps-measure - /proc/pid/smaps snapshot generator

and provide detailed output showing which app is actually spending the memory. 

when a process dies, it's dead<period> it can't leak memory, unless the kernel
or x server leak it.

if the xserver leaks it, that's usually a bug in the xserver.
if the kernel leaks it, then in one case that's a design both in Linux, and
it's not our fault.
Comment 3 timeless 2008-09-15 15:04:39 UTC
design bot[c]h
Comment 4 Eero Tamminen nokia 2008-09-15 15:24:03 UTC
As no useful information was provided (CPU applet doesn't show
the amount of the free system memory accurately enough to be useful
for this bug, there was no info how the supposed browser leakage
was measured etc) and this wasn't reproducible, I would mark this
as INVALID.

sp-memusage package can be installed from the tools repository according
to the instructions here:
  http://maemo.org/development/tools/

It's mem-monitor-smaps script can be used to report device free
memory and process memory usage accurately enough.

Data about shared memory segments (and other system resource) usage changes
can be logged with the tools&scripts in the sp-endurance package.


> (as reported by CPU load applet)

This has (small) memory leaks at least in the process memory usage list.
Comment 5 Andre Klapper maemo.org 2008-09-22 14:33:28 UTC
Closing as INVALID. Please reopen or file a new (clean) ticket when providing
more explicit information as described by Eero.