Bug 3700 - (int-130732) Put signatures not on top in replies (thereby not forcing top-post)
(int-130732)
: Put signatures not on top in replies (thereby not forcing top-post)
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(1.2009.41-10)
: All Maemo
: Low normal with 42 votes (vote)
: 5.0/Community-SSU
Assigned To: unassigned
: modest-bugs
:
: community-fremantle, patch
:
:
  Show dependency tree
 
Reported: 2008-09-12 18:14 UTC by Oskar
Modified: 2011-01-31 15:44 UTC (History)
12 users (show)

See Also:


Attachments
Patch modest_text_utils_quote_plain_text (1.56 KB, patch)
2009-12-19 22:47 UTC, Adam Sjøgen
Details
Updated patch for 3.1.18+0m5 (1.56 KB, patch)
2010-01-14 17:15 UTC, Adam Sjøgen
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Oskar (reporter) 2008-09-12 18:14:17 UTC
SOFTWARE VERSION:
4.2008.330-2

STEPS TO REPRODUCE THE PROBLEM:
Make modest use a signature. Reply to a message.

EXPECTED OUTCOME:
Original message on top, followed by signature.

ACTUAL OUTCOME:
signature on top, followed by original message.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Of course this is the "which posting style is correct" thing; I'm not a
militant fighter against top posting, it's just that *I* never do it. Therefore
I consider it a bug to start each reply with "select signature/edit/cut/scroll
to bottom/edit/paste/scroll up again", and modest is the only client I use that
makes me do this.
I'm happy with any solution, even only having an option in the settings would
do.


User-Agent:       Mozilla/5.0 (X11; U; Linux armv6l; de-DE; rv:1.9a6pre)
Gecko/20080716 Firefox/3.0a1 Tablet browser 0.3.7
RX-34+RX-44+RX-48_DIABLO_4.2008.30-2
Comment 1 Andre Klapper maemo.org 2008-09-15 13:28:33 UTC
SOFTWARE VERSION: 4.2008.30-2

STEPS TO REPRODUCE THE PROBLEM:
1. Go to Tools > Accounts... > Edit > User info > Signature > Edit
2. Set a signature
3. Reply to a message



At least the "-- " signature starting part is missing - good in this case
because some mail applications strip any text following that when replying to a
message (cf. RFC 3676 Section 4.3 about usenet message sigantures).

According to the internal ticket (80646) this is the design decision made, and
as you wrote already the topic is an endless debate. I personally share your
opinion.
Adding an option in the preferences might be OK, but we want to keep the User
Interface as simple as possible, so maybe adding a GConf key that can be edited
by advanced users could be an option.
Comment 2 Neil MacLeod maemo.org 2008-09-15 18:43:06 UTC
(In reply to comment #1)
> Adding an option in the preferences might be OK, but we want
> to keep the User Interface as simple as possible so maybe adding
> a GConf key that can be edited by advanced users could be an option.

Dumbing down the UI will dumb down the application - over reliance on gconf
will make the devices less accessible to those users who are far from being
advanced users but still want the ability to alter basic application
functionality. This bug is about a basic configurable option that should be
supported in the UI.

GConf should only be used for very obscure settings that don't normally need to
be changed by *anyone*. This isn't one of those settings.
Comment 3 Oskar (reporter) 2008-09-15 21:48:59 UTC
(In reply to comment #1)

> At least the "-- " signature starting part is missing - good in this case
> because some mail applications strip any text following that 

Isn't this a bug in itself? Should I ... ? ;)

> Adding an option in the preferences might be OK, but we want to keep the User
> Interface as simple as possible, so maybe adding a GConf key that can be edited
> by advanced users could be an option.

I'm with Neil on this. It's not such an uncommon setting.

Besides, let's not forget that officially for the Diablo user there's no other
way to edit GConf keys than from the command line. I don't see gconf-editor in
the application manager.
Comment 4 Lucas Maneos 2008-09-29 13:47:03 UTC
(In reply to comment #1)

Could we generalise this slightly to an RFE for allowing bottom/interleaved
replying?  Even without a signature present the current behaviour (reply opens
with cursor on a blank line followed by an "----- Original message ------" line
followed by the quoted text) encourages top-posting without trimming and/or
places unnecessary burden on the user who wants to do the Right Thing(TM).

> According to the internal ticket (80646) this is the design decision made, and
> as you wrote already the topic is an endless debate. I personally share your
> opinion.

I think we're all on the same page /here/.  Intentional or not, this is still a
bug IMHO.  Has RFC1855 been mentioned in int-80646?    Even some of the worst
MUAs allow the user to change the default at least.

> Adding an option in the preferences might be OK, but we want to keep the User
> Interface as simple as possible

That doesn't seem like an issue at the moment - there is currently only a
single preference in the Composing settings tab (somewhat defeating the purpose
of having a separate tab in the first place).
Comment 5 Lucas Maneos 2008-09-29 13:49:30 UTC
(In reply to comment #3)
> > At least the "-- " signature starting part is missing - good in this case
> > because some mail applications strip any text following that 
> 
> Isn't this a bug in itself? Should I ... ? ;)

Please do.  While you're at it, modest itself fails to strip signatures from
replies it generates.
Comment 6 Andre Klapper maemo.org 2008-12-22 17:55:35 UTC
Err. Running 5.2008.43-7 this seems to be magically fixed. Signatures are now
at the bottom.
Anybody who can confirm this?

If so, only bug 3941 is still valid (which would otherwise be blocked by this
one).
Comment 7 Neil MacLeod maemo.org 2008-12-22 18:13:10 UTC
(In reply to comment #6)
> Err. Running 5.2008.43-7 this seems to be magically fixed. Signatures are now
> at the bottom.

Oh man, and this is why we need a decent changelog with each release. This
situation only serves to make the current development process look more and
more amatuerish/chaotic, which may or may not be the case but that's certainly
how it appears. :(

Google are putting Maemo to shame with Android (aka "Cupcake"[1]) - they have a
public changelog available even before the firmware is released! ;) + :(

1. http://source.android.com/roadmap/cupcake
Comment 8 Andre Klapper maemo.org 2008-12-22 18:53:44 UTC
(In reply to comment #7)
> (In reply to comment #6)
> Oh man, and this is why we need a decent changelog with each release.

I don't think was changed by purpose, looks more like a side effect to me. So
it wouldn't be part of the ChangeLog anyway I bet. :-P
Comment 9 Andre Klapper maemo.org 2008-12-22 19:09:18 UTC
Yes, this is fixed in 4.1.3 (5.2008.43-7). Confirmed by developers.
Feel free to set to VERIFIED.
Comment 10 Andre Klapper maemo.org 2008-12-22 19:14:49 UTC
... and it's not part of the internal unreadable ChangeLog (
https://bugs.maemo.org/show_bug.cgi?id=2573#c6 ) either, as I had guessed. :-P
Comment 11 Oskar (reporter) 2008-12-22 21:25:33 UTC
(In reply to comment #9)
> Yes, this is fixed in 4.1.3 (5.2008.43-7). Confirmed by developers.
> Feel free to set to VERIFIED.
> 

Cool! One of the best things in *43-7.
Comment 12 Lucas Maneos 2009-07-28 17:20:47 UTC
(In reply to comment #9)
> Yes, this is fixed in 4.1.3 (5.2008.43-7). Confirmed by developers.

But it's back at the top in Fremantle.  Re-open, or file a new bug?
Comment 13 Andre Klapper maemo.org 2009-07-30 19:13:29 UTC
Sigh... Reopening.
As written, this is FIXED in the latest Diablo.
But unfixed in latest Fremantle.
Comment 14 Andre Klapper maemo.org 2009-07-30 20:26:50 UTC
Just dumping my internal ticket here:


Note: This refers to *Replying*, not Forwarding.
It is an ideological debate whether this is a bug or a feature request.

STEPS LEADING TO PROBLEM: 
1. Set a signature in the Modest account settings.
2. Reply to an email.

ACTUAL OUTCOME:
The signature will be put in front of the quoted message, as defined in the
Spec and int-89331.
Quoting from the Spec:
"In the case of a reply or forward, the signature shall appear immediately
above the "Reply" or "Forward" separator"
"This will allow the user to edit or delete the signature prior to transmission
if required."


EXPECTED OUTCOME:
Diablo 5.2008.43-7 used to place the signature at the bottom.

There are two parties in this world:

1. Top-posting. Current Modest Fremantle implementation, and Wikipedia says
   "Top-posting seems to be the most common style in business e-mail
   correspondence." in http://en.wikipedia.org/wiki/Posting_style

   Probably Default in Outlook.

2. Bottom-posting.
   A: No.
   Q: > Shall I answer above my question because I start 
      > reading at the bottom? 

   Default in Thunderbird, Evolution and KMail.
   Thunderbird, Evolution and KMail trim the signature of the 
   message you reply to (everything after "-- "). This means 
   that you will lose anything you have quoted in Modest when 
   replying to that message sent with Modest by using one of 
   these mailers.

   This can be a potential source of frustration, maybe a bigger one than 
   that you forgot to remove the signature (cf. the reasoning in the Spec).

Current Modest implementation means that you expect most users quote the
complete email they respond to, plus that they never ever trim it or comment
anything in there.
These users exist, while other users prefer to follow RFC 1855.

PROPOSAL:

Trying to not get this too controversial and ideologic, I propose to provide an
option in the signature settings.
At least KMail and Evolution provide such an "Insert signature above quoted
text" option and Thunderbird provides a "where to put the cursor" option. I
don't have access to Outlook here.
Comment 15 Andre Klapper maemo.org 2009-07-30 23:03:57 UTC
> 2. Bottom-posting.
>    Default in Thunderbird, Evolution and KMail.

and Gmail according to Jaffa.
Comment 16 Andre Klapper maemo.org 2009-09-24 12:56:15 UTC
So this has been closed as WONTFIX internally as Nokia won't add another option
in the preferences.
Comment 17 Lucas Maneos 2009-09-24 13:33:33 UTC
Sigh... If the only issue is that six settings are one too many, at least
restore the current Diablo behaviour (signature at the bottom, not
configurable).  I can't think of a valid reason why even a top-poster would
want their signature in the middle of the message.
Comment 18 Andre Klapper maemo.org 2009-10-18 20:46:56 UTC
As always - feel free to vote for this... :-/
Comment 19 Adam Sjøgen 2009-12-19 22:47:14 UTC
Created an attachment (id=1803) [details]
Patch modest_text_utils_quote_plain_text

The attached patch inserts the signature after the quoted text when using plain
text - to me it sounds like a reasonable compromise to assume that HTML-users
are top-quoters and plain text-users interleave, rather than adding an explicit
setting.

It is also available in my clone of the modest repository on gitorious.org:

 *
http://gitorious.org/~asjo/modest/asjo-modest/commit/9d9c0e393bc257eee2cc107402cbe9630cd21d2e
Comment 20 Vitaly Repin 2009-12-20 17:08:56 UTC
sergio, any chance to integrate this to N900 version?
Comment 21 Sergio Villar Senin 2009-12-21 11:56:43 UTC
As in bug 2563 I'd like to have some more objective reasons to change it than
"I personally prefer that". I hope you understand it, it's not about "you're
wrong" but I'd like to have a setting most people feel comfortable with.

Adding more settings is not the right way to go at least in Fremantle. We have
to keep modest as much simple as possible. It's one of the basic principles of
the Modest UI. Take a look at how you setup an account, it's pretty easy. So we
cannot have a complex settings dialog with tons of options.

Let's try to know how most of the email clients do this and then we'll evaluate
if it is worth it to change it.
Comment 22 Andre Klapper maemo.org 2009-12-21 12:28:16 UTC
It's not necessarily about preferences here. It's also about losing data as
standard mailers correctly remove what's after the "-- ".

Top-posting. Current Modest Fremantle implementation, and Wikipedia says
   "Top-posting seems to be the most common style in business e-mail
   correspondence." in http://en.wikipedia.org/wiki/Posting_style
   Probably Default in Outlook.

Bottom-posting.
   A: No.
   Q: > Shall I answer above my question because I start 
      > reading at the bottom? 

   Default in Thunderbird, Evolution, KMail, Diablo 5.2008.43-7.
   Thunderbird, Evolution and KMail trim the signature of the 
   message you reply to (everything after "-- "). This means 
   that you will lose anything you have quoted in Modest when 
   replying to that message sent with Modest by using one of 
   these mailers.
   This can be a potential source of frustration, maybe a bigger one than 
   that you forgot to remove the signature (cf. the reasoning in the Spec).

Current Modest implementation means that you expect most users quote the
complete email they respond to, plus that they never ever trim it or comment
anything in there.
These users exist, while other users prefer to follow RFC 1855.


KMail and Evolution provide an "Insert signature above quoted text" option and
Thunderbird provides a "where to put the cursor" option. I don't have access to
Outlook here.
Comment 23 Adam Sjøgen 2009-12-21 23:19:35 UTC
(In reply to comment #21)
> As in bug 2563 I'd like to have some more objective reasons to change it than
> "I personally prefer that". I hope you understand it, it's not about "you're
> wrong" but I'd like to have a setting most people feel comfortable with.

I have tried to provide information about what other programs do with
attribution and signatures in bug 2563#6.

There is no obvious answer, most programs differ slightly and/or let you
configure the behaviour.

> Adding more settings is not the right way to go at least in Fremantle. We have
> to keep modest as much simple as possible. It's one of the basic principles of
> the Modest UI. Take a look at how you setup an account, it's pretty easy. So we
> cannot have a complex settings dialog with tons of options.

I agree with this philosphy of keeping things simple and simply working.

That is why I created a patch to put the signature at the bottom for plain
text, where most people who prefer plain text emails prefer the signature, and
- if need be - to put it at the top on HTML-emails, instead of creating a patch
for a new configuration option.

Another option is to go as Gmail does. Obviously Google has put some thought
into email and email-interfaces.
Comment 24 bugs.maemo.org@falkensweb.com 2009-12-29 01:22:10 UTC
@Sergio: I consider this one of the basic settings that all email clients
should support. It's up there with SMTP server address and spell checking.
Comment 25 Lucas Maneos 2009-12-30 15:00:11 UTC
(In reply to comment #21)
> but I'd like to have a setting most people feel comfortable with.

One obvious test for that would be the number of complaints against the Diablo
5.2008.43-7 behaviour.  Is there an internal bug report about this (there are
no public ones as far as I can tell) or other reason that caused the revert to
signature at the top?  I'm thinking it could be something as simple as the
Fremantle fork happening before the Diablo fix.
Comment 26 Andre Klapper maemo.org 2009-12-30 15:05:15 UTC
(In reply to comment #25)
> or other reason that caused the revert to signature at the top?

Based on experience with weird decisions, my guess is Manager expectations.
Comment 27 Sergio Villar Senin 2010-01-05 12:47:17 UTC
(In reply to comment #26)
> (In reply to comment #25)
> > or other reason that caused the revert to signature at the top?
> 
> Based on experience with weird decisions, my guess is Manager expectations.
> 

Andre is right. There are a lot of managers and all of them have different
expectations.

BTW guys I don't forget you. I asked UI designer and I'm waiting for reply to
apply the patch.
Comment 28 Adam Sjøgen 2010-01-05 23:11:52 UTC
(In reply to comment #27)

> BTW guys I don't forget you. I asked UI designer and I'm waiting for reply to
> apply the patch.

Sounds great.

Will said UI designer share the thoughts and considerations of the evaluation
here, or?
Comment 29 Adam Sjøgen 2010-01-14 17:15:28 UTC
Created an attachment (id=1971) [details]
Updated patch for 3.1.18+0m5
Comment 30 Adam Williamson 2010-11-26 09:51:52 UTC
Just another vote for this (antiquated though the bug appears to be). Does
someone have a side repo somewhere with a patched Modest?

Sergio Villar Senin: I don't understand what you would consider an 'objective
reason' and why 'I am a user of your software and I really desire this
capability' is somehow not a valid reason for you. But let's give it a shot.

I work in F/OSS software development (just like you!) and it's practically
impossible to take part politely in discussions on F/OSS software development
mailing lists by top posting. They simply aren't set up for it. The expected
behaviour is that everyone posts replies either interleaved or at the bottom,
and this is also where the replier's signature lives.

I believe it's easy to demonstrate conclusively that this a better way to have
a detailed conversation over email. Interleaving responses is a much better way
to keep track of what exactly any given bit of text is a response to; by the
time you get three or four layers deep it's just about the *only* way.

Sure, 'in business', top posting has come to be the convention. But 'business'
is *not* the only context an email client is used in. I know Nokia sees N900
users as mostly free beta testing, but on a practical level, the N900 is your
only major source of users at the moment, and most of *those* are software
geeks who work in circles where bottom-posting replies is not just the
convention, but top-posting is heavily frowned upon. Since I got my N900, I
know I have simply chosen not to use it for anything but vital and very short
emails, because it would be rude for me to write emails in the way the N900
forces me to on most of the mailing lists I participate in. It's really just a
massive 'screw you' to most of your existing user base to not at least allow a
configuration setting for this *somewhere*.
Comment 31 Adam Sjøgen 2010-11-27 19:30:05 UTC
(In reply to comment #30)

> Does someone have a side repo somewhere with a patched Modest?

When PR1.2 was released I was unable to upgrade my installation of the SDK and
installing the SDK anew failed for me as well, so I haven't been able to
created a patched modest package.

These days I ssh to my desktop-machine and access email remotely that way.
Comment 32 Andrew Flegg maemo.org 2010-11-27 19:58:09 UTC
the patches here (and for attribution line) are included in the Fremantle
Community SSU, which is currently undergoing testing of its install process.
Comment 33 Adam Williamson 2010-11-27 20:38:54 UTC
Thanks, Andrew! Hadn't heard of the community SSU before but it sounds great.
Have you considered also patching https://bugs.maemo.org/show_bug.cgi?id=3409 ?
That's probably the other big modest wishlist item (at least it's the other big
item on mine).
Comment 34 Adam Williamson 2010-11-27 20:54:17 UTC
Awesome! I just grabbed the Modest from that SSU repo and installed it with
dpkg and it's great - attribution line, quoted text and signature at the
bottom, just the way it should be. thanks.
Comment 35 Andre Klapper maemo.org 2011-01-17 21:39:25 UTC
Internal bug is closed as WONTFIX for Maemo5 - reflecting state here.

MeeGo Handset is where the unstable development is taking place and its
bugtracker is located at https://bugs.meego.com. Note that MeeGo for the Nokia
N900 is unstable and by no means ready for end-users yet.
Comment 36 Andrew Flegg maemo.org 2011-01-18 11:40:14 UTC
(In reply to comment #35)
> Internal bug is closed as WONTFIX for Maemo5 - reflecting state here.

However it is included in the Community SSU
(http://gitorious.org/community-ssu), however Mohammad hasn't merged in the
updated Modest into that project yet.

At what point do we change this to RESOLVED FIXED?

  * Now?
  * When the CSSU "officially" includes Modest in its project?
  * When the CSSU launches for widespread testing?
  * When the CSSU launches for end-users?
  * Never?
Comment 37 Andrew Flegg maemo.org 2011-01-18 17:59:53 UTC
Merged into community-ssu at
http://gitorious.org/community-ssu/modest/commit/4141e740f9a5731f40246fb60ce656a3af28c2e4

A future public update released to the community-ssu-testing repository will
include the fix. Please verify that this new version fixes the bug by marking
this bug report as VERIFIED after the public update has been released and if
you have some time.

Once the community has QAed the release, it will be promoted to the
community-ssu repository. At that point, this issue will be marked as RELEASED.

----
Attempting to define a message as discussed at
http://talk.maemo.org/showthread.php?p=923088#post923088
Comment 38 Andrew Flegg maemo.org 2011-01-18 18:00:49 UTC
(In reply to comment #36)
> 
> At what point do we change this to RESOLVED FIXED?

Discussed at http://talk.maemo.org/showthread.php?p=923088#post923088. Sorry
for the noise.