Bug 3692 - Mailing lists must be re-imported
: Mailing lists must be re-imported
Status: RESOLVED FIXED
Product: maemo.org Website
Profile
: unspecified
: All All
: High normal (vote)
: ---
Assigned To: Ferenc Szekely
: profile-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-09-10 01:27 UTC by Simon Pickering
Modified: 2009-08-26 13:01 UTC (History)
10 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Simon Pickering (reporter) maemo.org 2008-09-10 01:27:13 UTC
The karma list here http://maemo.org/profile/list/ seems to have changed quite
drastically, this may or may not be by design.

Looking at my discussion rating, and that of Quim Gil, this metric appears to
be given little importance now (or at least the scores seem very low for the
amount of discussion). Is this intentional?

If this is by design, then fair enough.
Comment 1 Ryan Abel maemo.org 2008-09-10 01:29:54 UTC
http://maemo.org/profile/view/fanoush/
http://maemo.org/profile/view/generalantilles/

fanoush appears to have 1406 discussion karma now, so clearly the weighting
hasn't really changes. My own discussion karma has also gone up by quite a bit.
Comment 2 Simon Pickering (reporter) maemo.org 2008-09-10 01:39:58 UTC
Yeah sorry I should have been clearer in what I meant, presumably something has
changed in what's measured to calculate that metric.
Comment 3 Quim Gil nokia 2008-10-01 10:43:45 UTC
The change was caused by the fact that multiple email addresses were recognized
for a single user. fanoush got on the top because all his emails in the
maemo.org lists added points to his karma count.
Comment 4 Simon Pickering (reporter) maemo.org 2008-10-01 11:14:35 UTC
I'm happy for Fanoush, and indeed the fact that multiple email addresses are
now considered; what I find odd is that I have 8 points for my Discussion karma
(and you Quim have 6).

I'd assumed this Discussion section gave some rating for emails sent to the
mailing lists (and probably other things as well) and was curious as to why it
seems to have such a low ranking (as I've sent a reasonable number of emails in
my time)? Or is there some date cut-off (i.e. only posts in 2008 are counted),
etc.? Or perhaps this is desired behaviour, in which case I'll not wonder about
it any more.
Comment 5 Quim Gil nokia 2008-10-01 11:45:04 UTC
I see. Reopening then, with a more accurate summary.  :)
Comment 6 Frantisek Dufka maemo.org 2008-10-02 16:18:30 UTC
See also my last comment of bug #2481 pointing to bug #2212 Maybe counts for
each mail address are not added properly and only one (random) count is taken.
Maybe Simon sent 6 mails from different address and only that one counts?

As for the jump - my maemo profile e-mail was different from the one I used for
lists so the jump is because of fixing #2212 and #2481
Comment 7 Simon Pickering (reporter) maemo.org 2008-10-02 16:28:37 UTC
No, it can't be that as I've always used the same email address.
Comment 8 Quim Gil nokia 2008-11-06 07:39:46 UTC
After several weeks stuck at 6 points (when I had hundreds before) now a new
value has appeared: 74

http://maemo.org/profile/view/qgil/
Comment 9 Simon Pickering (reporter) maemo.org 2008-11-06 11:52:12 UTC
Mine's jumped from 8 to 34. An improvement certainly. Do we know how the metric
is calculated? I can count my posts and see if it tallies.
Comment 10 Niels Breet maemo.org 2008-11-11 14:54:05 UTC
We need to add a maemo-community forum too, so those posts are also counted.
Just posting this as a reminder.
Comment 11 Henri Bergius 2008-11-13 19:01:33 UTC
The problem with weird discussion karma was traced to some imported emails
getting assigned to the "deleted" duplicate account of user instead of the
active one. This obviously made those messages not count in karma.

This has been fixed upstream, and needs to be tested and deployed on maemo
environment:

http://trac.midgard-project.org/ticket/511
Comment 12 Henri Bergius 2008-12-03 22:55:52 UTC
Marking as fixed as this will be deployed with Midgard 8.09.3 as soon as it is
out.
Comment 13 Simon Pickering (reporter) maemo.org 2009-02-03 14:35:16 UTC
Re-opening as my Discussion karma is still quite a lot lower than I'd expect.

I've sent >220 emails, the majority to -developers, some to -users and some to
-community (which isn't counted atm, I know).

Yesterday I believe I had 38 discussion karma points, today I have 44
discussion karma points. Firstly, I've not sent any emails since yesterday, so
am not sure why my count has changed, and secondly, I'd expect to have a larger
amount of karma for 200-odd emails (I understand it's one point per email or
thereabouts).

Any ideas what's going on.

I've not changed my email address at any point, all came from the same address
as used on this bugzilla account.
Comment 14 Andrew Flegg maemo.org 2009-02-03 14:37:47 UTC
As another council election is looming, it is important for people's karma
counts to accurately reflect their participation in karma-contributing things.
Comment 15 Andrew Flegg maemo.org 2009-02-04 16:52:59 UTC
Increasing priority after February 2009 sprint meeting.
Comment 16 Andrea Grandi 2009-02-24 23:28:11 UTC
I'm having some problems with my karma and Discussion too. 
In particular: no karma is being counted for my discussions :(

Reading this document: http://wiki.maemo.org/Karma
a user should have 2 points for each email sent in maemo-developers,
maemo-users or maemo-community mailing list. Is it right?

Using Gmail search function, I see that I've:

- 62 messages sent in maemo-developers
- 18 messages sent in maemo-users
- 6 messages sent in maemo-community

(I'm just counting threads, not total messages, so the total messages could be
more...)

following the karma rule, I should have 62+18+6=86, 86*2=172 karma points for
Discussion, but I only have 42 and this value is frozen since a lot of time.

Someone told me I had two accounts ("andy80" and "andreagrandi") with the same
email address (a.grandi@gmail.com). Few days ago I changed the email address of
andreagrandi user from "a.grandi@gmail.com" to "andy80@hotmail.it", but this
didn't fix the problem.

Any idea?
Comment 17 Henri Bergius 2009-05-07 17:46:08 UTC
(In reply to comment #16)
> Someone told me I had two accounts ("andy80" and "andreagrandi") with the same
> email address (a.grandi@gmail.com). Few days ago I changed the email address of
> andreagrandi user from "a.grandi@gmail.com" to "andy80@hotmail.it", but this
> didn't fix the problem.

Now email-to-user matching is done once, when the message is imported into the
discussion forum. To handle the situation described above we would need to
change it so that authorship of old imported messages is re-checked
periodically.
Comment 18 Andrea Grandi 2009-07-22 11:39:25 UTC
The bug is still present, I've some updates to show you:

1) Now I see that each post counts as 1 point (http://wiki.maemo.org/Karma ).
This is ok, but this doesn't work yet.

2) I've just done another search with my GMail account for all emails sent by
a.grandi@gmail.com and direct to maemo-* mailing list. I can get about 160
threads. This means that there are surely more posts from my email account,
because usually I don't send a single message per thread.

3) If you look again to my profile: http://maemo.org/profile/view/andy80/
the Discussion points are just 66. Even if I had sent only 160 email to the
three mailing lists, I should have at least 160 points, don't you think?

So I think the bug is still present :(
Is it so difficoult to fix?

Thanks for your help, best regards.
Comment 19 Niels Breet maemo.org 2009-07-22 13:15:28 UTC
@Andrea As stated in #17, once an email has been imported nothing changes. So
if you change your email or account after the import, the old mails won't be
matched again.

Only new mails will be matched with the new account values.

AFAIK the archive re-check still needs to be implemented.
Comment 20 Andrea Grandi 2009-07-22 13:22:53 UTC
(In reply to comment #19)
> @Andrea As stated in #17, once an email has been imported nothing changes. So
> if you change your email or account after the import, the old mails won't be
> matched again.
> 
> Only new mails will be matched with the new account values.
> 
> AFAIK the archive re-check still needs to be implemented.
> 

What does it mean "Now email-to-user matching is done once, when the message is
imported into the discussion forum." ?

Mailing list messages are imported in talk.maemo.org?

What do you mean with "new mails"? What is the date from we can begin to talk
about "new mails" ? I'm sending a lot of email in these days to
maemo-developers mailing list and the points are always 66. For this reason I
think something is not working.... maybe just a problem with my account?
Comment 21 Simon Pickering (reporter) maemo.org 2009-07-22 20:39:44 UTC
Yes, I'm still suffering too. I have 68 discussion points at the moment but
have sent >200 emails (to maemo-developers mainly).

I did a quick test the other day and sent emails to the maemo-developers list
from both my work email and work webmail, both of them increased my karma count
by one as expected.

I can only assume that some (or lots ;) of my older emails are still not being
counted.

Cheers,


Simon
Comment 22 Andrea Grandi 2009-07-22 20:46:50 UTC
(In reply to comment #21)
> Yes, I'm still suffering too. I have 68 discussion points at the moment but
> have sent >200 emails (to maemo-developers mainly).
> 
> I did a quick test the other day and sent emails to the maemo-developers list
> from both my work email and work webmail, both of them increased my karma count
> by one as expected.

I sent at least two emails today, when I was in the office. All email were sent
by Gmail webmail, so were sent by my address. I don't know at what hour the
karma is updated, but you'll see tomorrow that the points will be always 66 :(
Comment 23 Andrea Grandi 2009-07-23 13:40:19 UTC
I can confirm the bug. Look my profile: http://maemo.org/profile/view/andy80/
same karma points as yesterday :(
And:

- I sent at least 3 emails
- I blogged 1 news and it was "loved" 3 times

result: no karma added. 

Is there any problem with my account or is it a common problem?
Comment 24 Niels Breet maemo.org 2009-07-23 15:32:04 UTC
@Andrea: Karma only gets calculated every few days, this is not something that
updates instantly.

My advice: Chill :)
Comment 25 Andrea Grandi 2009-07-23 15:33:15 UTC
(In reply to comment #24)
> @Andrea: Karma only gets calculated every few days, this is not something that
> updates instantly.
> 
> My advice: Chill :)

if you don't say it, how can I help to test it :D ?!
Ok, let's wait ;)
Comment 26 Simon Pickering (reporter) maemo.org 2009-07-23 19:58:42 UTC
> Ok, let's wait ;)

Not sure waiting is going to fix it for me (as I know recent emails do get
counted), but don't worry, I'm very chilled :)
Comment 27 Henri Bergius 2009-07-30 16:32:02 UTC
Little bit more investigation: in this case the problem is not with karma
algorithm or email matching (68 emails imported from Simon's address match to
68 emails associated with his account). The emails are from between 2008-08-27
and  2009-06-03.

In total maemo.org forums have 25,215 imported emails.
Comment 28 Henri Bergius 2009-07-30 16:48:02 UTC
It appears the mailing lists must be reimported. Current stats:

* maemo-developers in DB: 12618 (22012 in mbox file)
* maemo-users in DB: 10468
* maemo-community in DB: 1869
Comment 29 Andrea Grandi 2009-07-31 10:07:58 UTC
(In reply to comment #28)
> It appears the mailing lists must be reimported. Current stats:
> 
> * maemo-developers in DB: 12618 (22012 in mbox file)
> * maemo-users in DB: 10468
> * maemo-community in DB: 1869

just a question (and maybe a possible starting point to understand why
something is not working): messages are counted only if maemo-* is in the To:
field or even if it's in the Cc: one?
Comment 30 Anderson Lizardo 2009-08-05 15:17:24 UTC
I have the same problem: my e-mails to maemo-developers are not being
accounted, it seems to have been "frozen" several months ago.

Additionally, none of my bugzilla activity is being accounted.

See bug #4864, where I give URLs to some "evidence" that my activity is not
being accounted. Well, except maybe for the wiki edits, that look accurate.
Comment 31 Andrew Flegg maemo.org 2009-08-20 19:23:05 UTC
Ferenc is apparently doing the import now. However, it's *very* annoying that
such a long running job couldn't've been done in a separate database and the
results imported.

The council are currently deciding on summit sponsorships, and to have the
karma list totally askew is an enormous hindrance. What's the ETA for the
process to be completed? And, in future, can such tasks be conducted NOT on the
live database!
Comment 32 Valério Valério maemo.org 2009-08-20 20:47:08 UTC
CC'ing myself
Comment 33 Ferenc Szekely maemo.org 2009-08-25 12:23:40 UTC
(In reply to comment #31)
> Ferenc is apparently doing the import now. However, it's *very* annoying that
> such a long running job couldn't've been done in a separate database and the
> results imported.
> 
> The council are currently deciding on summit sponsorships, and to have the
> karma list totally askew is an enormous hindrance. What's the ETA for the
> process to be completed? And, in future, can such tasks be conducted NOT on the
> live database!
> 
Could have been done if we had a 'live mirror' of the current database. We
don't have such at the moment.
Comment 34 Ferenc Szekely maemo.org 2009-08-26 13:01:27 UTC
The last mail was imported 13 hours ago. Bug is fixed now. The karma points are
being recalculated.