Bug 3677 - Commenting does not work on maemo.org/downloads
: Commenting does not work on maemo.org/downloads
Status: RESOLVED FIXED
Product: maemo.org Website
Downloads
: unspecified
: All Linux
: Low normal (vote)
: ---
Assigned To: Henri Bergius
: downloads@maemo.org
:
:
:
:
  Show dependency tree
 
Reported: 2008-09-04 00:13 UTC by Mikko Vartiainen
Modified: 2008-11-11 14:56 UTC (History)
1 user (show)

See Also:


Attachments
Half-page load on downloads.maemo.org (51.47 KB, image/png)
2008-09-05 13:45 UTC, Andrew Flegg
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Mikko Vartiainen (reporter) 2008-09-04 00:13:53 UTC
STEPS TO REPRODUCE THE PROBLEM:
1. log in to maemo.org
2. goto http://maemo.org/downloads/product/OS2008/phonelink/ (or any other
application)
3. add comment about corrupted .install file (no rating, press save)
4. wait for page loading to finish
5. reload page

EXPECTED OUTCOME:
comment should added 

ACTUAL OUTCOME:
comment is not added

REPRODUCIBILITY:
always



User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1)
Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1
Comment 1 Dave Neary maemo.org 2008-09-05 09:56:22 UTC
Hi,

Have you tried accessing the page through https? I think the problem might be
related to the "No rating" that you give.

I know I have seen this problem periodically myself with one or two projects,
but once I'm logged in and the page loads correctly, I can add a comment no
problem with stars. When I try to add a comment without stars, the resulting
page doesn't have any comments at first, and when I reload, it doesn't include
my comment.

Cheers,
Dave.
Comment 2 Mikko Vartiainen (reporter) 2008-09-05 10:13:23 UTC
I was logged but apparently pasted link when I wasn't (you even can't enter
commenents if you are not logged in). I have tried this ~5 times and giving
rating does not help.
Comment 3 Henri Bergius 2008-09-05 13:38:23 UTC
Looking into the database, it seems the entries *do* get stored but not shown.
Investigating further...
Comment 4 Andrew Flegg maemo.org 2008-09-05 13:44:15 UTC
Confirmed: Went to above URL, logged in, rated as 3 *s and added comment. No
error shown.

Resulting page is only half rendered (screenshot to be attached); revisiting
the HTTPS URL shows no new comment.

Comment also has not shown up on my profile page:

    https://maemo.org/profile/view/jaffa/
Comment 5 Andrew Flegg maemo.org 2008-09-05 13:45:18 UTC
Created an attachment (id=925) [details]
Half-page load on downloads.maemo.org
Comment 6 Henri Bergius 2008-09-05 13:58:11 UTC
All right, more information:

* The comments posted do have metadata.creator set to the GUID of the user
* ...but their metadata.authors and author fields are empty (which is a bug)
* Comments listed on the site are filtered so that only ones with author field
are shown

I'll investigate what causes the author field to be empty and fix it.
Comment 7 Henri Bergius 2008-09-05 14:38:09 UTC
I think the problem is caused by segfaults on the current server. Anyway, this
should help to work around it:

http://trac.midgard-project.org/changeset/17407

I'll apply it to maemo.org later today.
Comment 8 Ryan Abel maemo.org 2008-09-13 13:04:07 UTC
Added a comment and rating to
http://maemo.org/downloads/product/OS2008/fbreader/ about an hour ago without
success.

Reopening
Comment 9 Mikko Vartiainen (reporter) 2008-09-13 13:12:52 UTC
I got two emails that comments were added (with the comment text) to
applications which specify me as the author. Comments have not been added to
web page.

Application which were commented were
http://maemo.org/downloads/product/OS2008/lbreakout2/
http://maemo.org/downloads/product/OS2008/openvpn-applet/
Comment 10 Niels Breet maemo.org 2008-09-15 11:34:58 UTC
I can confirm the bug. Mails get sent, but no entry shows up on the page.
Comment 11 Mikko Vartiainen (reporter) 2008-10-03 03:03:13 UTC
Commenting seems to be back online. Commented fbreader succesfully yesterday
and I am seeing other new comments for many applications too.
Comment 12 Niels Breet maemo.org 2008-11-11 14:56:47 UTC
This bug seems to be fixed. Please reopen if it is still broken.